# Error authentication

**URL:** https://discuss.elastic.co/t/error-authentication/275005
**Category:** Logstash
**Tags:** elastic-stack-security
**Created:** [June 4, 2021, 7:44pm UTC](https://discuss.elastic.co/t/error-authentication/275005 "2021-06-04T19:44:59Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Ilya\_21bA](https://avatars.discourse-cdn.com/v4/letter/i/b77776/32.png) [@Ilya\_21bA](https://discuss.elastic.co/u/Ilya_21bA)
#### Post date: [June 4, 2021, 7:44pm UTC](https://discuss.elastic.co/t/error-authentication/275005/1 "2021-06-04T19:44:59Z")

</div>

`[2021-06-04T22:36:16,657][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified [2021-06-04T22:36:16,704][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.1.1"} [2021-06-04T22:36:20,829][ERROR][logstash.licensechecker.licensereader] Unable to retrieve license information from license server {:message=>"Got response code '401' contacting Elasticsearch at URL 'http://localhost:9200/_xpack'"} [2021-06-04T22:36:20,954][ERROR][logstash.monitoring.internalpipelinesource] Failed to fetch X-Pack information from Elasticsearch. This is likely due to failure to reach a live Elasticsearch cluster. [2021-06-04T22:36:38,782][INFO][logstash.outputs.elasticsearch] Elasticsearch pool URLs updated {:changes=>{:removed=>[], :added=>[http://logstash_internal:xxxxxx@localhost:9200/]}} [2021-06-04T22:36:38,876][WARN][logstash.outputs.elasticsearch] Attempted to resurrect connection to dead ES instance, but got an error. {:url=>"http://logstash_internal:xxxxxx@localhost:9200/", :error_type=>LogStash::Outputs::ElasticSearch::HttpClient::Pool::BadResponseCodeError, :error=>"Got response code '401' contacting Elasticsearch at URL 'http://localhost:9200/'"} [2021-06-04T22:36:38,923][INFO][logstash.outputs.elasticsearch] New Elasticsearch output {:class=>"LogStash::Outputs::ElasticSearch", :hosts=>["//localhost:9200"]} [2021-06-04T22:36:39,001][INFO][logstash.filters.elasticsearch] New ElasticSearch filter client {:hosts=>["localhost:9200"]} [2021-06-04T22:36:39,454][ERROR][logstash.javapipeline] Pipeline aborted due to error {:pipeline_id=>"main", :exception=>#<Elasticsearch::Transport::Transport::Errors::Unauthorized: [401] >, :backtrace=>["C:/ELK/logstash-7.1.1/vendor/bundle/jruby/2.5.0/gems/elasticsearch-transport-5.0.5/lib/elasticsearch/transport/transport/base.rb:202:in `\_\_raise\_transport\_error'", "C:/ELK/logstash-7.1.1/vendor/bundle/jruby/2.5.0/gems/elasticsearch-transport-5.0.5/lib/elasticsearch/transport/transport/base.rb:319:in `perform_request'", "C:/ELK/logstash-7.1.1/vendor/bundle/jruby/2.5.0/gems/elasticsearch-transport-5.0.5/lib/elasticsearch/transport/transport/http/manticore.rb:67:in `perform\_request'", "C:/ELK/logstash-7.1.1/vendor/bundle/jruby/2.5.0/gems/elasticsearch-transport-5.0.5/lib/elasticsearch/transport/client.rb:131:in `perform_request'", "C:/ELK/logstash-7.1.1/vendor/bundle/jruby/2.5.0/gems/elasticsearch-api-5.0.5/lib/elasticsearch/api/actions/ping.rb:20:in `ping'", "C:/ELK/logstash-7.1.1/vendor/bundle/jruby/2.5.0/gems/logstash-filter-elasticsearch-3.6.0/lib/logstash/filters/elasticsearch.rb:192:in `test_connection!'", "C:/ELK/logstash-7.1.1/vendor/bundle/jruby/2.5.0/gems/logstash-filter-elasticsearch-3.6.0/lib/logstash/filters/elasticsearch.rb:74:in `register'", "org/logstash/config/ir/compiler/AbstractFilterDelegatorExt.java:56:in `register'", "C:/ELK/logstash-7.1.1/logstash-core/lib/logstash/java_pipeline.rb:191:in `block in register\_plugins'", "org/jruby/RubyArray.java:1792:in `each'", "C:/ELK/logstash-7.1.1/logstash-core/lib/logstash/java_pipeline.rb:190:in `register\_plugins'", "C:/ELK/logstash-7.1.1/logstash-core/lib/logstash/java\_pipeline.rb:446:in `maybe_setup_out_plugins'", "C:/ELK/logstash-7.1.1/logstash-core/lib/logstash/java_pipeline.rb:203:in `start\_workers'", "C:/ELK/logstash-7.1.1/logstash-core/lib/logstash/java\_pipeline.rb:145:in `run'", "C:/ELK/logstash-7.1.1/logstash-core/lib/logstash/java_pipeline.rb:104:in `block in start'"], :thread=\>"#\<Thread:0x4fee4a5 run\>"}  
[2021-06-04T22:36:39,501][ERROR][logstash.agent] Failed to execute action {:id=\>:main, :action\_type=\>LogStash::ConvergeResult::FailedAction, :message=\>"Could not execute action: PipelineAction::Create, action\_result: false", :backtrace=\>nil}  
[2021-06-04T22:36:40,469][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2021-06-04T22:36:43,969][WARN][logstash.outputs.elasticsearch] Attempted to resurrect connection to dead ES instance, but got an error. {:url=\>"[http://logstash\_internal:xxxxxx@localhost:9200/](http://logstash_internal:xxxxxx@localhost:9200/)", :error\_type=\>LogStash::Outputs::ElasticSearch::HttpClient::Pool::BadResponseCodeError, :error=\>"Got response code '401' contacting Elasticsearch at URL '[http://localhost:9200/](http://localhost:9200/)'"}  
[2021-06-04T22:36:44,908][INFO][logstash.runner] Logstash shut down.`

Please help, the error occurred after restarting the Elastic stack

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [June 7, 2021, 4:17am UTC](https://discuss.elastic.co/t/error-authentication/275005/2 "2021-06-07T04:17:18Z")

</div>

401 means the auth details you are using are incorrect.  
Can you test them via a curl to Elasticsearch?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2021, 4:18am UTC](https://discuss.elastic.co/t/error-authentication/275005/3 "2021-07-05T04:18:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
