# Error calling pipeline when setting the document ID in beats

**URL:** <https://discuss.elastic.co/t/error-calling-pipeline-when-setting-the-document-id-in-beats/272560>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [May 10, 2021, 9:26am UTC](https://discuss.elastic.co/t/error-calling-pipeline-when-setting-the-document-id-in-beats/272560 "2021-05-10T09:26:25Z")\
**Posts on this page:** 1\
**Showing post:** 7

<div class="post-metadata">

**Author:** ![Francisco\_Peralta\_Gu](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/francisco_peralta_gu/32/83575_2.png) [@Francisco\_Peralta\_Gu](https://discuss.elastic.co/u/Francisco_Peralta_Gu)\
**Post date:** [May 10, 2021, 1:30pm UTC](https://discuss.elastic.co/t/error-calling-pipeline-when-setting-the-document-id-in-beats/272560/7 "2021-05-10T13:30:29Z")

</div>

Really the pipeline is not called.

I have tried that configuration and it worked depending on the fields.index value stablished by the add\_fields processor above :

```auto
 - add_fields:
          fields:
            index: dumps

```

That configuration works without the add\_id processor.

I cannot use decode\_xml due to a bug that will be resolved in 7.13 version

> [@Filebeat decode\_xml processor missing](https://discuss.elastic.co/t/filebeat-decode-xml-processor-missing/268915/6):
>
> Hi. Please we need information about if the configuration is applied right or if this is an issue of the module decode\_xml. Thank you!

---

_[View the full topic](https://discuss.elastic.co/t/error-calling-pipeline-when-setting-the-document-id-in-beats/272560)._
