# Error code 403 with RUM agent

**URL:** <https://discuss.elastic.co/t/error-code-403-with-rum-agent/237918>\
**Category:** APM\
**Tags:** rum\
**Created:** [June 20, 2020, 3:03pm UTC](https://discuss.elastic.co/t/error-code-403-with-rum-agent/237918 "2020-06-20T15:03:28Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![stk1](https://avatars.discourse-cdn.com/v4/letter/s/ee59a6/32.png) [@stk1](https://discuss.elastic.co/u/stk1)\
**Post date:** [June 20, 2020, 3:03pm UTC](https://discuss.elastic.co/t/error-code-403-with-rum-agent/237918/1 "2020-06-20T15:03:28Z")

</div>

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text 🙂

**Kibana version** : 7.7

**Elasticsearch version** : 7.7

**APM Server version** : 7.7

**APM Agent language and version** : JavaScript (RUM) Version 5.1

**Browser version** : Chrome 80+

**Original install method (e.g. download page, yum, deb, from source, etc.) and version**: apt

**Fresh install or upgraded from other version?** recently updated from 7.4

**Is there anything special in your setup?** For example, are you using the Logstash or Kafka outputs? Are you using a load balancer in front of the APM Servers? Have you changed index pattern, generated custom templates, changed agent configuration etc.

**Description of the problem including expected versus actual behavior. Please include screenshots (if relevant)**:  
I am having trouble installing the RUM agent along the APM server (Version 7.7). I get an error code 403,  
telling me that RUM is disabled (nothing else, including no complains about missing CORS headers), which is not the case (enabled: true).  
The same error is present in the syslog and journalctl.  
The application and the APM server run on different VMs, both use HTTPS. A Python agent  
is already running in the backend and works fine. I have so far experimented with the  
Access-Control-Allow-Origin header in the APM config, trying \* and the actual origin, both lead to  
a 403 status.

**Steps to reproduce** :  
1.  
2.  
3.

**Errors in browser console (if relevant)**: "forbidden request: RUM endpoint is disabled. Configure the `apm-server.rum` section in apm-server.yml"

**Provide logs and/or server output (if relevant)**:

---

<div class="post-metadata">

**Author:** ![axw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/axw/32/28197_2.png) [@axw](https://discuss.elastic.co/u/axw)\
**Post date:** [June 23, 2020, 2:49am UTC](https://discuss.elastic.co/t/error-code-403-with-rum-agent/237918/2 "2020-06-23T02:49:09Z")

</div>

In the apm-server log, do you see "RUM endpoints disabled."? If you run `apm-server export config`, do you see something like the following in the output?

```auto
apm-server:
    host: localhost:8200
    rum:
        enabled: true
...

```

If it doesn't show up there, that would suggest there's a syntax issue in apm-server.yml.

---

<div class="post-metadata">

**Author:** ![stk1](https://avatars.discourse-cdn.com/v4/letter/s/ee59a6/32.png) [@stk1](https://discuss.elastic.co/u/stk1)\
**Post date:** [June 24, 2020, 8:20am UTC](https://discuss.elastic.co/t/error-code-403-with-rum-agent/237918/3 "2020-06-24T08:20:42Z")

</div>

That was indeed the problem! I disabled the Kibana section further down inside the config and also commented out the kibana at its beginning,so the enabled: false was associated with the rum section. Thank you!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 15, 2020, 4:20am UTC](https://discuss.elastic.co/t/error-code-403-with-rum-agent/237918/4 "2020-07-15T04:20:48Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
