# Error: com.microsoft.sqlserver.jdbc.SQLServerDriver not loaded. Are you sure you've included the correct jdbc driver in :jdbc\_driver\_library?

**URL:** <https://discuss.elastic.co/t/error-com-microsoft-sqlserver-jdbc-sqlserverdriver-not-loaded-are-you-sure-youve-included-the-correct-jdbc-driver-in-jdbc-driver-library/204440>\
**Category:** Logstash\
**Created:** [October 21, 2019, 10:34am UTC](https://discuss.elastic.co/t/error-com-microsoft-sqlserver-jdbc-sqlserverdriver-not-loaded-are-you-sure-youve-included-the-correct-jdbc-driver-in-jdbc-driver-library/204440 "2019-10-21T10:34:57Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![adarsh-c](https://avatars.discourse-cdn.com/v4/letter/a/3ec8ea/32.png) [@adarsh-c](https://discuss.elastic.co/u/adarsh-c)\
**Post date:** [October 21, 2019, 10:34am UTC](https://discuss.elastic.co/t/error-com-microsoft-sqlserver-jdbc-sqlserverdriver-not-loaded-are-you-sure-youve-included-the-correct-jdbc-driver-in-jdbc-driver-library/204440/1 "2019-10-21T10:34:57Z")

</div>

I am using logstash-7.4.0 , jdk-11.0.5 and Microsoft JDBC Driver 7.4 for SQL Server.  
I am getting an jdbc connection issue . Any idea ?

batch.delay"=\>50, "pipeline.max\_inflight"=\>500, :thread=\>"#\<Thread:0x2dcedb2a run\>"}  
[2019-10-21T15:52:48,968][INFO][logstash.outputs.elasticsearch][main] Attempting to install template {:manage\_template=\>{"index\_patterns"=\>"logstash-_", "version"=\>60001, "settings"=\>{"index.refresh\_interval"=\>"5s", "number\_of\_shards"=\>1}, "mappings"=\>{"dynamic\_templates"=\>[{"message\_field"=\>{"path\_match"=\>"message", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false}}}, {"string\_fields"=\>{"match"=\>"_", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false, "fields"=\>{"keyword"=\>{"type"=\>"keyword", "ignore\_above"=\>256}}}}}], "properties"=\>{"@timestamp"=\>{"type"=\>"date"}, "@version"=\>{"type"=\>"keyword"}, "geoip"=\>{"dynamic"=\>true, "properties"=\>{"ip"=\>{"type"=\>"ip"}, "location"=\>{"type"=\>"geo\_point"}, "latitude"=\>{"type"=\>"half\_float"}, "longitude"=\>{"type"=\>"half\_float"}}}}}}}  
[2019-10-21T15:52:49,321][INFO][logstash.javapipeline][main] Pipeline started {"pipeline.id"=\>"main"}  
[2019-10-21T15:52:49,422][INFO][logstash.agent] Pipelines running {:count=\>1, :running\_pipelines=\>[:main], :non\_running\_pipelines=\>}  
[2019-10-21T15:52:49,988][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}  
[2019-10-21T15:52:50,109][ERROR][logstash.inputs.jdbc][main] Failed to load C:\Program Files\sqljdbc\_7.4\enu\mssql-jdbc-7.4.1.jre8.jar {:exception=\>#\<TypeError: failed to coerce jdk.internal.loader.ClassLoaders$AppClassLoader to java.net.URLClassLoader\>}  
[2019-10-21T15:52:50,180][ERROR][logstash.javapipeline][main] A plugin had an unrecoverable error. Will restart this plugin.  
Pipeline\_id:main  
Plugin: \<LogStash::Inputs::Jdbc jdbc\_user=\>"ess", jdbc\_password=\>, statement=\>"SELECT \* FROM [UsersDB].dbo.[Employee]", jdbc\_driver\_library=\>"C:\Program Files\sqljdbc\_7.4\enu\mssql-jdbc-7.4.1.jre8.jar", jdbc\_connection\_string=\>"jdbc:sqlserver://TLTTVMLT123\SQLEXPRESS;user=ess;password=admin123\*;", id=\>"b9d05cd015a29052bcfc052e5878dcf2e65fe1cb6aa0dbdf98ae9d6ece8bb8bf", jdbc\_driver\_class=\>"com.microsoft.sqlserver.jdbc.SQLServerDriver", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_9cf811ba-2763-49c1-be3e-af4fa039eece", enable\_metric=\>true, charset=\>"UTF-8"\>, jdbc\_paging\_enabled=\>false, jdbc\_page\_size=\>100000, jdbc\_validate\_connection=\>false, jdbc\_validation\_timeout=\>3600, jdbc\_pool\_timeout=\>5, sql\_log\_level=\>"info", connection\_retry\_attempts=\>1, connection\_retry\_attempts\_wait\_time=\>0.5, parameters=\>{"sql\_last\_value"=\>1970-01-01 00:00:00 UTC}, last\_run\_metadata\_path=\>"C:\Users\User/.logstash\_jdbc\_last\_run", use\_column\_value=\>false, tracking\_column\_type=\>"numeric", clean\_run=\>false, record\_last\_run=\>true, lowercase\_column\_names=\>true\>  
Error: com.microsoft.sqlserver.jdbc.SQLServerDriver not loaded. Are you sure you've included the correct jdbc driver in :jdbc\_driver\_library?  
Exception: LogStash::ConfigurationError  
Stack: C:/Users/User/Downloads/logstash-7.4.0/logstash-7.4.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:163:in `open_jdbc_connection' C:/Users/User/Downloads/logstash-7.4.0/logstash-7.4.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/plugin_mixins/jdbc/jdbc.rb:221:in`execute\_statement'  
C:/Users/User/Downloads/logstash-7.4.0/logstash-7.4.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/inputs/jdbc.rb:277:in `execute_query' C:/Users/User/Downloads/logstash-7.4.0/logstash-7.4.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/inputs/jdbc.rb:263:in`run'  
C:/Users/User/Downloads/logstash-7.4.0/logstash-7.4.0/logstash-core/lib/logstash/java\_pipeline.rb:314:in `inputworker' C:/Users/User/Downloads/logstash-7.4.0/logstash-7.4.0/logstash-core/lib/logstash/java_pipeline.rb:306:in`block in start\_input'  
[2019-10-21T15:52:51,206][ERROR][logstash.inputs.jdbc][main] Failed to load C:\Program Files\sqljdbc\_7.4\enu\mssql-jdbc-7.4.1.jre8.jar {:exception=\>#\<TypeError: failed to coerce jdk.internal.loader.ClassLoaders$AppClassLoader to java.net.URLClassLoader\>}

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [October 21, 2019, 12:01pm UTC](https://discuss.elastic.co/t/error-com-microsoft-sqlserver-jdbc-sqlserverdriver-not-loaded-are-you-sure-youve-included-the-correct-jdbc-driver-in-jdbc-driver-library/204440/2 "2019-10-21T12:01:55Z")

</div>

> [@adarsh-c](#):
>
> exception=\>#\<TypeError: failed to coerce jdk.internal.loader.ClassLoaders$AppClassLoader to java.net.URLClassLoader\>

Read [this](https://discuss.elastic.co/t/error-unknown-command-logstash/187620/4).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 18, 2019, 12:02pm UTC](https://discuss.elastic.co/t/error-com-microsoft-sqlserver-jdbc-sqlserverdriver-not-loaded-are-you-sure-youve-included-the-correct-jdbc-driver-in-jdbc-driver-library/204440/3 "2019-11-18T12:02:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
