# Error: com.mysql.jdbc.Driver not loaded

**URL:** <https://discuss.elastic.co/t/error-com-mysql-jdbc-driver-not-loaded/181542>\
**Category:** Logstash\
**Created:** [May 17, 2019, 8:14am UTC](https://discuss.elastic.co/t/error-com-mysql-jdbc-driver-not-loaded/181542 "2019-05-17T08:14:42Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![prabhat](https://avatars.discourse-cdn.com/v4/letter/p/b782af/32.png) [@prabhat](https://discuss.elastic.co/u/prabhat)\
**Post date:** [May 17, 2019, 8:14am UTC](https://discuss.elastic.co/t/error-com-mysql-jdbc-driver-not-loaded/181542/1 "2019-05-17T08:14:43Z")

</div>

i am getting this error

[2019-05-17T12:49:58,687][ERROR][logstash.inputs.jdbc] Failed to load C:\Users\shiwani\Downloads\ELK\mysql-connector-java-5.1.47\mysql-connector-java-5.1.47-bin.jar {:exception=\>#\<TypeError: failed to coerce jdk.internal.loader.ClassLoaders$AppClassLoader to java.net.URLClassLoader\>}  
[2019-05-17T12:49:58,696][ERROR][logstash.javapipeline] A plugin had an unrecoverable error. Will restart this plugin.  
Pipeline\_id:main  
Plugin: \<LogStash::Inputs::Jdbc jdbc\_user=\>"root", jdbc\_password=\>, statement=\>"SELECT \* FROM users", jdbc\_driver\_library=\>"C:\Users\shiwani\Downloads\ELK\mysql-connector-java-5.1.47\mysql-connector-java-5.1.47-bin.jar", jdbc\_connection\_string=\>"jdbc:mysql://localhost:3306/ration", id=\>"51233e2f5943938b45ba6f8237494163b8ca46d61d8ae71dbe8ee64a1148c15b", jdbc\_driver\_class=\>"com.mysql.jdbc.Driver", enable\_metric=\>true, codec=\>\<LogStash::Codecs::Plain id=\>"plain\_7d85ef90-cac3-4eec-9c56-500018ee32dc", enable\_metric=\>true, charset=\>"UTF-8"\>, jdbc\_paging\_enabled=\>false, jdbc\_page\_size=\>100000, jdbc\_validate\_connection=\>false, jdbc\_validation\_timeout=\>3600, jdbc\_pool\_timeout=\>5, sql\_log\_level=\>"info", connection\_retry\_attempts=\>1, connection\_retry\_attempts\_wait\_time=\>0.5, parameters=\>{"sql\_last\_value"=\>1970-01-01 00:00:00 UTC}, last\_run\_metadata\_path=\>"C:\Users\shiwani/.logstash\_jdbc\_last\_run", use\_column\_value=\>false, tracking\_column\_type=\>"numeric", clean\_run=\>false, record\_last\_run=\>true, lowercase\_column\_names=\>true\>  
Error: com.mysql.jdbc.Driver not loaded. Are you sure you've included the correct jdbc driver in :jdbc\_driver\_library?  
Exception: LogStash::ConfigurationError  
Stack: C:/Users/shiwani/Downloads/ELK/logstash-7.0.0/logstash-7.0.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:163:in `open_jdbc_connection' C:/Users/shiwani/Downloads/ELK/logstash-7.0.0/logstash-7.0.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/plugin_mixins/jdbc/jdbc.rb:221:in`execute\_statement'  
C:/Users/shiwani/Downloads/ELK/logstash-7.0.0/logstash-7.0.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/inputs/jdbc.rb:277:in `execute_query' C:/Users/shiwani/Downloads/ELK/logstash-7.0.0/logstash-7.0.0/vendor/bundle/jruby/2.5.0/gems/logstash-input-jdbc-4.3.13/lib/logstash/inputs/jdbc.rb:263:in`run'  
C:/Users/shiwani/Downloads/ELK/logstash-7.0.0/logstash-7.0.0/logstash-core/lib/logstash/java\_pipeline.rb:297:in `inputworker' C:/Users/shiwani/Downloads/ELK/logstash-7.0.0/logstash-7.0.0/logstash-core/lib/logstash/java_pipeline.rb:290:in`block in start\_input'  
[2019-05-17T12:49:59,701][ERROR][logstash.inputs.jdbc] Failed to load C:\Users\shiwani\Downloads\ELK\mysql-connector-java-5.1.47\mysql-connector-java-5.1.47-bin.jar {:exception=\>#\<TypeError: failed to coerce jdk.internal.loader.ClassLoaders$AppClassLoader to java.net.URLClassLoader\>}  
[2019-05-17T12:49:59,709][ERROR][logstash.javapipeline] A plugin had an unrecoverable error. Will restart this plugin.

## logstash.conf

input {  
jdbc {  
jdbc\_connection\_string =\> "jdbc:mysql://localhost:3306/ration"  
# The user we wish to execute our statement as  
jdbc\_user =\> "root"  
jdbc\_password =\> ""  
# The path to our downloaded jdbc driver  
jdbc\_driver\_library =\>"C:\Users\shiwani\Downloads\ELK\mysql-connector-java-8.0.16\mysql-connector-java-8.0.16\mysql-connector-java-8.0.16.jar"  
jdbc\_driver\_class =\> "com.mysql.cj.jdbc.Driver"  
# our query  
statement =\> "SELECT \* FROM users"  
}  
}  
output {  
stdout { codec =\> json\_lines }  
elasticsearch {  
hosts =\> "localhost:9200"  
index =\> "users"  
document\_type =\> "user"  
document\_id =\> "%{id}"  
}  
}

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [May 17, 2019, 11:53am UTC](https://discuss.elastic.co/t/error-com-mysql-jdbc-driver-not-loaded/181542/2 "2019-05-17T11:53:26Z")

</div>

Which version of Java are you using? If you are using anything newer than Java 8 can you install Java 8 and see if that works?

---

<div class="post-metadata">

**Author:** ![prabhat](https://avatars.discourse-cdn.com/v4/letter/p/b782af/32.png) [@prabhat](https://discuss.elastic.co/u/prabhat)\
**Post date:** [May 18, 2019, 8:39am UTC](https://discuss.elastic.co/t/error-com-mysql-jdbc-driver-not-loaded/181542/3 "2019-05-18T08:39:35Z")

</div>

I am using java 12 on windows and for mysql i have insatlled xampp

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 15, 2019, 8:41am UTC](https://discuss.elastic.co/t/error-com-mysql-jdbc-driver-not-loaded/181542/4 "2019-06-15T08:41:10Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
