# Error Configuring Email for Watcher Kibana 7.3.2

**URL:** https://discuss.elastic.co/t/error-configuring-email-for-watcher-kibana-7-3-2/264389
**Category:** Kibana
**Tags:** elastic-stack-alerting
**Created:** [February 16, 2021, 8:34am UTC](https://discuss.elastic.co/t/error-configuring-email-for-watcher-kibana-7-3-2/264389 "2021-02-16T08:34:43Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![gobindbirsingh](https://avatars.discourse-cdn.com/v4/letter/g/a87d85/32.png) [@gobindbirsingh](https://discuss.elastic.co/u/gobindbirsingh)
#### Post date: [February 16, 2021, 8:34am UTC](https://discuss.elastic.co/t/error-configuring-email-for-watcher-kibana-7-3-2/264389/1 "2021-02-16T08:34:43Z")

</div>

I am trying to configure email for Watcher in Kibana 7.3.2. According to the article [here](https://www.elastic.co/guide/en/elasticsearch/reference/7.x/actions-email.html#configuring-email), it suggests configuring gmail settings into Elasticsearch.yml as:

xpack.notification.email.account:  
gmail\_account:  
profile: gmail  
smtp:  
auth: true  
starttls.enable: true  
host: [smtp.gmail.com](http://smtp.gmail.com)  
port: 587  
user: [myemail@gmail.com](mailto:myemail@gmail.com)

However, when I save the Elasticsearch.yml file, I receive the following error:

Your changes cannot be applied

\*\* Elasticsearch - 'xpack.watcher.enabled': is not allowed\*  
\*\* Elasticsearch - 'xpack.notification.email.account.gmail\_account': is not allowed\*  
\*\* Elasticsearch - 'xpack.notification.email.account.profile': is not allowed\*  
\*\* Elasticsearch - 'xpack.notification.email.account.smtp': is not allowed\*  
\*\* Elasticsearch - 'xpack.notification.email.account.auth': is not allowed\*  
\*\* Elasticsearch - 'xpack.notification.email.account.starttls.enable': is not allowed\*  
\*\* Elasticsearch - 'xpack.notification.email.account.host': is not allowed\*  
\*\* Elasticsearch - 'xpack.notification.email.account.port': is not allowed\*  
\*\* Elasticsearch - 'xpack.notification.email.account.user': is not allowed\*

I am using Kibana 7.3.2.

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [February 16, 2021, 11:25pm UTC](https://discuss.elastic.co/t/error-configuring-email-for-watcher-kibana-7-3-2/264389/2 "2021-02-16T23:25:02Z")

</div>

Welcome to our community! 😃

> [@gobindbirsingh](#):
>
> However, when I save the Elasticsearch.yml file, I receive the following error:
> 
> Your changes cannot be applied

Can you elaborate a little more on where you see these errors?

---

<div class="post-metadata">

### Author: ![gobindbirsingh](https://avatars.discourse-cdn.com/v4/letter/g/a87d85/32.png) [@gobindbirsingh](https://discuss.elastic.co/u/gobindbirsingh)
#### Post date: [February 24, 2021, 4:44pm UTC](https://discuss.elastic.co/t/error-configuring-email-for-watcher-kibana-7-3-2/264389/3 "2021-02-24T16:44:19Z")

</div>

I am using the Elastic Cloud portal.

Manage--\>Edit Deployment--\>Edit elasticsearch.yml--\>Make changes--\>Save--\>Error

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [February 25, 2021, 2:48am UTC](https://discuss.elastic.co/t/error-configuring-email-for-watcher-kibana-7-3-2/264389/4 "2021-02-25T02:48:47Z")

</div>

Does the documentation here help with the process? [Enable Watcher | Elasticsearch Service Documentation | Elastic](https://www.elastic.co/guide/en/cloud/current/ec-watcher.html)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 25, 2021, 2:49am UTC](https://discuss.elastic.co/t/error-configuring-email-for-watcher-kibana-7-3-2/264389/5 "2021-03-25T02:49:40Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
