# Error connect node elastic 5.4.3 spring boot 2M2 failed to load elasticsearch nodes : org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes are available

**URL:** <https://discuss.elastic.co/t/error-connect-node-elastic-5-4-3-spring-boot-2m2-failed-to-load-elasticsearch-nodes-org-elasticsearch-client-transport-nonodeavailableexception-none-of-the-configured-nodes-are-available/91486>\
**Category:** Elasticsearch\
**Created:** [June 30, 2017, 8:18pm UTC](https://discuss.elastic.co/t/error-connect-node-elastic-5-4-3-spring-boot-2m2-failed-to-load-elasticsearch-nodes-org-elasticsearch-client-transport-nonodeavailableexception-none-of-the-configured-nodes-are-available/91486 "2017-06-30T20:18:05Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![iquirino88](https://avatars.discourse-cdn.com/v4/letter/i/a9a28c/32.png) [@iquirino88](https://discuss.elastic.co/u/iquirino88)\
**Post date:** [June 30, 2017, 8:18pm UTC](https://discuss.elastic.co/t/error-connect-node-elastic-5-4-3-spring-boot-2m2-failed-to-load-elasticsearch-nodes-org-elasticsearch-client-transport-nonodeavailableexception-none-of-the-configured-nodes-are-available/91486/1 "2017-06-30T20:18:06Z")

</div>

Hi guys! I'm new here!

Im trying to connect with elasticsearch using a docker container, and the version 2.0.0.M2 of spring boot(spring-data-elastict-search), with version of elastic 5.4.3;

And throws:

:: Spring Boot :: (v2.0.0.M2)

2017-06-30 17:07:35.304 INFO 13523 --- [main] o.apache.catalina.core.StandardService : Starting service [Tomcat]  
2017-06-30 17:07:35.306 INFO 13523 --- [main] org.apache.catalina.core.StandardEngine : Starting Servlet Engine: Apache Tomcat/8.5.15  
2017-06-30 17:07:35.373 INFO 13523 --- [ost-startStop-1] o.a.c.c.C.[Tomcat].[localhost].[/] : Initializing Spring embedded WebApplicationContext  
2017-06-30 17:07:36.399 INFO 13523 --- [main] o.s.d.e.c.TransportClientFactoryBean : adding transport node : localhost:9300  
2017-06-30 17:07:36.658 ERROR 13523 --- [main] .d.e.r.s.AbstractElasticsearchRepository : failed to load elasticsearch nodes : org.elasticsearch.client.transport.NoNodeAvailableException: None of the configured nodes are available: [{#transport#-1}{RlWUN61vRwCWhZYkuh1TQw}{localhost}{127.0.0.1:9300}]

Docker command:  
docker run -p 9200:9200 -p 9300:9300 -e "http.host=0.0.0.0" -e "transport.host=127.0.0.1" [docker.elastic.co/elasticsearch/elasticsearch:5.4.3](http://docker.elastic.co/elasticsearch/elasticsearch:5.4.3)

My application.yml

spring:  
data:  
elasticsearch:  
cluster-nodes: localhost:9300  
cluster-name: docker-cluster

Did you guys have this kind of problem too?? help me!! 😄

Thanks!!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 28, 2017, 8:18pm UTC](https://discuss.elastic.co/t/error-connect-node-elastic-5-4-3-spring-boot-2m2-failed-to-load-elasticsearch-nodes-org-elasticsearch-client-transport-nonodeavailableexception-none-of-the-configured-nodes-are-available/91486/2 "2017-07-28T20:18:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
