# ERROR CONSULTING/MANAGING RULES - Alerts and Insights

**URL:** <https://discuss.elastic.co/t/error-consulting-managing-rules-alerts-and-insights/378970>\
**Category:** Kibana\
**Tags:** elastic-stack-alerting\
**Created:** [June 6, 2025, 10:14pm UTC](https://discuss.elastic.co/t/error-consulting-managing-rules-alerts-and-insights/378970 "2025-06-06T22:14:37Z")\
**Posts on this page:** 1\
**Showing post:** 18

<div class="post-metadata">

**Author:** ![dudahl](https://avatars.discourse-cdn.com/v4/letter/d/8e8cbc/32.png) [@dudahl](https://discuss.elastic.co/u/dudahl)\
**Post date:** [June 17, 2025, 5:53pm UTC](https://discuss.elastic.co/t/error-consulting-managing-rules-alerts-and-insights/378970/18 "2025-06-17T17:53:38Z")

</div>

> [@stephenb](#):
>
> You can also go into Chrome Dev tools and see what the response is clear the network and hit refresh...

Hello @stephenb, thx for the answer!!

I did what you said and got the following result:

```auto
{
    "statusCode": 400,
    "error": "Bad Request",
    "message": "Error injecting reference into rule params for rule id 4fcb9f70-8014-11ee-b50b-0b6b99edc1f - Could not find reference for kibanaSavedObjectMeta.searchSourceJSON.index"
}

```

searched a little bit more and found two links that may be helpful, even though the first one was closed without resolution:

> [@Error in one alert rule object crashes the rule list](https://discuss.elastic.co/t/error-in-one-alert-rule-object-crashes-the-rule-list/329533):
>
> Hi, After playing around with alerting and browser monitors in uptime, my alert rules page got completely broken. On every request it raises an error similar to: Could not find reference for kibanaSavedObjectMeta.searchSourceJSON.index These errors provide saved object IDs which point to the alerts I've tried to silence right before everything broke down. Is it possible to somehow reanimate/delete alert in this state? So far I've tried the saved objects UI and the API. The UI says there's a …

and

> <https://github.com/elastic/kibana/issues/152960>
>
> \*\*stack version:\*\* 8.6.2
> 
> User is getting a 400 from the \`/internal/alerting/r…ules/\_find\` route with the error message
> 
> Error injecting reference into rule params for rule id \<id\> - 
> Could not find reference for kibanaSavedObjectMeta.searchSourceJSON.index
> 
> Looking the rule saved object, the \`references\` array is empty, but there are indirect references to two expected references in the remaining body of the saved object. So it looks like somehow the references were removed from the saved object.
> 
> That by itself is obviously not good, but the real problem is the 400 from the \`\_find\` call causes the rule list to be displayed empty, when that rule would be in the list. Regardless of internal difficulties with the rule objects, they shouldn't prevent the rule list from being displayed.
> 
> Looks like this may be a changed in behavior in 8.6.2 from 8.5.3. Previously, the user saw 2 "unable to load rule" toasts when displaying rules, but since the upgrade, they only see 1, but also now don't see any rules at all. Presumably there is some other rule with an error (the remaining toast).

---

_[View the full topic](https://discuss.elastic.co/t/error-consulting-managing-rules-alerts-and-insights/378970)._
