# Error consuming weblogic server topic using logstash-input-jms

**URL:** <https://discuss.elastic.co/t/error-consuming-weblogic-server-topic-using-logstash-input-jms/202366>\
**Category:** Logstash\
**Created:** [October 4, 2019, 4:24pm UTC](https://discuss.elastic.co/t/error-consuming-weblogic-server-topic-using-logstash-input-jms/202366 "2019-10-04T16:24:32Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Luis\_Carvalho](https://avatars.discourse-cdn.com/v4/letter/l/e0b2c6/32.png) [@Luis\_Carvalho](https://discuss.elastic.co/u/Luis_Carvalho)\
**Post date:** [October 4, 2019, 4:24pm UTC](https://discuss.elastic.co/t/error-consuming-weblogic-server-topic-using-logstash-input-jms/202366/1 "2019-10-04T16:24:32Z")

</div>

Hi,

I'm using logstash-7.3.2 and config the input with jms plugin to consume a Weblogic JMS topic, but i'm getting a "Unable to resolve 'weblogic.jms.backend.jms'. Resolved 'weblogic.jms.backend'". error.

I already tested the connection to the weblogic server and it's ok.

My settings:

```
input {
jms {
  
  destination => "jms/HELIX-fm-publish-topic"
  pub_sub => true

  # JNDI Settings
  jndi_name => "jms/HELIX-fm-api-factory"
  jndi_context => { 
    'java.naming.factory.initial' => "weblogic.jndi.WLInitialContextFactory"
    'java.naming.provider.url' => "t3://eagleeye.corporativo.pt:3032"
  }
  #Jar files to be imported
  require_jars=> ['/home/nosuser/ELK/logstash-7.3.2/jms_jars/ddmp-wlfullclient-12.2.1.3.jar']
}

```

}

Error:

> [2019-10-04T15:42:55,485][WARN][logstash.inputs.jms] JMS Consumer Died {:exception=\>"Java::WeblogicJmsCommon::JMSException", :exception\_message=\>"[JMSExceptions:045103]While trying to find a topic or a queue, the specific JMS server requested could not be found. The linked exception may contain more information about the reason for failure.", :backtrace=\>["weblogic.jms.dispatcher.DispatcherAdapter.convertToJMSExceptionAndThrow(weblogic/jms/dispatcher/DispatcherAdapter.java:110)", "weblogic.jms.dispatcher.DispatcherAdapter.dispatchSyncNoTran(weblogic/jms/dispatcher/DispatcherAdapter.java:61)", "weblogic.jms.client.JMSSession.createDestination(weblogic/jms/client/JMSSession.java:3192)", "weblogic.jms.client.JMSSession.createQueue(weblogic/jms/client/JMSSession.java:2577)", "weblogic.jms.client.WLSessionImpl.createQueue(weblogic/jms/client/WLSessionImpl.java:938)", "java.lang.reflect.Method.invoke(java/lang/reflect/Method.java:498)", "org.jruby.javasupport.JavaMethod.invokeDirectWithExceptionHandling(org/jruby/javasupport/JavaMethod.java:455)", "org.jruby.javasupport.JavaMethod.invokeDirect(org/jruby/javasupport/JavaMethod.java:316)", "home.nosuser.ELK.logstash\_minus\_7\_dot\_3\_dot\_2.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.jruby\_minus\_jms\_minus\_1\_dot\_3\_dot\_0\_minus\_java.lib.jms.session.create\_destination(/home/nosuser/ELK/logstash-7.3.2/vendor/bundle/jruby/2.5.0/gems/jruby-jms-1.3.0-java/lib/jms/session.rb:199)", "home.nosuser.ELK.logstash\_minus\_7\_dot\_3\_dot\_2.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_input\_minus\_jms\_minus\_3\_dot\_1\_dot\_1\_minus\_java.lib.logstash.inputs.jms.subscriber(/home/nosuser/ELK/logstash-7.3.2/vendor/bundle/jruby/2.5.0/gems/logstash-input-jms-3.1.1-java/lib/logstash/inputs/jms.rb:307)", "home.nosuser.ELK.logstash\_minus\_7\_dot\_3\_dot\_2.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_input\_minus\_jms\_minus\_3\_dot\_1\_dot\_1\_minus\_java.lib.logstash.inputs.jms.run(/home/nosuser/ELK/logstash-7.3.2/vendor/bundle/jruby/2.5.0/gems/logstash-input-jms-3.1.1-java/lib/logstash/inputs/jms.rb:230)", "home.nosuser.ELK.logstash\_minus\_7\_dot\_3\_dot\_2.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_input\_minus\_jms\_minus\_3\_dot\_1\_dot\_1\_minus\_java.lib.logstash.inputs.jms.RUBY$method$run$0$ **VARARGS** (home/nosuser/ELK/logstash\_minus\_7\_dot\_3\_dot\_2/vendor/bundle/jruby/$2\_dot\_5\_dot\_0/gems/logstash\_minus\_input\_minus\_jms\_minus\_3\_dot\_1\_dot\_1\_minus\_java/lib/logstash/inputs//home/nosuser/ELK/logstash-7.3.2/vendor/bundle/jruby/2.5.0/gems/logstash-input-jms-3.1.1-java/lib/logstash/inputs/jms.rb)", "home.nosuser.ELK.logstash\_minus\_7\_dot\_3\_dot\_2.logstash\_minus\_core.lib.logstash.java\_pipeline.inputworker(/home/nosuser/ELK/logstash-7.3.2/logstash-core/lib/logstash/java\_pipeline.rb:309)", "home.nosuser.ELK.logstash\_minus\_7\_dot\_3\_dot\_2.logstash\_minus\_core.lib.logstash.java\_pipeline.RUBY$method$inputworker$0$ **VARARGS** (home/nosuser/ELK/logstash\_minus\_7\_dot\_3\_dot\_2/logstash\_minus\_core/lib/logstash//home/nosuser/ELK/logstash-7.3.2/logstash-core/lib/logstash/java\_pipeline.rb)", "home.nosuser.ELK.logstash\_minus\_7\_dot\_3\_dot\_2.logstash\_minus\_core.lib.logstash.java\_pipeline.start\_input(/home/nosuser/ELK/logstash-7.3.2/logstash-core/lib/logstash/java\_pipeline.rb:302)", "org.jruby.RubyProc.call(org/jruby/RubyProc.java:295)", "org.jruby.RubyProc.call(org/jruby/RubyProc.java:274)", "org.jruby.RubyProc.call(org/jruby/RubyProc.java:270)", "java.lang.Thread.run(java/lang/Thread.java:748)"], :root\_cause=\>{:exception=\>"Java::JavaxNaming::NameNotFoundException", :exception\_message=\>"Unable to resolve 'weblogic.jms.backend.jms'. Resolved 'weblogic.jms.backend'"}}

Can someone help me?

Thanks,  
LC

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 1, 2019, 4:24pm UTC](https://discuss.elastic.co/t/error-consuming-weblogic-server-topic-using-logstash-input-jms/202366/2 "2019-11-01T16:24:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
