# Error: Could not create the Java Virtual Machine. ES won't start

**URL:** <https://discuss.elastic.co/t/error-could-not-create-the-java-virtual-machine-es-wont-start/317581>\
**Category:** Elasticsearch\
**Created:** [October 27, 2022, 3:31am UTC](https://discuss.elastic.co/t/error-could-not-create-the-java-virtual-machine-es-wont-start/317581 "2022-10-27T03:31:46Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![rrrrrrrrrrr](https://avatars.discourse-cdn.com/v4/letter/r/50afbb/32.png) [@rrrrrrrrrrr](https://discuss.elastic.co/u/rrrrrrrrrrr)\
**Post date:** [October 27, 2022, 3:31am UTC](https://discuss.elastic.co/t/error-could-not-create-the-java-virtual-machine-es-wont-start/317581/1 "2022-10-27T03:31:46Z")

</div>

Hello,

I've tried to follow this step [https://discuss.elastic.co/t/elasticsearch-logs-are-getting-piled-up-in-var-log-elasticsearch-path-how-to-cater-to-this-problem/186039](https://discuss.elastic.co/t/elasticsearch-logs-are-getting-piled-up-in-var-log-elasticsearch-path-how-to-cater-to-this-problem/186039) to do the log rotation but when I tried to restart the elasticsearch It cannot start anymore.

Please hep. Thank you. I'm not really sure what to do since I just followed the steps given.

```auto
Oct 27 11:26:26 - systemd-entrypoint[3571565]: Error: Could not create the Java Virtual Machine.
Oct 27 11:26:26 - systemd-entrypoint[3571565]: Error: A fatal exception has occurred. Program will exit.
Oct 27 11:26:26 - systemd-entrypoint[3571565]: at org.elasticsearch.tools.launchers.JvmOption.flagsFinal(JvmOption.java:119)
Oct 27 11:26:26 - systemd-entrypoint[3571565]: at org.elasticsearch.tools.launchers.JvmOption.findFinalOptions(JvmOption.java:81)
Oct 27 11:26:26 - systemd-entrypoint[3571565]: at org.elasticsearch.tools.launchers.JvmErgonomics.choose(JvmErgonomics.java:38)
Oct 27 11:26:26 - systemd-entrypoint[3571565]: at org.elasticsearch.tools.launchers.JvmOptionsParser.jvmOptions(JvmOptionsParser.java:135)
Oct 27 11:26:26 - systemd-entrypoint[3571565]: at org.elasticsearch.tools.launchers.JvmOptionsParser.main(JvmOptionsParser.java:86)

```

---

<div class="post-metadata">

**Author:** ![rrrrrrrrrrr](https://avatars.discourse-cdn.com/v4/letter/r/50afbb/32.png) [@rrrrrrrrrrr](https://discuss.elastic.co/u/rrrrrrrrrrr)\
**Post date:** [October 27, 2022, 3:52am UTC](https://discuss.elastic.co/t/error-could-not-create-the-java-virtual-machine-es-wont-start/317581/2 "2022-10-27T03:52:24Z")

</div>

Additional information is that we're using 7.15. I only followed the link provided above since we're having the same issue. Thank you.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 31, 2022, 2:20am UTC](https://discuss.elastic.co/t/error-could-not-create-the-java-virtual-machine-es-wont-start/317581/3 "2022-10-31T02:20:44Z")

</div>

Can you please share more of your Elasticsearch log, and your elasticsearch.yml.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 28, 2022, 2:21am UTC](https://discuss.elastic.co/t/error-could-not-create-the-java-virtual-machine-es-wont-start/317581/4 "2022-11-28T02:21:38Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
