# ERROR: Could not load plugin descriptor for existing plugin \[shield\]. Was the plugin built before 2.0?

**URL:** <https://discuss.elastic.co/t/error-could-not-load-plugin-descriptor-for-existing-plugin-shield-was-the-plugin-built-before-2-0/93806>\
**Category:** Elasticsearch\
**Created:** [July 19, 2017, 3:40pm UTC](https://discuss.elastic.co/t/error-could-not-load-plugin-descriptor-for-existing-plugin-shield-was-the-plugin-built-before-2-0/93806 "2017-07-19T15:40:50Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nikhilpawar1985](https://avatars.discourse-cdn.com/v4/letter/n/e68b1a/32.png) [@Nikhilpawar1985](https://discuss.elastic.co/u/Nikhilpawar1985)\
**Post date:** [July 19, 2017, 3:40pm UTC](https://discuss.elastic.co/t/error-could-not-load-plugin-descriptor-for-existing-plugin-shield-was-the-plugin-built-before-2-0/93806/1 "2017-07-19T15:40:50Z")

</div>

Can someone please help with the issue . Received an error while installing the plugin shield while rolling upgrade.I am upgrading ES from 2.2 to 2.4.5

```
root@dfsyselasticp1:/usr/share/elasticsearch# dpkg -l | grep elasticsearch
ii elasticsearch 2.4.5 all Elasticsearch is a distributed RESTful search engine built for the cloud. Reference documentation can be found at https://www.elastic.co/guide/en/elasticsearch/reference/current/index.html and the 'Elasticsearch: The Definitive Guide' book can be found at https://www.elastic.co/guide/en/elasticsearch/guide/current/index.html
root@dfsyselasticp1:/usr/share/elasticsearch# bin/plugin install shield
-> Installing shield...
Trying https://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/shield/2.4.5/shield-2.4.5.zip ...
Downloading ...............................................................................................................................................DONE
Verifying https://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/shield/2.4.5/shield-2.4.5.zip checksums if available ...
Downloading .DONE
ERROR: Could not load plugin descriptor for existing plugin [shield]. Was the plugin built before 2.0?
root@dfsyselasticp1:/usr/share/elasticsearch#
```

---

<div class="post-metadata">

**Author:** ![Nikhilpawar1985](https://avatars.discourse-cdn.com/v4/letter/n/e68b1a/32.png) [@Nikhilpawar1985](https://discuss.elastic.co/u/Nikhilpawar1985)\
**Post date:** [July 19, 2017, 4:17pm UTC](https://discuss.elastic.co/t/error-could-not-load-plugin-descriptor-for-existing-plugin-shield-was-the-plugin-built-before-2-0/93806/2 "2017-07-19T16:17:09Z")

</div>

There was a symbolic link for shield which was causing the problem . After removing it , resolved the issue. I was able to install .

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 16, 2017, 4:17pm UTC](https://discuss.elastic.co/t/error-could-not-load-plugin-descriptor-for-existing-plugin-shield-was-the-plugin-built-before-2-0/93806/3 "2017-08-16T16:17:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
