# Error creating a new index : validation failed maximum shards open

**URL:** <https://discuss.elastic.co/t/error-creating-a-new-index-validation-failed-maximum-shards-open/318564>\
**Category:** Elasticsearch\
**Created:** [November 9, 2022, 4:24pm UTC](https://discuss.elastic.co/t/error-creating-a-new-index-validation-failed-maximum-shards-open/318564 "2022-11-09T16:24:41Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![mpniel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mpniel/32/113170_2.png) [@mpniel](https://discuss.elastic.co/u/mpniel)\
**Post date:** [November 9, 2022, 4:24pm UTC](https://discuss.elastic.co/t/error-creating-a-new-index-validation-failed-maximum-shards-open/318564/1 "2022-11-09T16:24:41Z")

</div>

Hi,  
I need to create a new index and get the following error:  
Could you please help?

command: POST /myindex1213/\_doc

error message:  
validatiion failed 1: this action would add [2] total shards, but this cluster currently has [5000]/[5000] maxmimum shards open

My version is: 7.5

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [November 9, 2022, 5:22pm UTC](https://discuss.elastic.co/t/error-creating-a-new-index-validation-failed-maximum-shards-open/318564/2 "2022-11-09T17:22:02Z")

</div>

Welcome!

As the message says, you can not create a new index.  
You would need first to remove non needed indices if any.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [November 9, 2022, 10:51pm UTC](https://discuss.elastic.co/t/error-creating-a-new-index-validation-failed-maximum-shards-open/318564/3 "2022-11-09T22:51:14Z")

</div>

Welcome to our community! 😃

> [@mpniel](#):
>
> My version is: 7.5

Please upgrade, this is a very very old version that is [EOL](https://www.elastic.co/support/eol) and no longer supported.

What is the output from the [`_cluster/stats?pretty&human` API](https://www.elastic.co/guide/en/elasticsearch/reference/8.4/cluster-stats.html)?

---

<div class="post-metadata">

**Author:** ![mpniel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mpniel/32/113170_2.png) [@mpniel](https://discuss.elastic.co/u/mpniel)\
**Post date:** [November 20, 2022, 5:32pm UTC](https://discuss.elastic.co/t/error-creating-a-new-index-validation-failed-maximum-shards-open/318564/4 "2022-11-20T17:32:39Z")

</div>

Thanks very much!  
I solved the problem by deleting unused indexes and that freed room for new shards.

‫בתאריך יום ה׳, 10 בנוב׳ 2022 ב-1:01 מאת ‪Mark Walkom via Discuss the Elastic Stack‬‏ \<‪[notifications@elastic.discoursemail.com](mailto:notifications@elastic.discoursemail.com)‬‏\>:‬

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 18, 2022, 5:32pm UTC](https://discuss.elastic.co/t/error-creating-a-new-index-validation-failed-maximum-shards-open/318564/5 "2022-12-18T17:32:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
