# Error during elasticsearch cluster setup

**URL:** <https://discuss.elastic.co/t/error-during-elasticsearch-cluster-setup/83164>\
**Category:** Elasticsearch\
**Created:** [April 21, 2017, 7:59am UTC](https://discuss.elastic.co/t/error-during-elasticsearch-cluster-setup/83164 "2017-04-21T07:59:31Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Newbie111985](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/newbie111985/32/17561_2.png) [@Newbie111985](https://discuss.elastic.co/u/Newbie111985)\
**Post date:** [April 21, 2017, 7:59am UTC](https://discuss.elastic.co/t/error-during-elasticsearch-cluster-setup/83164/1 "2017-04-21T07:59:31Z")

</div>

I am trying to setup an elasticsearch cluster with 3 nodes. I am using es version 5.1.2.  
The node details are as follows:  
node1: 10.248.9.42  
node2: 10.242.235.167  
node3: 10.88.28.33

The node1 configuration is as follows:

[cluster.name](http://cluster.name): my-cluster-1  
[node.name](http://node.name): node1  
network.host: 0.0.0.0  
transport.host: 10.248.9.42  
transport.tcp.port: 9300  
http.port: 9200  
indices.query.bool.max\_clause\_count: 4096

discovery.zen.minimum\_master\_nodes: 2  
discovery.zen.ping.unicast.hosts: ["10.248.9.42", "10.242.235.167", "10.88.28.33"]

When I start elasticsearch on node1, it can start successfully.

The node2 configuration is as follows:  
[cluster.name](http://cluster.name): my-cluster-1  
[node.name](http://node.name): node2  
network.host: 0.0.0.0  
transport.host: 10.242.235.167  
transport.tcp.port: 9300  
http.port: 9200  
indices.query.bool.max\_clause\_count: 4096

discovery.zen.minimum\_master\_nodes: 2  
discovery.zen.ping.unicast.hosts: ["10.248.9.42", "10.242.235.167", "10.88.28.33"]

When I try starting elasticsearch on node2, I am getting below error.  
What is going wrong here?

org.elasticsearch.transport.BindTransportException: Failed to bind to [9300]  
at org.elasticsearch.transport.TcpTransport.bindToPort(TcpTransport.java:636) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.transport.TcpTransport.bindServer(TcpTransport.java:601) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.transport.netty4.Netty4Transport.doStart(Netty4Transport.java:182) ~[?:?]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:69) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.transport.TransportService.doStart(TransportService.java:188) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:69) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.node.Node.start(Node.java:577) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:234) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:308) [elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) [elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) [elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) [elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) [elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.cli.Command.main(Command.java:88) [elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89) [elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82) [elasticsearch-5.1.2.jar:5.1.2]  
Caused by: java.net.BindException: Cannot assign requested address  
at sun.nio.ch.Net.bind0(Native Method) ~[?:1.8.0\_121]  
at sun.nio.ch.Net.bind(Net.java:433) ~[?:1.8.0\_121]  
at sun.nio.ch.Net.bind(Net.java:425) ~[?:1.8.0\_121]  
at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:223) ~[?:1.8.0\_121]  
at io.netty.channel.socket.nio.NioServerSocketChannel.doBind(NioServerSocketChannel.java:127) ~[?:?]  
at io.netty.channel.AbstractChannel$AbstractUnsafe.bind(AbstractChannel.java:554) ~[?:?]  
at io.netty.channel.DefaultChannelPipeline$HeadContext.bind(DefaultChannelPipeline.java:1258) ~[?:?]  
at io.netty.channel.AbstractChannelHandlerContext.invokeBind(AbstractChannelHandlerContext.java:512) ~[?:?]  
at io.netty.channel.AbstractChannelHandlerContext.bind(AbstractChannelHandlerContext.java:497) ~[?:?]  
at io.netty.channel.DefaultChannelPipeline.bind(DefaultChannelPipeline.java:980) ~[?:?]  
at io.netty.channel.AbstractChannel.bind(AbstractChannel.java:250) ~[?:?]  
at io.netty.bootstrap.AbstractBootstrap$2.run(AbstractBootstrap.java:363) ~[?:?]  
at io.netty.util.concurrent.AbstractEventExecutor.safeExecute(AbstractEventExecutor.java:163) ~[?:?]  
at io.netty.util.concurrent.SingleThreadEventExecutor.runAllTasks(SingleThreadEventExecutor.java:418) ~[?:?]  
at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:454) ~[?:?]  
at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:873) ~[?:?]  
at java.lang.Thread.run(Thread.java:745) ~[?:1.8.0\_121]  
[2017-04-21T00:29:57,688][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [[slc12mun.us.oracle.com](http://slc12mun.us.oracle.com)] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: BindTransportException[Failed to bind to [9300]]; nested: BindException[Cannot assign requested address];  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:125) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.cli.Command.main(Command.java:88) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82) ~[elasticsearch-5.1.2.jar:5.1.2]  
Caused by: org.elasticsearch.transport.BindTransportException: Failed to bind to [9300]  
at org.elasticsearch.transport.TcpTransport.bindToPort(TcpTransport.java:636) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.transport.TcpTransport.bindServer(TcpTransport.java:601) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.transport.netty4.Netty4Transport.doStart(Netty4Transport.java:182) ~[?:?]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:69) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.transport.TransportService.doStart(TransportService.java:188) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:69) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.node.Node.start(Node.java:577) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:234) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:308) ~[elasticsearch-5.1.2.jar:5.1.2]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) ~[elasticsearch-5.1.2.jar:5.1.2]  
... 6 more

P.S. I have verified that port 9300 is not in use by any other process in node2.

---

<div class="post-metadata">

**Author:** ![xavierfacq](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xavierfacq/32/8744_2.png) [@xavierfacq](https://discuss.elastic.co/u/xavierfacq)\
**Post date:** [April 21, 2017, 8:21am UTC](https://discuss.elastic.co/t/error-during-elasticsearch-cluster-setup/83164/2 "2017-04-21T08:21:28Z")

</div>

Hi,

In all your configurations, remove "transport.host" entries,

and just set "network.host":

```
network.host: ["10.242.235.167", "127.0.0.1"] # add or remove entries you need to bind

```

bye,  
Xavier

---

<div class="post-metadata">

**Author:** ![Newbie111985](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/newbie111985/32/17561_2.png) [@Newbie111985](https://discuss.elastic.co/u/Newbie111985)\
**Post date:** [April 21, 2017, 8:35am UTC](https://discuss.elastic.co/t/error-during-elasticsearch-cluster-setup/83164/3 "2017-04-21T08:35:38Z")

</div>

May I know why this change is necessary and what is wrong with my configuration?  
As I mentioned, elasticsearch is running fine in node1 with above configuration.

---

<div class="post-metadata">

**Author:** ![xavierfacq](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/xavierfacq/32/8744_2.png) [@xavierfacq](https://discuss.elastic.co/u/xavierfacq)\
**Post date:** [April 21, 2017, 8:53am UTC](https://discuss.elastic.co/t/error-during-elasticsearch-cluster-setup/83164/4 "2017-04-21T08:53:52Z")

</div>

"transport.host" overwrite "network.host" setting.

Does your node2 have a special connection ?

```
Cannot assign requested address bind0(Native Method) ~[?:1.8.0_121]
```

---

<div class="post-metadata">

**Author:** ![Newbie111985](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/newbie111985/32/17561_2.png) [@Newbie111985](https://discuss.elastic.co/u/Newbie111985)\
**Post date:** [April 21, 2017, 8:56am UTC](https://discuss.elastic.co/t/error-during-elasticsearch-cluster-setup/83164/5 "2017-04-21T08:56:53Z")

</div>

Thanks. I did not get what you mean by-  
Does your node2 have a special connection?  
Please elaborate.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 19, 2017, 9:04am UTC](https://discuss.elastic.co/t/error-during-elasticsearch-cluster-setup/83164/6 "2017-05-19T09:04:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
