# Error during startup of application configured with Elastic APM Java agent (Beta)

**URL:** <https://discuss.elastic.co/t/error-during-startup-of-application-configured-with-elastic-apm-java-agent-beta/140070>\
**Category:** APM\
**Created:** [July 16, 2018, 1:56am UTC](https://discuss.elastic.co/t/error-during-startup-of-application-configured-with-elastic-apm-java-agent-beta/140070 "2018-07-16T01:56:13Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![krishnaarp](https://avatars.discourse-cdn.com/v4/letter/k/97f17d/32.png) [@krishnaarp](https://discuss.elastic.co/u/krishnaarp)\
**Post date:** [July 16, 2018, 1:56am UTC](https://discuss.elastic.co/t/error-during-startup-of-application-configured-with-elastic-apm-java-agent-beta/140070/1 "2018-07-16T01:56:13Z")

</div>

I am trying to configure my java app, with elastic APM agent, as per instructions given here - [https://www.elastic.co/guide/en/apm/agent/java/current/index.html](https://www.elastic.co/guide/en/apm/agent/java/current/index.html)

Once I bring up my java app, when I try to access its url - I am getting this error -

HTTP ERROR: 500

Problem accessing /libs/granite/core/content/login.html. Reason:

```
java.lang.NoClassDefFoundError: co/elastic/apm/servlet/ServletApiAdvice

```

I have not packaged APM client jar with my java app, rather, I have just updated javaagent param to point to the apm client jar. Any help or pointers much appreciated.

---

<div class="post-metadata">

**Author:** ![felixbarny](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/felixbarny/32/27341_2.png) [@felixbarny](https://discuss.elastic.co/u/felixbarny)\
**Post date:** [August 1, 2018, 12:35pm UTC](https://discuss.elastic.co/t/error-during-startup-of-application-configured-with-elastic-apm-java-agent-beta/140070/2 "2018-08-01T12:35:20Z")

</div>

I'm very sorry, I must have overlooked your thread! 😱

The problem should be already resolved by now. Could you try out this snapshot: [https://oss.sonatype.org/content/repositories/snapshots/co/elastic/apm/elastic-apm-agent/0.7.0-SNAPSHOT/elastic-apm-agent-0.7.0-20180801.093112-31.jar](https://oss.sonatype.org/content/repositories/snapshots/co/elastic/apm/elastic-apm-agent/0.7.0-SNAPSHOT/elastic-apm-agent-0.7.0-20180801.093112-31.jar)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 29, 2018, 12:35pm UTC](https://discuss.elastic.co/t/error-during-startup-of-application-configured-with-elastic-apm-java-agent-beta/140070/3 "2018-08-29T12:35:21Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
