# Error during startup

**URL:** <https://discuss.elastic.co/t/error-during-startup/327941>\
**Category:** Elasticsearch\
**Created:** [March 17, 2023, 2:31pm UTC](https://discuss.elastic.co/t/error-during-startup/327941 "2023-03-17T14:31:34Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Soren\_vdc](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Soren\_vdc](https://discuss.elastic.co/u/Soren_vdc)\
**Post date:** [March 17, 2023, 2:31pm UTC](https://discuss.elastic.co/t/error-during-startup/327941/1 "2023-03-17T14:31:34Z")

</div>

Hi,

I receive this error during startup:  
[ERROR][o.e.b.Elasticsearch] [s2ab00jb.be.srv.dev.sys] fatal exception while booting Elasticsearch  
java.lang.IllegalArgumentException: Could not load codec 'Lucene94'. Did you forget to add lucene-backward-codecs.jar?

Caused by: java.lang.IllegalArgumentException: An SPI class of type org.apache.lucene.codecs.Codec with name 'Lucene94' does not exist. You need to add the corresponding JAR file supporting this SPI to your classpath. The current classpath supports the following names: [Lucene92, Lucene70, Lucene80, Lucene84, Lucene86, Lucene87, Lucene90, Lucene91, BWCLucene70Codec, Lucene62, Lucene60, SimpleText]

What may cause this?  
thx!

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [March 19, 2023, 10:04pm UTC](https://discuss.elastic.co/t/error-during-startup/327941/2 "2023-03-19T22:04:58Z")

</div>

What version of Elasticsearch are you running?  
What does yout config look like?  
What is the full log?

---

<div class="post-metadata">

**Author:** ![Soren\_vdc](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Soren\_vdc](https://discuss.elastic.co/u/Soren_vdc)\
**Post date:** [March 20, 2023, 7:37am UTC](https://discuss.elastic.co/t/error-during-startup/327941/3 "2023-03-20T07:37:55Z")

</div>

Hi,

version:  
Version: 8.6.2, Build: rpm/2d58d0f136141f03239816a4e360a8d17b6d8f29/2023-02-13T09:35:20.314882762Z, JVM: 19.0.2

You want to see something specific from the config?  
Complete log:

```auto
[2023-03-14T13:59:04,779][ERROR][o.e.b.Elasticsearch] fatal exception while booting Elasticsearch
java.lang.IllegalArgumentException: Could not load codec 'Lucene94'. Did you forget to add lucene-backward-codecs.jar?
        at org.apache.lucene.index.SegmentInfos.readCodec(SegmentInfos.java:515) ~[lucene-core-9.3.0.jar:?]
        at org.apache.lucene.index.SegmentInfos.parseSegmentInfos(SegmentInfos.java:404) ~[lucene-core-9.3.0.jar:?]
        at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:363) ~[lucene-core-9.3.0.jar:?]
        at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:299) ~[lucene-core-9.3.0.jar:?]
        at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:88) ~[lucene-core-9.3.0.jar:?]
        at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:77) ~[lucene-core-9.3.0.jar:?]
        at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:809) ~[lucene-core-9.3.0.jar:?]
        at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:109) ~[lucene-core-9.3.0.jar:?]
        at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:67) ~[lucene-core-9.3.0.jar:?]
        at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:60) ~[lucene-core-9.3.0.jar:?]
        at org.elasticsearch.gateway.PersistedClusterStateService.nodeMetadata(PersistedClusterStateService.java:322) ~[elasticsearch-8.4.2.jar:?]
        at org.elasticsearch.env.NodeEnvironment.loadNodeMetadata(NodeEnvironment.java:599) ~[elasticsearch-8.4.2.jar:?]
        at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:326) ~[elasticsearch-8.4.2.jar:?]
        at org.elasticsearch.node.Node.<init>(Node.java:456) ~[elasticsearch-8.4.2.jar:?]
        at org.elasticsearch.node.Node.<init>(Node.java:311) ~[elasticsearch-8.4.2.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch$2.<init>(Elasticsearch.java:214) ~[elasticsearch-8.4.2.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch.initPhase3(Elasticsearch.java:214) ~[elasticsearch-8.4.2.jar:?]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:67) ~[elasticsearch-8.4.2.jar:?]
        Suppressed: org.apache.lucene.index.CorruptIndexException: checksum passed (b8f9f84b). possibly transient resource issue, or a Lucene or JVM bug (resource=BufferedChecksumIndexInput(NIOFSIndexInput(path="/var/lib/elasticsearch/_state/segments_1ury")))
                at org.apache.lucene.codecs.CodecUtil.checkFooter(CodecUtil.java:500) ~[lucene-core-9.3.0.jar:?]
                at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:370) ~[lucene-core-9.3.0.jar:?]
                at org.apache.lucene.index.SegmentInfos.readCommit(SegmentInfos.java:299) ~[lucene-core-9.3.0.jar:?]
                at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:88) ~[lucene-core-9.3.0.jar:?]
                at org.apache.lucene.index.StandardDirectoryReader$1.doBody(StandardDirectoryReader.java:77) ~[lucene-core-9.3.0.jar:?]
                at org.apache.lucene.index.SegmentInfos$FindSegmentsFile.run(SegmentInfos.java:809) ~[lucene-core-9.3.0.jar:?]
                at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:109) ~[lucene-core-9.3.0.jar:?]
                at org.apache.lucene.index.StandardDirectoryReader.open(StandardDirectoryReader.java:67) ~[lucene-core-9.3.0.jar:?]
                at org.apache.lucene.index.DirectoryReader.open(DirectoryReader.java:60) ~[lucene-core-9.3.0.jar:?]
                at org.elasticsearch.gateway.PersistedClusterStateService.nodeMetadata(PersistedClusterStateService.java:322) ~[elasticsearch-8.4.2.jar:?]
                at org.elasticsearch.env.NodeEnvironment.loadNodeMetadata(NodeEnvironment.java:599) ~[elasticsearch-8.4.2.jar:?]
                at org.elasticsearch.env.NodeEnvironment.<init>(NodeEnvironment.java:326) ~[elasticsearch-8.4.2.jar:?]
                at org.elasticsearch.node.Node.<init>(Node.java:456) ~[elasticsearch-8.4.2.jar:?]
                at org.elasticsearch.node.Node.<init>(Node.java:311) ~[elasticsearch-8.4.2.jar:?]
                at org.elasticsearch.bootstrap.Elasticsearch$2.<init>(Elasticsearch.java:214) ~[elasticsearch-8.4.2.jar:?]
                at org.elasticsearch.bootstrap.Elasticsearch.initPhase3(Elasticsearch.java:214) ~[elasticsearch-8.4.2.jar:?]
                at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:67) ~[elasticsearch-8.4.2.jar:?]
Caused by: java.lang.IllegalArgumentException: An SPI class of type org.apache.lucene.codecs.Codec with name 'Lucene94' does not exist. You need to add the corresponding JAR file supporting this SPI to your classpath. The current classpath supports the following names: [Lucene92, Lucene70, Lucene80, Lucene84, Lucene86, Lucene87, Lucene90, Lucene91, BWCLucene70Codec, Lucene62, Lucene60, SimpleText]
        at org.apache.lucene.util.NamedSPILoader.lookup(NamedSPILoader.java:113) ~[lucene-core-9.3.0.jar:?]
        at org.apache.lucene.codecs.Codec.forName(Codec.java:118) ~[lucene-core-9.3.0.jar:?]
        at org.apache.lucene.index.SegmentInfos.readCodec(SegmentInfos.java:511) ~[lucene-core-9.3.0.jar:?]

```

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [March 20, 2023, 7:49am UTC](https://discuss.elastic.co/t/error-during-startup/327941/4 "2023-03-20T07:49:53Z")

</div>

> [@Soren\_vdc](#):
>
> You want to see something specific from the config?

All of it please. Same with the log.

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [March 20, 2023, 8:15am UTC](https://discuss.elastic.co/t/error-during-startup/327941/5 "2023-03-20T08:15:54Z")

</div>

You said Elasticsearch 8.6.2 but the version running is `elasticsearch-8.4.2.jar`.

Did you try to downgrade?

---

<div class="post-metadata">

**Author:** ![Soren\_vdc](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Soren\_vdc](https://discuss.elastic.co/u/Soren_vdc)\
**Post date:** [March 20, 2023, 8:58am UTC](https://discuss.elastic.co/t/error-during-startup/327941/6 "2023-03-20T08:58:26Z")

</div>

Hi David,

Good remark! I have checked and it seems there was an downgrade triggered some time ago. I have tried to reinstall version 8.6.2 but still the same error during startup. Any idea?

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [March 20, 2023, 9:10am UTC](https://discuss.elastic.co/t/error-during-startup/327941/7 "2023-03-20T09:10:21Z")

</div>

Could you share the full logs again?

---

<div class="post-metadata">

**Author:** ![Soren\_vdc](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Soren\_vdc](https://discuss.elastic.co/u/Soren_vdc)\
**Post date:** [March 20, 2023, 9:51am UTC](https://discuss.elastic.co/t/error-during-startup/327941/8 "2023-03-20T09:51:07Z")

</div>

Hi David,

Elasticsearch is running again after update to version 8.6.2. So it seems the downgrade cause the issue. Thanks for the help!

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 17, 2023, 9:52am UTC](https://discuss.elastic.co/t/error-during-startup/327941/9 "2023-04-17T09:52:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
