# \[ERROR\]\[elasticsearch-service\] Unable to retrieve version information from Elasticsearch nodes

**URL:** <https://discuss.elastic.co/t/error-elasticsearch-service-unable-to-retrieve-version-information-from-elasticsearch-nodes/306399>\
**Category:** Elasticsearch\
**Created:** [June 5, 2022, 11:56am UTC](https://discuss.elastic.co/t/error-elasticsearch-service-unable-to-retrieve-version-information-from-elasticsearch-nodes/306399 "2022-06-05T11:56:51Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![HKN\_MZ](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hkn_mz/32/75678_2.png) [@HKN\_MZ](https://discuss.elastic.co/u/HKN_MZ)\
**Post date:** [June 5, 2022, 11:56am UTC](https://discuss.elastic.co/t/error-elasticsearch-service-unable-to-retrieve-version-information-from-elasticsearch-nodes/306399/1 "2022-06-05T11:56:51Z")

</div>

Hi Everyone, I try to install Elasticsearch8.2.2 and Kibana8.2.2 on the one ubuntu20.04 virtual machine. I installed and configured Elasticsearch8.2.2 and get accessed from my local browser successfully. As below picture.

![image](https://us1.discourse-cdn.com/elastic/original/3X/9/8/980d072b03d83bb055092aa2ea4a8027c02de81b.png)

I also installed and configured Kibana8.2.2. But when I try to get access from my local browser. Browser always say` Kibana server is not ready yet.`

![image](https://us1.discourse-cdn.com/elastic/original/3X/b/9/b998284ecac59686ab380887bb337f95efc5f3bc.png)

> root@el1# **sudo systemctl status kibana.service**  
> Jun 05 11:19:55 elastic1 kibana[17804]: [2022-06-05T11:19:55.411+00:00][ERROR][elasticsearch-service] Unable to retrieve version information from Elasticsearch nodes.\>

> root@el1# **journalctl -f -u kibana.service**  
> un 05 11:19:55 elastic1 kibana[17804]: [2022-06-05T11:19:55.411+00:00][ERROR][elasticsearch-service] Unable to retrieve version information from Elasticsearch nodes. self signed certificate in certificate chain  
> Jun 05 11:19:58 elastic1 kibana[17804]: [2022-06-05T11:19:58.607+00:00][INFO][plugins.screenshotting.chromium] Browser executable: /usr/share/kibana/x-pack/plugins/screenshotting/chromium/headless\_shell-linux\_x64/headless\_shell

root@el1# **sudo nano /etc/elasticsearch/elasticsearch.yml**

```auto
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch

xpack.security.enabled: true
xpack.security.enrollment.enabled: true
xpack.security.http.ssl:
  enabled: true
  keystore.path: certs/http.p12
xpack.security.transport.ssl:
  enabled: true
  verification_mode: certificate
  keystore.path: certs/transport.p12
  truststore.path: certs/transport.p12
cluster.initial_master_nodes: ["elastic1"]

cluster.name: elastic
node.name: elastic1
network.host: 192.168.216.142

```

root@el1# **sudo nano /etc/kibana/kibana.yml**

```auto
server.port: 5601
server.host: "192.168.216.142"
elasticsearch.hosts: ["https://192.168.216.142:9200"]
elasticsearch.username: "kibana_system"
elasticsearch.password: "B4CRasddasdasGBXzTI"

# Enables you to specify a file where Kibana stores log output.
logging:
  appenders:
    file:
      type: file
      fileName: /var/log/kibana/kibana.log
      layout:
        type: json
  root:
    appenders:
      - default
      - file

pid.file: /run/kibana/kibana.pid

```

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [June 5, 2022, 1:04pm UTC](https://discuss.elastic.co/t/error-elasticsearch-service-unable-to-retrieve-version-information-from-elasticsearch-nodes/306399/2 "2022-06-05T13:04:34Z")

</div>

Hi @HKN_MZ

As the error says

> Unable to retrieve version information from Elasticsearch nodes. self signed certificate in certificate chain

You need to provide the self signed CA for elasticsearch to Kibana in `kibana.yml`

`elasticsearch.ssl.certificateAuthorities: "/path/cert.ca"`

> **[Configure Kibana | Kibana Guide \[8.11\] | Elastic](https://www.elastic.co/guide/en/kibana/current/settings.html)**

You can test by setting

`elasticsearch.ssl.verificationMode: "none"`

But that is not recommended for production.

---

<div class="post-metadata">

**Author:** ![HKN\_MZ](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hkn_mz/32/75678_2.png) [@HKN\_MZ](https://discuss.elastic.co/u/HKN_MZ)\
**Post date:** [June 5, 2022, 1:49pm UTC](https://discuss.elastic.co/t/error-elasticsearch-service-unable-to-retrieve-version-information-from-elasticsearch-nodes/306399/3 "2022-06-05T13:49:45Z")

</div>

Thank's for your repply, You are right when I added this code `elasticsearch.ssl.verificationMode: "none"` in kibana.yml. Problem is fixed.

I checked your shared document but I didn't figure out Where is `cert.ca` file? or should I create this file?

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [June 5, 2022, 3:10pm UTC](https://discuss.elastic.co/t/error-elasticsearch-service-unable-to-retrieve-version-information-from-elasticsearch-nodes/306399/4 "2022-06-05T15:10:22Z")

</div>

It depends on how you generated your certificates.

Did you just use the default steps when you installed elasticseaech or is it a certificate from your company or are you created them yourself.

---

<div class="post-metadata">

**Author:** ![HKN\_MZ](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/hkn_mz/32/75678_2.png) [@HKN\_MZ](https://discuss.elastic.co/u/HKN_MZ)\
**Post date:** [June 12, 2022, 7:46am UTC](https://discuss.elastic.co/t/error-elasticsearch-service-unable-to-retrieve-version-information-from-elasticsearch-nodes/306399/5 "2022-06-12T07:46:16Z")

</div>

I fixed the problem and I wrote an [article](https://hakanmazi123.medium.com/online-installation-elasticsearch-and-kibana-to-ubuntu-97ca71d869e2) about it.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 10, 2022, 7:46am UTC](https://discuss.elastic.co/t/error-elasticsearch-service-unable-to-retrieve-version-information-from-elasticsearch-nodes/306399/6 "2022-07-10T07:46:41Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [September 22, 2022, 6:10pm UTC](https://discuss.elastic.co/t/error-elasticsearch-service-unable-to-retrieve-version-information-from-elasticsearch-nodes/306399/7 "2022-09-22T18:10:35Z")

</div>

Nice! That Works...

Turns out you don't need to do that if you use [the enrollment token method](https://www.elastic.co/guide/en/elasticsearch/reference/current/configuring-stack-security.html#stack-start-with-security) ... which is just a shortcut to what you did...

Glad you got it working... it was much harder in 7.x why I also wrote a [How To](https://github.com/bvader/howtos/tree/master/basic-security-elasticsearch)
