# Error: ElasticSearch won't start when downgraded from 8.9.2 to 8.4.1

**URL:** <https://discuss.elastic.co/t/error-elasticsearch-wont-start-when-downgraded-from-8-9-2-to-8-4-1/342879>\
**Category:** Elasticsearch\
**Created:** [September 12, 2023, 5:49pm UTC](https://discuss.elastic.co/t/error-elasticsearch-wont-start-when-downgraded-from-8-9-2-to-8-4-1/342879 "2023-09-12T17:49:47Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![ujosyula](https://avatars.discourse-cdn.com/v4/letter/u/c2a13f/32.png) [@ujosyula](https://discuss.elastic.co/u/ujosyula)\
**Post date:** [September 12, 2023, 5:49pm UTC](https://discuss.elastic.co/t/error-elasticsearch-wont-start-when-downgraded-from-8-9-2-to-8-4-1/342879/1 "2023-09-12T17:49:47Z")

</div>

I see this error when I try to downgrade. The version of elasticsearch is 8.4.1, but the service won't start.  
[2023-09-12T09:52:39,253][ERROR][o.e.b.Elasticsearch] fatal exception while booting Elasticsearch  
java.lang.IllegalArgumentException: Could not load codec 'Lucene95'. Did you forget to add lucene-backward-codecs.jar?  
at org.apache.lucene.index.SegmentInfos.readCodec(SegmentInfos.java:515) ~[lucene-core-9.3.0.jar:?]

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 12, 2023, 5:56pm UTC](https://discuss.elastic.co/t/error-elasticsearch-wont-start-when-downgraded-from-8-9-2-to-8-4-1/342879/2 "2023-09-12T17:56:29Z")

</div>

Elasticsearch does not support downgrades. If you want to downgrade you will need to restore your data from a snapshot into an empty cluster.

Why are you looking to downgrade?

---

<div class="post-metadata">

**Author:** ![ujosyula](https://avatars.discourse-cdn.com/v4/letter/u/c2a13f/32.png) [@ujosyula](https://discuss.elastic.co/u/ujosyula)\
**Post date:** [September 12, 2023, 6:07pm UTC](https://discuss.elastic.co/t/error-elasticsearch-wont-start-when-downgraded-from-8-9-2-to-8-4-1/342879/3 "2023-09-12T18:07:13Z")

</div>

I want to be able to downgrade in case I run into an issue upgrading version in Production.  
So I am trying to get the downgrade to work in lower environment.  
I can't even start elasticsearch, I am not worried about data.  
I want to be able to start Elasticsearch and if you can tell me how to fix the lucene95 codec, I would appreciate it.  
I can run pipelines and get my indices populated.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 12, 2023, 6:15pm UTC](https://discuss.elastic.co/t/error-elasticsearch-wont-start-when-downgraded-from-8-9-2-to-8-4-1/342879/4 "2023-09-12T18:15:30Z")

</div>

You need to install a clean cluster of the old version and restore data from a snapshot.

---

<div class="post-metadata">

**Author:** ![ujosyula](https://avatars.discourse-cdn.com/v4/letter/u/c2a13f/32.png) [@ujosyula](https://discuss.elastic.co/u/ujosyula)\
**Post date:** [September 12, 2023, 6:27pm UTC](https://discuss.elastic.co/t/error-elasticsearch-wont-start-when-downgraded-from-8-9-2-to-8-4-1/342879/5 "2023-09-12T18:27:25Z")

</div>

What do you mean by install a clean cluster?  
Like I said, I don’t worry about data, we run pipelines nightly, and don’t worry about historical data.

---

<div class="post-metadata">

**Author:** ![Christian\_Dahlqvist](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/christian_dahlqvist/32/4617_2.png) [@Christian\_Dahlqvist](https://discuss.elastic.co/u/Christian_Dahlqvist)\
**Post date:** [September 12, 2023, 6:38pm UTC](https://discuss.elastic.co/t/error-elasticsearch-wont-start-when-downgraded-from-8-9-2-to-8-4-1/342879/6 "2023-09-12T18:38:20Z")

</div>

You need to clear the data path and start up completely empty.

---

<div class="post-metadata">

**Author:** ![ujosyula](https://avatars.discourse-cdn.com/v4/letter/u/c2a13f/32.png) [@ujosyula](https://discuss.elastic.co/u/ujosyula)\
**Post date:** [September 12, 2023, 7:31pm UTC](https://discuss.elastic.co/t/error-elasticsearch-wont-start-when-downgraded-from-8-9-2-to-8-4-1/342879/7 "2023-09-12T19:31:42Z")

</div>

Do you mean I have to delete all the data in the indices?

---

<div class="post-metadata">

**Author:** ![ujosyula](https://avatars.discourse-cdn.com/v4/letter/u/c2a13f/32.png) [@ujosyula](https://discuss.elastic.co/u/ujosyula)\
**Post date:** [September 12, 2023, 7:33pm UTC](https://discuss.elastic.co/t/error-elasticsearch-wont-start-when-downgraded-from-8-9-2-to-8-4-1/342879/8 "2023-09-12T19:33:22Z")

</div>

But the error I see in the logs is about Lucene95 not being there.  
How does this error get resolved, if I delete the data?

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [September 12, 2023, 8:52pm UTC](https://discuss.elastic.co/t/error-elasticsearch-wont-start-when-downgraded-from-8-9-2-to-8-4-1/342879/9 "2023-09-12T20:52:35Z")

</div>

The error is because some of your data needs a codec called `Lucene95` to read it. If you delete the data, there's nothing that requires that codec any more.

It's not really a "downgrade" that you're doing tho, it's just a reinstall.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 10, 2023, 8:53pm UTC](https://discuss.elastic.co/t/error-elasticsearch-wont-start-when-downgraded-from-8-9-2-to-8-4-1/342879/10 "2023-10-10T20:53:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
