# Error: ENOENT: no such file or directory.....Kibana docker failed to start

**URL:** https://discuss.elastic.co/t/error-enoent-no-such-file-or-directory-kibana-docker-failed-to-start/225390
**Category:** Kibana
**Tags:** docker
**Created:** [March 27, 2020, 11:04am UTC](https://discuss.elastic.co/t/error-enoent-no-such-file-or-directory-kibana-docker-failed-to-start/225390 "2020-03-27T11:04:49Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Raushan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/raushan/32/102180_2.png) [@Raushan](https://discuss.elastic.co/u/Raushan)
#### Post date: [March 27, 2020, 11:04am UTC](https://discuss.elastic.co/t/error-enoent-no-such-file-or-directory-kibana-docker-failed-to-start/225390/1 "2020-03-27T11:04:49Z")

</div>

I'm trying to load **kibana.yml** version 7.5.2 with Dockerfile in **Windows10**. It fails to read file located in directory.  
Error:

```auto
{"type":"log","@timestamp":"2020-03-27T11:01:51Z","tags":["fatal","root"],"pid":6,"message":"{ Error: ENOENT: no such file or directory, open 'D:\\\\ELK-certs\\\\kibana.crt'\n at Object.openSync (fs.js:439:3)\n at readFileSync (fs.js:344:35)\n at getServerOptions (/usr/share/kibana/src/core/server/http/http_tools.js:77:34)\n at HttpServer.setup (/usr/share/kibana/src/core/server/http/http_server.js:72:60)\n at HttpService.runNotReadyServer (/usr/share/kibana/src/core/server/http/http_service.js:140:26)\n at HttpService.setup (/usr/share/kibana/src/core/server/http/http_service.js:60:18)\n errno: -2,\n syscall: 'open',\n code: 'ENOENT',\n path: 'D:\\\\\\\\ELK-certs\\\\\\\\kibana.crt' }"}

 FATAL Error: ENOENT: no such file or directory, open 'D:\\ELK-certs\\kibana.crt'

```

Kibana.yml file:

```auto
server.name: "kibana"
server.host: "app-vm2-ssl"
server.ssl.enabled: true
elasticsearch.hosts: ["https://app-vm2-ssl.company.com:9200","https://app-vm1-ssl.company.com:9200"]
elasticsearch.username: "kibana"
elasticsearch.password: "111111"
elasticsearch.ssl.certificateAuthorities: ["D:\\ELK-certs\\DigiCert Global Root CA.pem", "D:\\ELK-certs\\DigiCert SHA2 Secure Server CA.pem"]
server.ssl.key: D:\\ELK-certs\\companyPrivateKey.pem
server.ssl.certificate: D:\\ELK-certs\\kibana.crt

```

Docker file:

```auto
FROM docker.elastic.co/kibana/kibana:7.5.2
ADD kibana.yml /usr/share/kibana/config/kibana.yml
EXPOSE 5601

```

---

<div class="post-metadata">

### Author: ![flash1293](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/flash1293/32/41227_2.png) [@flash1293](https://discuss.elastic.co/u/flash1293)
#### Post date: [March 27, 2020, 12:39pm UTC](https://discuss.elastic.co/t/error-enoent-no-such-file-or-directory-kibana-docker-failed-to-start/225390/2 "2020-03-27T12:39:03Z")

</div>

As Kibana runs within the container, it doesn't know anything about your host file system.

Either [mount](https://docs.docker.com/storage/bind-mounts/) the certificate files when running docker or [ADD](https://docs.docker.com/engine/reference/builder/#add) it to the image itself and then reference it in the yml file using the path in the container file system - e.g. if you mount it via `-v D:\\ELK-certs\\companyPrivateKey.pem:/myKey.pem:ro`, then in `kibana.yml` you have to reference it like `server.ssl.key: /myKey.pem`.

---

<div class="post-metadata">

### Author: ![Raushan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/raushan/32/102180_2.png) [@Raushan](https://discuss.elastic.co/u/Raushan)
#### Post date: [March 27, 2020, 4:41pm UTC](https://discuss.elastic.co/t/error-enoent-no-such-file-or-directory-kibana-docker-failed-to-start/225390/3 "2020-03-27T16:41:20Z")

</div>

Thanks @flash1293. I am able to copy now with the [ADD](https://docs.docker.com/engine/reference/builder/#add) approach.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [April 24, 2020, 4:41pm UTC](https://discuss.elastic.co/t/error-enoent-no-such-file-or-directory-kibana-docker-failed-to-start/225390/4 "2020-04-24T16:41:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
