# Error: fail to communicate with updated API client hosts

**URL:** <https://discuss.elastic.co/t/error-fail-to-communicate-with-updated-api-client-hosts/313525>\
**Category:** Elastic Agent\
**Tags:** fleet\
**Created:** [September 2, 2022, 8:19am UTC](https://discuss.elastic.co/t/error-fail-to-communicate-with-updated-api-client-hosts/313525 "2022-09-02T08:19:36Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![ethical20](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ethical20/32/68123_2.png) [@ethical20](https://discuss.elastic.co/u/ethical20)\
**Post date:** [September 2, 2022, 8:19am UTC](https://discuss.elastic.co/t/error-fail-to-communicate-with-updated-api-client-hosts/313525/1 "2022-09-02T08:19:36Z")

</div>

Hi All,

I have a self managed fleet server with one local machine connecting perfectly and i can see logs.

I've installed a new remote cloud machine, the installation was successful but I can't see logs coming.

Checking the remote machine agent logs i can see the following errors:

```auto
{"log.level":"info","@timestamp":"2022-09-02T07:51:39.462Z","log.origin":{"file.name":"cmd/run.go","file.line":201},"message":"APM instrumentation disabled","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2022-09-02T07:51:39.501Z","log.origin":{"file.name":"application/application.go","file.line":78},"message":"Detecting execution mode","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2022-09-02T07:51:39.538Z","log.origin":{"file.name":"application/application.go","file.line":102},"message":"Agent is managed by Fleet","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2022-09-02T07:51:39.538Z","log.origin":{"file.name":"capabilities/capabilities.go","file.line":59},"message":"capabilities file not found in C:\\Program Files\\Elastic\\Agent\\capabilities.yml","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2022-09-02T07:51:40.073Z","log.logger":"composable.providers.docker","log.origin":{"file.name":"docker/docker.go","file.line":44},"message":"Docker provider skipped, unable to connect: protocol not available","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2022-09-02T07:51:40.118Z","log.logger":"api","log.origin":{"file.name":"api/server.go","file.line":68},"message":"Starting stats endpoint","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2022-09-02T07:51:40.118Z","log.origin":{"file.name":"application/managed_mode.go","file.line":315},"message":"Agent is starting","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2022-09-02T07:51:40.118Z","log.logger":"api","log.origin":{"file.name":"api/server.go","file.line":70},"message":"Metrics endpoint listening on: \\\\.\\pipe\\elastic-agent (configured: npipe:///elastic-agent)","ecs.version":"1.6.0"}
{"log.level":"error","@timestamp":"2022-09-02T07:51:56.906Z","log.origin":{"file.name":"fleet/fleet_gateway.go","file.line":208},"message":"failed to dispatch actions, error: fail to communicate with updated API client hosts: Get \"https://192.168.0.3:8220/api/status?\": context deadline exceeded","ecs.version":"1.6.0"}
{"log.level":"error","@timestamp":"2022-09-02T07:51:56.906Z","log.origin":{"file.name":"status/reporter.go","file.line":236},"message":"Elastic Agent status changed to: 'error'","ecs.version":"1.6.0"}
{"log.level":"error","@timestamp":"2022-09-02T07:52:14.189Z","log.origin":{"file.name":"fleet/fleet_gateway.go","file.line":208},"message":"failed to dispatch actions, error: fail to communicate with updated API client hosts: Get \"https://192.168.0.3:8220/api/status?\": context deadline exceeded","ecs.version":"1.6.0"}
{"log.level":"error","@timestamp":"2022-09-02T07:52:31.382Z","log.origin":{"file.name":"fleet/fleet_gateway.go","file.line":208},"message":"failed to dispatch actions, error: fail to communicate with updated API client hosts: Get \"https://192.168.0.3:8220/api/status?\": context deadline exceeded","ecs.version":"1.6.0"}
{"log.level":"error","@timestamp":"2022-09-02T07:52:48.908Z","log.origin":{"file.name":"fleet/fleet_gateway.go","file.line":208},"message":"failed to dispatch actions, error: fail to communicate with updated API client hosts: Get \"https://192.168.0.3:8220/api/status?\": context deadline exceeded","ecs.version":"1.6.0"}
{"log.level":"error","@timestamp":"2022-09-02T07:53:06.524Z","log.origin":{"file.name":"fleet/fleet_gateway.go","file.line":208},"message":"failed to dispatch actions, error: fail to communicate with updated API client hosts: Get \"https://192.168.0.3:8220/api/status?\": context deadline exceeded","ecs.version":"1.6.0"}

```

Where `192.168.0.3:8220` is the ip of my fleet server.

 ![Issue](https://us1.discourse-cdn.com/elastic/original/3X/8/5/8541731acabe24080a338f34e846b25f50db78d6.png)

Any help in this?

---

<div class="post-metadata">

**Author:** ![mtojek](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mtojek/32/63863_2.png) [@mtojek](https://discuss.elastic.co/u/mtojek)\
**Post date:** [September 5, 2022, 3:28pm UTC](https://discuss.elastic.co/t/error-fail-to-communicate-with-updated-api-client-hosts/313525/2 "2022-09-05T15:28:34Z")

</div>

I would leave it for a few minutes to check if it resolves eventually. Let us know if it helped.

---

<div class="post-metadata">

**Author:** ![ethical20](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ethical20/32/68123_2.png) [@ethical20](https://discuss.elastic.co/u/ethical20)\
**Post date:** [September 6, 2022, 6:37am UTC](https://discuss.elastic.co/t/error-fail-to-communicate-with-updated-api-client-hosts/313525/3 "2022-09-06T06:37:41Z")

</div>

Hi,

Thanks for your reply, actually ive solved this by adding the ip of the proxy server in the hosts field in fleet settings.

Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 4, 2022, 6:37am UTC](https://discuss.elastic.co/t/error-fail-to-communicate-with-updated-api-client-hosts/313525/4 "2022-10-04T06:37:58Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
