# ERROR: Failed to determine the health of the cluster with elasticsearch-create-enrollment-token

**URL:** https://discuss.elastic.co/t/error-failed-to-determine-the-health-of-the-cluster-with-elasticsearch-create-enrollment-token/297041
**Category:** Elasticsearch
**Tags:** elastic-stack-security
**Created:** [February 12, 2022, 8:04am UTC](https://discuss.elastic.co/t/error-failed-to-determine-the-health-of-the-cluster-with-elasticsearch-create-enrollment-token/297041 "2022-02-12T08:04:09Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Ismaeel\_Enjreny](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ismaeel_enjreny/32/69578_2.png) [@Ismaeel\_Enjreny](https://discuss.elastic.co/u/Ismaeel_Enjreny)
#### Post date: [February 12, 2022, 8:04am UTC](https://discuss.elastic.co/t/error-failed-to-determine-the-health-of-the-cluster-with-elasticsearch-create-enrollment-token/297041/1 "2022-02-12T08:04:09Z")

</div>

I have Elasticsearch cluster on my local machine with enabled HTTPs (2 nodes), all is working fine, I am trying to use the new tool elasticsearch-create-enrollment-token to enroll the third node, but I got the following error

> ERROR: Failed to determine the health of the cluster

when I execute the following command

> elasticsearch-create-enrollment-token -s node -v

How can I determine the root cause of this issue

BTW, I have the following settings for SSL

```auto
# This turns on SSL for the HTTP (Rest) interface
xpack.security.http.ssl.enabled: true

# This configures the keystore to use for SSL on HTTP
xpack.security.http.ssl.keystore.path: certs\http.p12
xpack.security.http.ssl.truststore.path: certs\es.p12
xpack.security.http.ssl.verification_mode: certificate

```

I generated the certificate using the following instructions

> **[Set up basic security for the Elastic Stack plus secured HTTPS traffic |...](https://www.elastic.co/guide/en/elasticsearch/reference/master/security-basic-setup-https.html)**

---

<div class="post-metadata">

### Author: ![ikakavas](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ikakavas/32/34430_2.png) [@ikakavas](https://discuss.elastic.co/u/ikakavas)
#### Post date: [February 13, 2022, 7:24pm UTC](https://discuss.elastic.co/t/error-failed-to-determine-the-health-of-the-cluster-with-elasticsearch-create-enrollment-token/297041/2 "2022-02-13T19:24:13Z")

</div>

Hi there,

The enrolment process is designed to work only with the auto-configured TLS setup that one gets with Elasticsearch 8.0.

You could theoretically alter your existing configuration so that enrollment works for you too but we don’t have any documentation around it and it’s probably going to be more work that adding a node with TLS using the documentation you have already followed.

The error message that you got in this case is misleading and we’ll look into making it clearer, thanks for your feedback !

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 13, 2022, 7:24pm UTC](https://discuss.elastic.co/t/error-failed-to-determine-the-health-of-the-cluster-with-elasticsearch-create-enrollment-token/297041/3 "2022-03-13T19:24:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
