# Error: Failed to start Filebeat sends log files to Logstash or directly to Elasticsearch

**URL:** https://discuss.elastic.co/t/error-failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/259409
**Category:** Beats
**Tags:** filebeat
**Created:** [December 22, 2020, 4:35pm UTC](https://discuss.elastic.co/t/error-failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/259409 "2020-12-22T16:35:22Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![Jonathan\_Davis](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jonathan_davis/32/81269_2.png) [@Jonathan\_Davis](https://discuss.elastic.co/u/Jonathan_Davis)
#### Post date: [December 22, 2020, 4:35pm UTC](https://discuss.elastic.co/t/error-failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/259409/1 "2020-12-22T16:35:22Z")

</div>

Good time of the day! I have got a problem with a launch of Filebeat. It doen't want to start. Here is a text of error:  
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''  
filebeat.service - Filebeat sends log files to Logstash or directly to Elasticsearch.  
Loaded: loaded (/lib/systemd/system/filebeat.service; disabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Tue 2020-12-22 19:12:54 MSK; 11min ago  
Docs: [https://www.elastic.co/products/beats/filebeat](https://www.elastic.co/products/beats/filebeat)  
Process: 2623 ExecStart=/usr/share/filebeat/bin/filebeat --environment systemd $BEAT\_LOG\_OPTS $BEAT\_CONFIG\_OPTS $BEAT\_PATH\_OPTS (code=exited, status=1/FAILURE)  
Main PID: 2623 (code=exited, status=1/FAILURE)

дек 22 19:12:54 vmzeek-VirtualBox systemd[1]: filebeat.service: Main process exited, code=exited, status=1/FAILURE  
дек 22 19:12:54 vmzeek-VirtualBox systemd[1]: filebeat.service: Failed with result 'exit-code'.  
дек 22 19:12:54 vmzeek-VirtualBox systemd[1]: filebeat.service: Scheduled restart job, restart counter is at 5.  
дек 22 19:12:54 vmzeek-VirtualBox systemd[1]: Stopped Filebeat sends log files to Logstash or directly to Elasticsearch..  
дек 22 19:12:54 vmzeek-VirtualBox systemd[1]: filebeat.service: Start request repeated too quickly.  
дек 22 19:12:54 vmzeek-VirtualBox systemd[1]: filebeat.service: Failed with result 'exit-code'.  
дек 22 19:12:54 vmzeek-VirtualBox systemd[1]: Failed to start Filebeat sends log files to Logstash or directly to Elasticsearch..  
'''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''  
I have written in the output field of filebeat.yml this information:  
'''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''  
output.logstash:

# The Logstash hosts

```
    hosts: ["192.168.56.103:5044"]
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

```

This VM is pinging successfully the other VM. And I used Ubuntu on both VM's.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 19, 2021, 6:35pm UTC](https://discuss.elastic.co/t/error-failed-to-start-filebeat-sends-log-files-to-logstash-or-directly-to-elasticsearch/259409/2 "2021-01-19T18:35:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
