# Error fetching fields in kibana

**URL:** https://discuss.elastic.co/t/error-fetching-fields-in-kibana/211910
**Category:** Kibana
**Created:** [December 15, 2019, 12:56pm UTC](https://discuss.elastic.co/t/error-fetching-fields-in-kibana/211910 "2019-12-15T12:56:31Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![111228](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/111228/32/56505_2.png) [@111228](https://discuss.elastic.co/u/111228)
#### Post date: [December 15, 2019, 12:56pm UTC](https://discuss.elastic.co/t/error-fetching-fields-in-kibana/211910/1 "2019-12-15T12:56:31Z")

</div>

Good day  
I have a problem.  
 ![](https://us1.discourse-cdn.com/elastic/original/3X/5/6/5661112ddb7cefdcb9a840fa27ae855c68b4b4fb.png)  
Anyone had such a problem? how to resolve it?

---

<div class="post-metadata">

### Author: ![kschandramouli](https://avatars.discourse-cdn.com/v4/letter/k/7c8e57/32.png) [@kschandramouli](https://discuss.elastic.co/u/kschandramouli)
#### Post date: [December 16, 2019, 12:23am UTC](https://discuss.elastic.co/t/error-fetching-fields-in-kibana/211910/2 "2019-12-16T00:23:18Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/2/4/241f44b997e13140e7d58f2af573ba1482247f3f.png)

Hi All,

I am getting the same error in Kibana. I am using Metricbeat in one of my AWS Instance and would like to push monotoring metrics to Elasticsearch/ Kibana. My default dashboards are created in Kibana, but when I open any of the dashboards I am getting this error "Error fetching fields - Not Found" - Error: Not Found  
at [http://10.133.43.232:5601/bundles/commons.bundle.js:1:688003](http://10.133.43.232:5601/bundles/commons.bundle.js:1:688003)

I am using Metricbeat-7.5.0 -OSS version. I have used older versions as well, but it still throws the same error.  
Please find my metricbeat.yml configuration below:

###################### Metricbeat Configuration Example #######################

# This file is an example configuration file highlighting only the most common

# options. The metricbeat.reference.yml file from the same directory contains all the

# supported options with more comments. You can use it as a reference.

# 

# You can find the full configuration reference here:

# [https://www.elastic.co/guide/en/beats/metricbeat/index.html](https://www.elastic.co/guide/en/beats/metricbeat/index.html)

#========================== Modules configuration ============================

metricbeat.config.modules:

# Glob pattern for configuration loading

path: ${path.config}/modules.d/\*.yml

# Set to true to enable config reloading

reload.enabled: false

# Period on which files under path should be checked for changes

#reload.period: 10s

#==================== Elasticsearch template setting ==========================

setup.template.settings:  
index.number\_of\_shards: 1  
#index.codec: best\_compression  
#\_source.enabled: false  
#ilm settings added  
ilm.enabled: false  
setup.template.overwrite: true  
#================================ General =====================================

# The name of the shipper that publishes the network data. It can be used to group

# all the transactions sent by a single shipper in the web interface.

#name:

# The tags of the shipper are included in their own field with each

# transaction published.

#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the

# output.

#fields:

# env: staging

#============================== Dashboards =====================================

# These settings control loading the sample dashboards to the Kibana index. Loading

# the dashboards is disabled by default and can be enabled either by setting the

# options here or by using the `setup` command.

#setup.dashboards.enabled: false  
setup.dashboards.index: "metricbeat-\*"

# The URL from where to download the dashboards archive. By default this URL

# has a value which is computed based on the Beat name and version. For released

# versions, this URL points to the dashboard archive on the [artifacts.elastic.co](http://artifacts.elastic.co)

# website.

#setup.dashboards.url:

setup.dashboards.enabled: true

#============================== Kibana =====================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.

# This requires a Kibana endpoint configuration.

setup.kibana:

# Kibana Host

# Scheme and port can be left out and will be set to the default (http and 5601)

# In case you specify and additional path, the scheme is required: [http://localhost:5601/path](http://localhost:5601/path)

# IPv6 addresses should always be defined as: https://[2001:db8::1]:5601

#host: "localhost:5601"  
host: "[http://Server-IP:5601](http://Server-IP:5601)"  
index: "metricbeat-\*"

# Kibana Space ID

# ID of the Kibana Space into which the dashboards should be loaded. By default,

# the Default Space will be used.

#space.id:

#============================= Elastic Cloud ==================================

# These settings simplify using Metricbeat with the Elastic Cloud ([https://cloud.elastic.co/](https://cloud.elastic.co/)).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and

# `setup.kibana.host` options.

# You can find the `cloud.id` in the Elastic Cloud web UI.

#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and

# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.

#cloud.auth:

#================================ Outputs =====================================

# Configure what output to use when sending the data collected by the beat.

#-------------------------- Elasticsearch output ------------------------------  
output.elasticsearch:

# Array of hosts to connect to.

#hosts: ["localhost:9200"]  
hosts: ["[http://Server-IP:9200](http://Server-IP:9200)"]  
#index: "metricbeat-_"  
index: "metricbeat-%{[agent.version]}-%{+yyyy.MM.dd}"  
setup.template.name: "metricbeat"  
setup.template.pattern: "metricbeat-_"

# Optional protocol and basic auth credentials.

#protocol: "https"  
#username: "elastic"  
#password: "changeme"

#----------------------------- Logstash output --------------------------------  
#output.logstash:

# The Logstash hosts

#hosts: ["localhost:5044"]

# Optional SSL. By default is off.

# List of root certificates for HTTPS server verifications

#ssl.certificate\_authorities: ["/etc/pki/root/ca.pem"]

# Certificate for SSL client authentication

#ssl.certificate: "/etc/pki/client/cert.pem"

# Client Certificate Key

#ssl.key: "/etc/pki/client/cert.key"

#================================ Processors =====================================

# Configure processors to enhance or manipulate events generated by the beat.

processors:

- add\_host\_metadata: ~
- add\_cloud\_metadata: ~

#================================ Logging =====================================

# Sets log level. The default log level is info.

# Available log levels are: error, warning, info, debug

logging.level: info  
#logging.to\_files: true

# At debug level, you can selectively enable logging only for some components.

# To enable all selectors use ["\*"]. Examples of other selectors are "beat",

# "publish", "service".

#logging.selectors: ["\*"]  
logging.selectors: ["beat,publish"]

#============================== X-Pack Monitoring ===============================

# metricbeat can export internal metrics to a central Elasticsearch monitoring

# cluster. This requires xpack monitoring to be enabled in Elasticsearch. The

# reporting is disabled by default.

xpack.monitoring.elasticsearch.collection.enabled: false

# Set to true to enable the monitoring reporter.

#monitoring.enabled: true

# Sets the UUID of the Elasticsearch cluster under which monitoring data for this

# Metricbeat instance will appear in the Stack Monitoring UI. If output.elasticsearch

# is enabled, the UUID is derived from the Elasticsearch cluster referenced by output.elasticsearch.

#monitoring.cluster\_uuid:

# Uncomment to send the metrics to Elasticsearch. Most settings from the

# Elasticsearch output are accepted here as well.

# Note that the settings should point to your Elasticsearch _monitoring_ cluster.

# Any setting that is not set is automatically inherited from the Elasticsearch

# output configuration, so if you have the Elasticsearch output configured such

# that it is pointing to your Elasticsearch monitoring cluster, you can simply

# uncomment the following line.

#monitoring.elasticsearch:

#================================= Migration ==================================

# This allows to enable 6.7 migration aliases

#migration.6\_to\_7.enabled: true  
metricbeat.modules:  
#---------------------------- Apache Status Module ---------------------------

- module: apache  
metricsets: ["status"]  
period: 1s  
hosts: ["[http://127.0.0.1/](http://127.0.0.1/)"]

---

<div class="post-metadata">

### Author: ![111228](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/111228/32/56505_2.png) [@111228](https://discuss.elastic.co/u/111228)
#### Post date: [December 18, 2019, 4:48pm UTC](https://discuss.elastic.co/t/error-fetching-fields-in-kibana/211910/3 "2019-12-18T16:48:27Z")

</div>

And how it must help me ?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 15, 2020, 4:48pm UTC](https://discuss.elastic.co/t/error-fetching-fields-in-kibana/211910/4 "2020-01-15T16:48:30Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
