# Error fetching fields

**URL:** <https://discuss.elastic.co/t/error-fetching-fields/200008>\
**Category:** Kibana\
**Created:** [September 18, 2019, 12:53pm UTC](https://discuss.elastic.co/t/error-fetching-fields/200008 "2019-09-18T12:53:52Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Josef\_Fritzer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/josef_fritzer/32/54420_2.png) [@Josef\_Fritzer](https://discuss.elastic.co/u/Josef_Fritzer)\
**Post date:** [September 18, 2019, 12:53pm UTC](https://discuss.elastic.co/t/error-fetching-fields/200008/1 "2019-09-18T12:53:52Z")

</div>

Hi guys,

I got the following error if I try to create an index pattern:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/9/6/969885a71b66827bd711f0f13428b25024169099.png)

Index size about 2.2GB  
approximately 3500 fields per document

Has anyone an idea? THANKS

---

<div class="post-metadata">

**Author:** ![alisongoryachev](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/alisongoryachev/32/111352_2.png) [@alisongoryachev](https://discuss.elastic.co/u/alisongoryachev)\
**Post date:** [September 18, 2019, 1:15pm UTC](https://discuss.elastic.co/t/error-fetching-fields/200008/2 "2019-09-18T13:15:11Z")

</div>

Hi, @Josef_Fritzer!

What version are you on? The default total fields limit is 1000. See: [https://www.elastic.co/guide/en/elasticsearch/reference/current/mapping.html#mapping-limit-settings](https://www.elastic.co/guide/en/elasticsearch/reference/current/mapping.html#mapping-limit-settings)

Also, it would be helpful to see what the request looks like using your browser's debugger.

---

<div class="post-metadata">

**Author:** ![Josef\_Fritzer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/josef_fritzer/32/54420_2.png) [@Josef\_Fritzer](https://discuss.elastic.co/u/Josef_Fritzer)\
**Post date:** [September 18, 2019, 2:02pm UTC](https://discuss.elastic.co/t/error-fetching-fields/200008/3 "2019-09-18T14:02:00Z")

</div>

Hi @alisongoryachev,

the version is 7.3.2, I have increased the index field limit to 6000. Everything works fine on 6.6.0, there was no problem creating the pattern even with a much larger index.

Which of the requests do you wanna see:  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/7/770f74158b683b619e95995daf8c027c0033fd89.png)

thanks

---

<div class="post-metadata">

**Author:** ![Josef\_Fritzer](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/josef_fritzer/32/54420_2.png) [@Josef\_Fritzer](https://discuss.elastic.co/u/Josef_Fritzer)\
**Post date:** [September 19, 2019, 4:55am UTC](https://discuss.elastic.co/t/error-fetching-fields/200008/4 "2019-09-19T04:55:44Z")

</div>

SOLVED [Kibana 5.1.2/ES 5.1.2 - Index patterns with more than 1000 fields](https://discuss.elastic.co/t/kibana-5-1-2-es-5-1-2-index-patterns-with-more-than-1000-fields/72567) the problem was in my case the reindexing from my 6.6.0 index to my new 7.3.2 one. I solved the problem by adding a single document(from the old index) to the new index before starting the reindex process. That's it 😊😇

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 17, 2019, 4:55am UTC](https://discuss.elastic.co/t/error-fetching-fields/200008/5 "2019-10-17T04:55:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
