# Error Filebeats in kubernetes

**URL:** <https://discuss.elastic.co/t/error-filebeats-in-kubernetes/198853>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [September 10, 2019, 8:56am UTC](https://discuss.elastic.co/t/error-filebeats-in-kubernetes/198853 "2019-09-10T08:56:01Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![florenzo](https://avatars.discourse-cdn.com/v4/letter/f/dc4da7/32.png) [@florenzo](https://discuss.elastic.co/u/florenzo)\
**Post date:** [September 10, 2019, 8:56am UTC](https://discuss.elastic.co/t/error-filebeats-in-kubernetes/198853/1 "2019-09-10T08:56:02Z")

</div>

im trying to install filebat over kubernetes in a Openshift environment . the idea is use it instead openshift fluentd  
my environment is Openshift 3.6 with kubernetes 1.6 .  
ok i followed this guide [https://www.elastic.co/guide/en/beats/filebeat/master/running-on-kubernetes.html](https://www.elastic.co/guide/en/beats/filebeat/master/running-on-kubernetes.html)  
but it fails with the following error  
kubernetes: Performing a resource sync err decode error status 403: cannot decode json payload into protobuf object for \*v1.PodList

Any help is appreciate

---

<div class="post-metadata">

**Author:** ![florenzo](https://avatars.discourse-cdn.com/v4/letter/f/dc4da7/32.png) [@florenzo](https://discuss.elastic.co/u/florenzo)\
**Post date:** [September 11, 2019, 6:37am UTC](https://discuss.elastic.co/t/error-filebeats-in-kubernetes/198853/2 "2019-09-11T06:37:44Z")

</div>

Forget it . problem is solved  
documentation is only valid for ocp versions over 3.6  
[https://www.elastic.co/guide/en/beats/filebeat/master/running-on-kubernetes.html](https://www.elastic.co/guide/en/beats/filebeat/master/running-on-kubernetes.html)  
you will have to modify filebeat-kubernetes.yaml and change apiVersion for ClusterRoleBinding and ClusterRole

```auto
sed "s%rbac.authorization.k8s.io/v1%v1%" filebeat-kubernetes.yaml 

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 9, 2019, 6:37am UTC](https://discuss.elastic.co/t/error-filebeats-in-kubernetes/198853/3 "2019-10-09T06:37:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
