# Error for logstash.conf

**URL:** <https://discuss.elastic.co/t/error-for-logstash-conf/286400>\
**Category:** Logstash\
**Created:** [October 11, 2021, 6:44pm UTC](https://discuss.elastic.co/t/error-for-logstash-conf/286400 "2021-10-11T18:44:47Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Johnny\_Cash\_Cow](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/johnny_cash_cow/32/78919_2.png) [@Johnny\_Cash\_Cow](https://discuss.elastic.co/u/Johnny_Cash_Cow)\
**Post date:** [October 11, 2021, 6:44pm UTC](https://discuss.elastic.co/t/error-for-logstash-conf/286400/1 "2021-10-11T18:44:47Z")

</div>

The only non-commented out line of my logstash.conf is:

```auto
  path.config: "C:/ELK/logstash-7.15.0-windows-x86_64/logstash-7.15.0/config/logstash-sample.conf"

```

My only non commented out section is of my pipeline.yml:

```auto
- pipeline.id: log_files
#
# # The configuration string to be used by this pipeline
# config.string: "input { generator {} } filter { sleep { time => 1 } } output { stdout { codec => dots } }"

# # The path from where to read the configuration text
  path.config: "C:/ELK/logstash-7.15.0-windows-x86_64/logstash-7.15.0/config/logstash-sample.conf"

```

If I simply run `logstash.bat` within the bin:

```auto
[2021-10-11T14:40:51,933][ERROR][logstash.config.sourceloader] No configuration found in the configured sources.

```

If I run: `logstash.bat -f C:\ELK\logstash-7.15.0-windows-x86_64\logstash-7.15.0\config\logstash-sample.conf`

```auto
C:\ELK\logstash-7.15.0-windows-x86_64\logstash-7.15.0\bin>logstash.bat -f C:\ELK\logstash-7.15.0-windows-x86_64\logstash-7.15.0\config\logstash-sample.conf
"Using bundled JDK: ""
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Sending Logstash logs to C:/ELK/logstash-7.15.0-windows-x86_64/logstash-7.15.0/logs which is now configured via log4j2.properties
[2021-10-11T14:38:51,311][INFO][logstash.runner] Log4j configuration path used is: C:\ELK\logstash-7.15.0-windows-x86_64\logstash-7.15.0\config\log4j2.properties
[2021-10-11T14:38:51,327][INFO][logstash.runner] Starting Logstash {"logstash.version"=>"7.15.0", "jruby.version"=>"jruby 9.2.19.0 (2.5.8) 2021-06-15 55810c552b OpenJDK 64-Bit Server VM 11.0.11+9 on 11.0.11+9 +indy +jit [mswin32-x86_64]"}
[2021-10-11T14:38:51,421][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified
[2021-10-11T14:38:53,230][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=>9600}
[2021-10-11T14:38:53,465][ERROR][logstash.agent] Failed to execute action {:action=>LogStash::PipelineAction::Create/pipeline_id:main, :exception=>"LogStash::ConfigurationError", :message=>"Expected one of [\\t\\r\\n], \"#\", [A-Za-z0-9_-], '\"', \"'\", [A-Za-z_], \"-\", [0-9], \"[\", \"{\" at line 13, column 37 (byte 250) after filter{\ncsv{\nseparator=>\",\"\ncolumns=>[\"ip\",\"date\",\"time\",\"zone\",", :backtrace=>["C:/ELK/logstash-7.15.0-windows-x86_64/logstash-7.15.0/logstash-core/lib/logstash/compiler.rb:32:in `compile_imperative'", "org/logstash/execution/AbstractPipelineExt.java:187:in `initialize'", "org/logstash/execution/JavaBasePipelineExt.java:72:in `initialize'", "C:/ELK/logstash-7.15.0-windows-x86_64/logstash-7.15.0/logstash-core/lib/logstash/java_pipeline.rb:47:in `initialize'", "C:/ELK/logstash-7.15.0-windows-x86_64/logstash-7.15.0/logstash-core/lib/logstash/pipeline_action/create.rb:52:in `execute'", "C:/ELK/logstash-7.15.0-windows-x86_64/logstash-7.15.0/logstash-core/lib/logstash/agent.rb:391:in `block in converge_state'"]}
[2021-10-11T14:38:53,559][INFO][logstash.runner] Logstash shut down.
[2021-10-11T14:38:53,575][FATAL][org.logstash.Logstash] Logstash stopped processing because of an error: (SystemExit) exit
org.jruby.exceptions.SystemExit: (SystemExit) exit
        at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:747) ~[jruby-complete-9.2.19.0.jar:?]
        at org.jruby.RubyKernel.exit(org/jruby/RubyKernel.java:710) ~[jruby-complete-9.2.19.0.jar:?]
        at C_3a_.ELK.logstash_minus_7_dot_15_dot_0_minus_windows_minus_x86_64.logstash_minus_7_dot_15_dot_0.lib.bootstrap.environment.<main>(C:\ELK\logstash-7.15.0-windows-x86_64\logstash-7.15.0\lib\bootstrap\environment.rb:94) ~[?:?]

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 8, 2021, 6:45pm UTC](https://discuss.elastic.co/t/error-for-logstash-conf/286400/2 "2021-11-08T18:45:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
