# Error from \_cat APIs: Values less than -1 bytes are not supported

**URL:** <https://discuss.elastic.co/t/error-from-cat-apis-values-less-than-1-bytes-are-not-supported/220071>\
**Category:** Elasticsearch\
**Created:** [February 20, 2020, 2:54am UTC](https://discuss.elastic.co/t/error-from-cat-apis-values-less-than-1-bytes-are-not-supported/220071 "2020-02-20T02:54:02Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![anon17386273](https://avatars.discourse-cdn.com/v4/letter/a/d2c977/32.png) [@anon17386273](https://discuss.elastic.co/u/anon17386273)\
**Post date:** [February 20, 2020, 2:54am UTC](https://discuss.elastic.co/t/error-from-cat-apis-values-less-than-1-bytes-are-not-supported/220071/1 "2020-02-20T02:54:03Z")

</div>

Elasticsearch cluster running 7.1.1. I was adding/removing some nodes to the cluster, but no other config changes took place. The `_cat/nodes` and `_cat/indices` API started returning an error as below

```auto
$ curl localhost:9200/_cat/nodes
{"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"Values less than -1 bytes are not supported: -9223372036854752403b"}],"type":"illegal_argument_exception","reason":"Values less than -1 bytes are not supported: -9223372036854752403b"},"status":400}

```

I used curl localhost:9200/nodes/\_local/stats?error\_trace=true and this error:

```auto
$ curl http://localhost:9200/nodes/_local/stats?error_trace=true
{"error":{"root_cause":[{"type":"index_not_found_exception","reason":"no such index [nodes]","resource.type":"index_expression","resource.id":"nodes","index_uuid":"_na_","index":"nodes","stack_trace":"[nodes] IndexNotFoundException[no such index [nodes]]

```

Any help is appreciated on this

Thank you!

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [February 20, 2020, 8:40am UTC](https://discuss.elastic.co/t/error-from-cat-apis-values-less-than-1-bytes-are-not-supported/220071/2 "2020-02-20T08:40:24Z")

</div>

Hey,

there has been a fix for something like this in later versions, see [https://github.com/elastic/elasticsearch/pull/42725](https://github.com/elastic/elasticsearch/pull/42725)

Do you have the possibility to upgrade your cluster?

--Alex

---

<div class="post-metadata">

**Author:** ![anon17386273](https://avatars.discourse-cdn.com/v4/letter/a/d2c977/32.png) [@anon17386273](https://discuss.elastic.co/u/anon17386273)\
**Post date:** [February 20, 2020, 9:03am UTC](https://discuss.elastic.co/t/error-from-cat-apis-values-less-than-1-bytes-are-not-supported/220071/3 "2020-02-20T09:03:32Z")

</div>

Hi Alex

Thanks for replying. Which version will this be resolved?  
I deployed my cluster using tar files

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [February 20, 2020, 9:11am UTC](https://discuss.elastic.co/t/error-from-cat-apis-values-less-than-1-bytes-are-not-supported/220071/4 "2020-02-20T09:11:10Z")

</div>

the best would be to update to the latest 7.x version, 7.6.0 as of today.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 19, 2020, 9:11am UTC](https://discuss.elastic.co/t/error-from-cat-apis-values-less-than-1-bytes-are-not-supported/220071/5 "2020-03-19T09:11:12Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
