# Error from watcher in Elasticsearch

**URL:** <https://discuss.elastic.co/t/error-from-watcher-in-elasticsearch/118059>\
**Category:** Elasticsearch\
**Created:** [February 1, 2018, 4:04pm UTC](https://discuss.elastic.co/t/error-from-watcher-in-elasticsearch/118059 "2018-02-01T16:04:10Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![cavramescu](https://avatars.discourse-cdn.com/v4/letter/c/8c91f0/32.png) [@cavramescu](https://discuss.elastic.co/u/cavramescu)\
**Post date:** [February 1, 2018, 4:04pm UTC](https://discuss.elastic.co/t/error-from-watcher-in-elasticsearch/118059/1 "2018-02-01T16:04:10Z")

</div>

After upgrading from one node to three nodes on my elasticsearch cluster and install x-pack i run a weird error , when trying to access the watcher from kibana , and also when i try to create a new watch  
\<-

> trying to auto create mapping, but dynamic mapping is disabled

I researched i little bit and i changed the index.mapping.dynamic to true :

> {  
> "index" : {  
> "mapper": {  
> "dynamic" : true  
> }  
> }  
> }

but is still giving me the error . What should i do ?

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 1, 2018, 11:21pm UTC](https://discuss.elastic.co/t/error-from-watcher-in-elasticsearch/118059/2 "2018-02-01T23:21:27Z")

</div>

Please post the entire error and let us know what version you are on.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 1, 2018, 11:21pm UTC](https://discuss.elastic.co/t/error-from-watcher-in-elasticsearch/118059/3 "2018-03-01T23:21:27Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
