# Error generating report for Dashboard

**URL:** <https://discuss.elastic.co/t/error-generating-report-for-dashboard/105008>\
**Category:** Elasticsearch\
**Created:** [October 24, 2017, 8:04am UTC](https://discuss.elastic.co/t/error-generating-report-for-dashboard/105008 "2017-10-24T08:04:52Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![karnamonkster](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/karnamonkster/32/67266_2.png) [@karnamonkster](https://discuss.elastic.co/u/karnamonkster)\
**Post date:** [October 24, 2017, 8:04am UTC](https://discuss.elastic.co/t/error-generating-report-for-dashboard/105008/1 "2017-10-24T08:04:52Z")

</div>

Hello,

I am facing issues generating PDF report for Dashboards and visualizations.  
Attached is the error

 ![Kibana Reporting Error](https://us1.discourse-cdn.com/elastic/original/3X/9/6/96d10ead16fa3d24395cfd5078adf605d86f11d8.JPG)

System Details: Kibana 5.6.2 (Single Instance)  
ES: 5.6.2

---

<div class="post-metadata">

**Author:** ![karnamonkster](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/karnamonkster/32/67266_2.png) [@karnamonkster](https://discuss.elastic.co/u/karnamonkster)\
**Post date:** [October 26, 2017, 9:40am UTC](https://discuss.elastic.co/t/error-generating-report-for-dashboard/105008/2 "2017-10-26T09:40:41Z")

</div>

Anyone who came across this issue?

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [October 26, 2017, 11:21am UTC](https://discuss.elastic.co/t/error-generating-report-for-dashboard/105008/3 "2017-10-26T11:21:17Z")

</div>

Hi,

Yes, I faced this issue also (or at least similar) whats you config in kibana.yml looks like? I have set the following:

xpack.reporting.encryptionKey: nQPdxkCTVTZ4Os0ihhOaGwGXqavih4N7  
xpack.reporting.kibanaServer.hostname: \< my fqdn \>  
xpack.reporting.queue.timeout: 60000  
xpack.reporting.kibanaServer.protocol: http

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [October 26, 2017, 12:04pm UTC](https://discuss.elastic.co/t/error-generating-report-for-dashboard/105008/4 "2017-10-26T12:04:26Z")

</div>

Are you guys running Kibana behind a reverse proxy? If so, this requires some additional settings be set in the `kibana.yml`. Reporting uses a headless browser to take the screenshots of Kibana, so it has to know a few things about your environment via the `kibana.yml`.

The most common settings that need to be set are:

- `xpack.reporting.kibanaServer.protocol` to the protocol that the reverse proxy is using (https/http)
- `xpack.reporting.kibanaServer.hostname` to the hostname of the reverse proxy fully qualified domain name
- `xpack.reporting.kibanaServer.port` to the port that the reverse proxy is listening, 80 or 443 most commonly

There's one other potential issue that might be causing this behavior, are you only seeing these Timeouts when using Tilemaps?

---

<div class="post-metadata">

**Author:** ![karnamonkster](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/karnamonkster/32/67266_2.png) [@karnamonkster](https://discuss.elastic.co/u/karnamonkster)\
**Post date:** [November 14, 2017, 4:19am UTC](https://discuss.elastic.co/t/error-generating-report-for-dashboard/105008/5 "2017-11-14T04:19:16Z")

</div>

Figured to set the key, also followed the steps mentioned by @Brandon_Kobel  
Now i am getting an error: **HeadlessError: Phantom Process died**

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [November 20, 2017, 1:33pm UTC](https://discuss.elastic.co/t/error-generating-report-for-dashboard/105008/6 "2017-11-20T13:33:12Z")

</div>

@karnamonkster we've generally seen this occur when there isn't enough CPU/Memory on the server running Kibana to support spawning and running PhantomJS (our headless browser) that takes the screenshots itself. Would you mind seeing how much CPU/Memory is available on that server?

---

<div class="post-metadata">

**Author:** ![karnamonkster](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/karnamonkster/32/67266_2.png) [@karnamonkster](https://discuss.elastic.co/u/karnamonkster)\
**Post date:** [November 21, 2017, 4:13am UTC](https://discuss.elastic.co/t/error-generating-report-for-dashboard/105008/7 "2017-11-21T04:13:53Z")

</div>

Hi @Brandon_Kobel

I have the following on my Kibana instance  
OS Free Memory: 4.3 GB  
Version: 5.6.2

---

<div class="post-metadata">

**Author:** ![Brandon\_Kobel](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/brandon_kobel/32/14829_2.png) [@Brandon\_Kobel](https://discuss.elastic.co/u/Brandon_Kobel)\
**Post date:** [November 21, 2017, 1:22pm UTC](https://discuss.elastic.co/t/error-generating-report-for-dashboard/105008/8 "2017-11-21T13:22:19Z")

</div>

@karnamonkster is Kibana running on it's own server/VM? How does the CPU utilization look before/during Reporting execution? If you create a simple Markdown Visualization, do you see the same behavior?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 19, 2017, 1:22pm UTC](https://discuss.elastic.co/t/error-generating-report-for-dashboard/105008/9 "2017-12-19T13:22:29Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
