# Error importing Kibana dashboards

**URL:** <https://discuss.elastic.co/t/error-importing-kibana-dashboards/260382>\
**Category:** Kibana\
**Tags:** docker\
**Created:** [January 6, 2021, 7:25pm UTC](https://discuss.elastic.co/t/error-importing-kibana-dashboards/260382 "2021-01-06T19:25:00Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![KelvUK](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kelvuk/32/81796_2.png) [@KelvUK](https://discuss.elastic.co/u/KelvUK)\
**Post date:** [January 6, 2021, 7:25pm UTC](https://discuss.elastic.co/t/error-importing-kibana-dashboards/260382/1 "2021-01-06T19:25:00Z")

</div>

Hi, I'm new to Elastic & Kibana so this I expect is very much bad config but I can't figure out what I've gotten wrong with this.

Everything is in docker, I've a single-node deployment with transport security configured and using basic auth via the built-in accounts. Metric & filebeats are working fine except I can't get the dashboards to import via the `setup.dashboard` config in the .yml files. The error I get is the same from both beats containers and is below...

`2021-01-06T18:34:16.981Z	ERROR	instance/beat.go:956	Exiting: Error importing Kibana dashboards: fail to import the dashboards in Kibana: Error importing directory /usr/share/metricbeat/kibana: failed to import Kibana index pattern: 1 error: error loading index pattern: returned 500 to import file: <nil>. Response: {"statusCode":500,"error":"Internal Server Error","message":"An internal server error occurred."}`

I've attributed this topic against Kibana but this could be something wrong my config in metric/file beats?

Also I'm not confident I've correctly implemented transport security although everything is functioning normally from what I can tell and I'm not getting/seeing any errors other than the reason for this post?

**metricbeat.yml:**

```
seccomp.enabled: false

path.config: "/usr/share/metricbeat/config/"
path.data: "/usr/share/metricbeat/data/"
keystore.path: "${path.config}/metricbeats.keystore"

monitoring.enabled: false
monitoring.cluster_uuid: "I5NPSd8MRuGLDRhSX5rRaw"

http.enabled: true
http.host: localhost
http.port: 5066

metricbeat.config.modules:
  path: "${path.config}/modules/*.yml"
  reload.period: 10s
  reload.enabled: true

output.elasticsearch:
  protocol: "https"
  hosts: "*es.mydomain.com*:9200"
  username: elastic
  password: "*password*"
  ssl.verification_mode: full
  ssl.certificate_authorities: "/usr/share/metricbeat/config/certs/ca.crt"

setup:
  dashboards:
    enabled: false
    #index: metricbeat-*
  kibana:
    host: "*kibana.mydomain.com*:5601"
    protocol: "http"
    path: ""
    username: "kibana_system"
    password: "*password*"

```

**elasticsearch.yml:**

```
cluster.name: "blacknas"
node.name: "elasticsearch"
network.host: 0.0.0.0
bootstrap.system_call_filter: false
xpack.monitoring.collection.enabled: false
discovery.type: single-node
xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate 
xpack.security.transport.ssl.key: /usr/share/elasticsearch/config/certs/elasticsearch.key
xpack.security.transport.ssl.certificate: /usr/share/elasticsearch/config/certs/elasticsearch.crt 
xpack.security.transport.ssl.certificate_authorities: /usr/share/elasticsearch/config/certs/ca/ca.crt
xpack.security.http.ssl.enabled: true
xpack.security.http.ssl.keystore.path: "/usr/share/elasticsearch/config/certs/http/elasticsearch/http.p12"

```

**kibana.yml:**

```
server.name: kibana
server.host: 0.0.0.0
server.port: 5601
path.data: /usr/share/kibana/config/
elasticsearch.hosts: "*https://es.mydomain.com*:9200"
elasticsearch.username: "kibana_system"
elasticsearch.password: "*password*"
#monitoring.kibana.collection.enabled: false
elasticsearch.ssl.certificateAuthorities: "/usr/share/kibana/config/certs/elasticsearch-ca.pem"

```

Would appreicate any help etc so thanks in advance.

K

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 6, 2021, 8:25pm UTC](https://discuss.elastic.co/t/error-importing-kibana-dashboards/260382/2 "2021-01-06T20:25:32Z")

</div>

Welcome to our community! 😃

What do the Kibana logs show?

---

<div class="post-metadata">

**Author:** ![KelvUK](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kelvuk/32/81796_2.png) [@KelvUK](https://discuss.elastic.co/u/KelvUK)\
**Post date:** [January 6, 2021, 8:34pm UTC](https://discuss.elastic.co/t/error-importing-kibana-dashboards/260382/3 "2021-01-06T20:34:27Z")

</div>

Thanks for the welcome!

I was just about to follow up...as I found the cause of the issue to be the user account I defined in the beat .yml...I'd assumed the built-in `kibana_system` user would carry sufficient privileges for dashboard import but it doesn't, using the built-in `elastic`/superuser account works for the moment.

Sorry for the time waste.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 3, 2021, 8:34pm UTC](https://discuss.elastic.co/t/error-importing-kibana-dashboards/260382/4 "2021-02-03T20:34:31Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
