# Error in autodiscover provider settings - unexpected type \<nil\>

**URL:** <https://discuss.elastic.co/t/error-in-autodiscover-provider-settings-unexpected-type-nil/224082>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [March 18, 2020, 11:03am UTC](https://discuss.elastic.co/t/error-in-autodiscover-provider-settings-unexpected-type-nil/224082 "2020-03-18T11:03:41Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Anto74](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/anto74/32/64647_2.png) [@Anto74](https://discuss.elastic.co/u/Anto74)\
**Post date:** [March 18, 2020, 11:03am UTC](https://discuss.elastic.co/t/error-in-autodiscover-provider-settings-unexpected-type-nil/224082/1 "2020-03-18T11:03:42Z")

</div>

Hi,

I'm deploying my filebeat to collect log in a specific namespace. My chart looks like the following:

autodiscover:  
enabled: true  
namespace: ".RELEASE.NAMESPACE"  
logplane: kubelog  
json:  
enabled: true  
target: "json"  
hints:  
enabled: false  
inclusions:  
# - field: "kubernetes.annotations.collect"  
# value: "true"  
exclusions:  
# - field: "kubernetes.annotations.drop"  
# value: "true"

After installation I see my filebeat running (container created correctly) , but no logs is sent out to logstash. The logs reports the following periodic error:  
ERROR  
instance/beat.go:911  
Exiting: error in autodiscover settings: unexpected type of

Can anyone help?

Regards,  
Antonio

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 15, 2020, 11:03am UTC](https://discuss.elastic.co/t/error-in-autodiscover-provider-settings-unexpected-type-nil/224082/2 "2020-04-15T11:03:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
