# Error In Elasticsearch After enable security on Window

**URL:** <https://discuss.elastic.co/t/error-in-elasticsearch-after-enable-security-on-window/189975>\
**Category:** Elasticsearch\
**Created:** [July 11, 2019, 10:39am UTC](https://discuss.elastic.co/t/error-in-elasticsearch-after-enable-security-on-window/189975 "2019-07-11T10:39:33Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sharma3007](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sharma3007/32/43414_2.png) [@Sharma3007](https://discuss.elastic.co/u/Sharma3007)\
**Post date:** [July 11, 2019, 10:39am UTC](https://discuss.elastic.co/t/error-in-elasticsearch-after-enable-security-on-window/189975/1 "2019-07-11T10:39:33Z")

</div>

Hi Team,  
I am getting below error while running elastic search after enable security 🙂

2019-07-11T12:30:59,252][ERROR][o.e.b.Bootstrap] [CMSDEV] node validation exception  
[1] bootstrap checks failed  
[1]: Transport SSL must be enabled if security is enabled on a [basic] license. Please set [xpack.security.transport.ssl.enabled] to [true] or disable security by setting [xpack.security.enabled] to [false]

below are the my elasticsearch yaml file configuration:

```
bootstrap.memory_lock: true
cluster.name: logging-dev
network.host: 0.0.0.0
network.bind_host: 0.0.0.0
network.publish_host: 0.0.0.0
http.port: 9200
node.data: true
node.ingest: true
node.master: true
node.max_local_storage_nodes: 3
node.name: CMSDEV
path.data: D:\ElasticStack\Elasticsearch\data
path.logs: D:\ElasticStack\Elasticsearch\logs
transport.tcp.port: 9300
xpack.license.self_generated.type: basic
xpack.security.enabled: true
cluster.initial_master_nodes: node-1

xpack.security.http.ssl.enabled: true
xpack.security.http.ssl.keystore.path: certs/elastic-certificates.p12 
xpack.security.http.ssl.truststore.path: certs/elastic-certificates.p12
```

---

<div class="post-metadata">

**Author:** ![ylasri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ylasri/32/86120_2.png) [@ylasri](https://discuss.elastic.co/u/ylasri)\
**Post date:** [July 11, 2019, 10:41am UTC](https://discuss.elastic.co/t/error-in-elasticsearch-after-enable-security-on-window/189975/2 "2019-07-11T10:41:31Z")

</div>

check this post [XPACK Security in ELK stack 7.1.1](https://discuss.elastic.co/t/xpack-security-in-elk-stack-7-1-1/184004)

---

<div class="post-metadata">

**Author:** ![Sharma3007](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sharma3007/32/43414_2.png) [@Sharma3007](https://discuss.elastic.co/u/Sharma3007)\
**Post date:** [July 11, 2019, 11:10am UTC](https://discuss.elastic.co/t/error-in-elasticsearch-after-enable-security-on-window/189975/3 "2019-07-11T11:10:31Z")

</div>

Thanks for the reply.

I have followed all that security step after generated certificate.  
While try to run elastic search. I am getting the above error.

---

<div class="post-metadata">

**Author:** ![ylasri](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ylasri/32/86120_2.png) [@ylasri](https://discuss.elastic.co/u/ylasri)\
**Post date:** [July 11, 2019, 11:13am UTC](https://discuss.elastic.co/t/error-in-elasticsearch-after-enable-security-on-window/189975/4 "2019-07-11T11:13:06Z")

</div>

Use this note, and change your elasticsearch.yml file

```
 discovery.type: single-node

```

### Single-node discovery ([https://github.com/elastic/elasticsearch/edit/7.2/docs/reference/setup/bootstrap-checks.asciidoc](https://github.com/elastic/elasticsearch/edit/7.2/docs/reference/setup/bootstrap-checks.asciidoc))

We recognize that some users need to bind transport to an external interface for testing their usage of the transport client. For this situation, we provide the discovery type `single-node` (configure it by setting `discovery.type` to `single-node` ); in this situation, a node will elect itself master and will not join a cluster with any other node.

---

<div class="post-metadata">

**Author:** ![Sharma3007](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/sharma3007/32/43414_2.png) [@Sharma3007](https://discuss.elastic.co/u/Sharma3007)\
**Post date:** [July 12, 2019, 5:16am UTC](https://discuss.elastic.co/t/error-in-elasticsearch-after-enable-security-on-window/189975/5 "2019-07-12T05:16:25Z")

</div>

Thanks @ylasri,

Its working now. I was missing this configuration.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 9, 2019, 5:27am UTC](https://discuss.elastic.co/t/error-in-elasticsearch-after-enable-security-on-window/189975/6 "2019-08-09T05:27:49Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
