# Error in Elasticsearch master pod that FileSystemException: /data/log: Input/output error

**URL:** <https://discuss.elastic.co/t/error-in-elasticsearch-master-pod-that-filesystemexception-data-log-input-output-error/270379>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [April 16, 2021, 11:32am UTC](https://discuss.elastic.co/t/error-in-elasticsearch-master-pod-that-filesystemexception-data-log-input-output-error/270379 "2021-04-16T11:32:35Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![subha1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/subha1/32/45343_2.png) [@subha1](https://discuss.elastic.co/u/subha1)\
**Post date:** [April 16, 2021, 11:32am UTC](https://discuss.elastic.co/t/error-in-elasticsearch-master-pod-that-filesystemexception-data-log-input-output-error/270379/1 "2021-04-16T11:32:35Z")

</div>

I found the below error logs in Elasticsearch master pod logs-

```auto

Caused by: java.lang.IllegalStateException: Unable to access 'path.logs' (/data/log)
        at org.elasticsearch.bootstrap.FilePermissionUtils.addDirectoryPath(FilePermissionUtils.java:70) ~[elasticsearch-7.8.0.jar:7.8.0]
        at org.elasticsearch.bootstrap.Security.addFilePermissions(Security.java:290) ~[elasticsearch-7.8.0.jar:7.8.0]
        at org.elasticsearch.bootstrap.Security.createPermissions(Security.java:252) ~[elasticsearch-7.8.0.jar:7.8.0]
        at org.elasticsearch.bootstrap.Security.configure(Security.java:121) ~[elasticsearch-7.8.0.jar:7.8.0]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:222) ~[elasticsearch-7.8.0.jar:7.8.0]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:393) ~[elasticsearch-7.8.0.jar:7.8.0]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) ~[elasticsearch-7.8.0.jar:7.8.0]
        ... 6 more
Caused by: java.nio.file.FileSystemException: /data/log: Input/output error

```

ES version deployed : 7.8.0  
when login to master pod & check

```auto

[elasticsearch@elasticsearch-master-1 ~]$ ls /data/ -ld
drwxrwsr-x. 5 root elasticsearch 4096 Mar 24 21:18 /data/
[elasticsearch@elasticsearch-master-1 ~]$ ls /data/log -ld
drwxrwsr-x. 2 elasticsearch elasticsearch 4096 Mar 24 21:18 /data/log

```

Could you please help to find the cause for this issue?

---

<div class="post-metadata">

**Author:** ![subha1](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/subha1/32/45343_2.png) [@subha1](https://discuss.elastic.co/u/subha1)\
**Post date:** [April 19, 2021, 9:02am UTC](https://discuss.elastic.co/t/error-in-elasticsearch-master-pod-that-filesystemexception-data-log-input-output-error/270379/2 "2021-04-19T09:02:40Z")

</div>

is there update for this issue? could someone help in debug?

---

<div class="post-metadata">

**Author:** ![DavidTurner](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/davidturner/32/22453_2.png) [@DavidTurner](https://discuss.elastic.co/u/DavidTurner)\
**Post date:** [April 19, 2021, 11:15am UTC](https://discuss.elastic.co/t/error-in-elasticsearch-master-pod-that-filesystemexception-data-log-input-output-error/270379/3 "2021-04-19T11:15:59Z")

</div>

> [@subha1](#):
>
> `Input/output error`

This means the operating system returned `EIO` from some kind of IO operation, which indicates a fundamental problem in your storage. You've deleted the bit of the stack trace that says what operation failed, but that's not normally very important anyway. Maybe check `dmesg` to see if there are any kernel logs indicating storage problems.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 17, 2021, 11:16am UTC](https://discuss.elastic.co/t/error-in-elasticsearch-master-pod-that-filesystemexception-data-log-input-output-error/270379/4 "2021-05-17T11:16:13Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
