# Error in Netty pipeline: java.io.IOException: Connection reset by peer

**URL:** https://discuss.elastic.co/t/error-in-netty-pipeline-java-io-ioexception-connection-reset-by-peer/283606
**Category:** Logstash
**Tags:** docker
**Created:** [September 8, 2021, 5:04am UTC](https://discuss.elastic.co/t/error-in-netty-pipeline-java-io-ioexception-connection-reset-by-peer/283606 "2021-09-08T05:04:23Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![smm](https://avatars.discourse-cdn.com/v4/letter/s/bb73d2/32.png) [@smm](https://discuss.elastic.co/u/smm)
#### Post date: [September 8, 2021, 5:04am UTC](https://discuss.elastic.co/t/error-in-netty-pipeline-java-io-ioexception-connection-reset-by-peer/283606/1 "2021-09-08T05:04:23Z")

</div>

Dear community,  
in my logstash 7.8.1 logs I get this error message quite a lot:  
[2021-09-07T08:36:56,031][ERROR][logstash.inputs.tcp][main] Error in Netty pipeline: java.io.IOException: Connection reset by peer  
It only occurs when data is sent from google/kubernetes.  
Also: In these cases we have data loss.

Do you know a reason and / or a workaround for this?

Our input plugin part looks like this:

```auto
input {

  redis {
    host => "127.0.0.1"
    data_type => "list"
    key => "logstash"
    codec => json
    threads => 8
    add_field => { "[@metadata][datatype]" => "log" }
  }

  redis {
    host => "127.0.0.1"
    data_type => "list"
    key => "filebeat"
    codec => json
    threads => 6
    add_field => { "[@metadata][datatype]" => "log" }
  }

  redis {
    host => "127.0.0.1"
    data_type => "list"
    key => "winlogbeat"
    codec => json
    threads => 1
    add_field => { "[@metadata][datatype]" => "log" }
  }

  redis {
    host => "127.0.0.1"
    data_type => "list"
    key => "beat"
    codec => json
    threads => 4
    add_field => { "[@metadata][datatype]" => "beat" }
  }

  beats {
    id => "beats-input"
    port => 5044
    add_field => { "[@metadata][indexprefix]" => "%{[@metadata][beat]}-%{[@metadata][version]}" }
  }
  
  tcp {
    port => 5518
    codec => "fluent"
    tcp_keep_alive => true
    tags => ['basic','docker','json']
  }
}

```

Could be some kind of timeout / too much data problem.

Thanks for any insight you can give in this!  
Cheers

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 6, 2021, 5:05am UTC](https://discuss.elastic.co/t/error-in-netty-pipeline-java-io-ioexception-connection-reset-by-peer/283606/2 "2021-10-06T05:05:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
