# Error in Taking Snapshot

**URL:** <https://discuss.elastic.co/t/error-in-taking-snapshot/161273>\
**Category:** Elasticsearch\
**Created:** [December 18, 2018, 8:02am UTC](https://discuss.elastic.co/t/error-in-taking-snapshot/161273 "2018-12-18T08:02:57Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![paul1243](https://avatars.discourse-cdn.com/v4/letter/p/e99b99/32.png) [@paul1243](https://discuss.elastic.co/u/paul1243)\
**Post date:** [December 18, 2018, 8:02am UTC](https://discuss.elastic.co/t/error-in-taking-snapshot/161273/1 "2018-12-18T08:02:57Z")

</div>

I updated the path.repo to a Windows shared drive folder and tried starting the ElasticSearch, I get the below error message:

```auto
path.repo: ["\\\\10. **.**.***\\Snapshots"]

```

```auto
[2018-12-18T07:41:37,014][ERROR][o.e.b.Bootstrap] Exception
java.lang.IllegalStateException: Unable to access 'path.repo' (\\10. **.**.***\Snapshots\)
	at org.elasticsearch.bootstrap.Security.addPath(Security.java:379) ~[elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.bootstrap.Security.addFilePermissions(Security.java:267) ~[elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.bootstrap.Security.createPermissions(Security.java:215) ~[elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.bootstrap.Security.configure(Security.java:121) ~[elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:209) ~[elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:306) [elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:121) [elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:112) [elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.cli.SettingCommand.execute(SettingCommand.java:54) [elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:96) [elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.cli.Command.main(Command.java:62) [elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:89) [elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:82) [elasticsearch-5.1.1.jar:5.1.1]
Caused by: java.nio.file.FileSystemException: \\10. **.**.***\Snapshots\: 

	at java.nio.file.Files.createDirectories(Files.java:756) ~[?:1.8.0_111]
	at org.elasticsearch.bootstrap.Security.ensureDirectoryExists(Security.java:421) ~[elasticsearch-5.1.1.jar:5.1.1]
	at org.elasticsearch.bootstrap.Security.addPath(Security.java:377) ~[elasticsearch-5.1.1.jar:5.1.1]
	... 12 more

```

I could able to access the Windows UNC Path from the Elastic Search Server. Could someone please let me know how do I resolve this issue.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 15, 2019, 8:03am UTC](https://discuss.elastic.co/t/error-in-taking-snapshot/161273/2 "2019-01-15T08:03:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
