# Error:Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release

**URL:** <https://discuss.elastic.co/t/error-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/207661>\
**Category:** Elasticsearch\
**Created:** [November 13, 2019, 9:04am UTC](https://discuss.elastic.co/t/error-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/207661 "2019-11-13T09:04:17Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![pyerunka](https://avatars.discourse-cdn.com/v4/letter/p/d6d6ee/32.png) [@pyerunka](https://discuss.elastic.co/u/pyerunka)\
**Post date:** [November 13, 2019, 9:04am UTC](https://discuss.elastic.co/t/error-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/207661/1 "2019-11-13T09:04:17Z")

</div>

Hello,

Can anyone help me in this?

I am getting below error when trying to run logstash config file:

```
Java HotSpot(TM) 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
Error: Could not find or load main class version
Caused by: java.lang.ClassNotFoundException: version

```

Regards,  
Priyanka

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 11, 2019, 9:04am UTC](https://discuss.elastic.co/t/error-java-hotspot-tm-64-bit-server-vm-warning-option-useconcmarksweepgc-was-deprecated-in-version-9-0-and-will-likely-be-removed-in-a-future-release/207661/2 "2019-12-11T09:04:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
