# Error kibana 8.0 start windows

**URL:** <https://discuss.elastic.co/t/error-kibana-8-0-start-windows/298264>\
**Category:** Kibana\
**Created:** [February 25, 2022, 10:34am UTC](https://discuss.elastic.co/t/error-kibana-8-0-start-windows/298264 "2022-02-25T10:34:47Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![jdim](https://avatars.discourse-cdn.com/v4/letter/j/a183cd/32.png) [@jdim](https://discuss.elastic.co/u/jdim)\
**Post date:** [February 25, 2022, 10:34am UTC](https://discuss.elastic.co/t/error-kibana-8-0-start-windows/298264/1 "2022-02-25T10:34:47Z")

</div>

Hi,

I'm new in Elasticsearch, and i can't start kibana on my windows 10.  
I'm using the 8.0 version for Elasticsearch and kibana.

I have start Elasticsearch and i have created 1 super user and kibana system user.  
Here my config file.

```auto
# ======================== Elasticsearch Configuration =========================
#
# NOTE: Elasticsearch comes with reasonable defaults for most settings.
# Before you set out to tweak and tune the configuration, make sure you
# understand what are you trying to accomplish and the consequences.
#
# The primary way of configuring a node is via this file. This template lists
# the most important settings you may want to configure for a production cluster.
#
# Please consult the documentation for further information on configuration options:
# https://www.elastic.co/guide/en/elasticsearch/reference/index.html
#
# ---------------------------------- Cluster -----------------------------------
#
# Use a descriptive name for your cluster:
#
cluster.name: WiseElastic
#
# ------------------------------------ Node ------------------------------------
#
# Use a descriptive name for the node:
#
node.name: prod
#
# Add custom attributes to the node:
#
node.attr.rack: r1
#
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#
path.data: C:\Elastic\Elasticsearch\data
#
# Path to log files:
#
path.logs: C:\Elastic\Elasticsearch\logs
#
ingest.geoip.downloader.enabled: false
# ----------------------------------- Memory -----------------------------------
#
# Lock the memory on startup:
#
#bootstrap.memory_lock: true
#
# Make sure that the heap size is set to about half the memory available
# on the system and that the owner of the process is allowed to use this
# limit.
#
# Elasticsearch performs poorly when the system is swapping the memory.
#
# ---------------------------------- Network -----------------------------------
#
# By default Elasticsearch is only accessible on localhost. Set a different
# address here to expose this node on the network:
#
#network.host: 192.168.0.1
#
# By default Elasticsearch listens for HTTP traffic on the first free port it
# finds starting at 9200. Set a specific HTTP port here:
#
#http.port: 9200
#
# For more information, consult the network module documentation.
#
# --------------------------------- Discovery ----------------------------------
#
# Pass an initial list of hosts to perform discovery when this node is started:
# The default list of hosts is ["127.0.0.1", "[::1]"]
#
#discovery.seed_hosts: ["host1", "host2"]
#
# Bootstrap the cluster using an initial set of master-eligible nodes:
#
#cluster.initial_master_nodes: ["node-1", "node-2"]
#
# For more information, consult the discovery and cluster formation module documentation.
#
# ---------------------------------- Various -----------------------------------
#
# Allow wildcard deletion of indices:
#
#action.destructive_requires_name: false

```

When i check the health with  
curl -XGET [http://localhost:9200/\_cat/health?v](http://localhost:9200/_cat/health?v) it's green status

I when to start kibana on the same computer. Here my config :

```auto
# For more configuration options see the configuration guide for Kibana in
# https://www.elastic.co/guide/index.html

# =================== System: Kibana Server ===================
# Kibana is served by a back end server. This setting specifies the port to use.
server.port: 5601

# Specifies the address to which the Kibana server will bind. IP addresses and host names are both valid values.
# The default is 'localhost', which usually means remote machines will not be able to connect.
# To allow connections from remote users, set this parameter to a non-loopback address.
server.host: "localhost"

# Enables you to specify a path to mount Kibana at if you are running behind a proxy.
# Use the `server.rewriteBasePath` setting to tell Kibana if it should remove the basePath
# from requests it receives, and to prevent a deprecation warning at startup.
# This setting cannot end in a slash.
#server.basePath: ""

# Specifies whether Kibana should rewrite requests that are prefixed with
# `server.basePath` or require that they are rewritten by your reverse proxy.
# Defaults to `false`.
#server.rewriteBasePath: false

# Specifies the public URL at which Kibana is available for end users. If
# `server.basePath` is configured this URL should end with the same basePath.
#server.publicBaseUrl: ""

# The maximum payload size in bytes for incoming server requests.
#server.maxPayload: 1048576

# The Kibana server's name. This is used for display purposes.
#server.name: "your-hostname"

# =================== System: Kibana Server (Optional) ===================
# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
#server.ssl.enabled: false
#server.ssl.certificate: /path/to/your/server.crt
#server.ssl.key: /path/to/your/server.key

# =================== System: Elasticsearch ===================
# The URLs of the Elasticsearch instances to use for all your queries.
elasticsearch.hosts: ["http://localhost:9200"]

# If your Elasticsearch is protected with basic authentication, these settings provide
# the username and password that the Kibana server uses to perform maintenance on the Kibana
# index at startup. Your Kibana users still need to authenticate with Elasticsearch, which
# is proxied through the Kibana server.
elasticsearch.username: "kbnuser"
elasticsearch.password: "kibana"

# Kibana can also authenticate to Elasticsearch via "service account tokens".
# Service account tokens are Bearer style tokens that replace the traditional username/password based configuration.
# Use this token instead of a username/password.
# elasticsearch.serviceAccountToken: "my_token"

# Time in milliseconds to wait for Elasticsearch to respond to pings. Defaults to the value of
# the elasticsearch.requestTimeout setting.
#elasticsearch.pingTimeout: 1500

# Time in milliseconds to wait for responses from the back end or Elasticsearch. This value
# must be a positive integer.
#elasticsearch.requestTimeout: 30000

# List of Kibana client-side headers to send to Elasticsearch. To send *no* client-side
# headers, set this value to [] (an empty list).
#elasticsearch.requestHeadersWhitelist: [authorization]

# Header names and values that are sent to Elasticsearch. Any custom headers cannot be overwritten
# by client-side headers, regardless of the elasticsearch.requestHeadersWhitelist configuration.
#elasticsearch.customHeaders: {}

# Time in milliseconds for Elasticsearch to wait for responses from shards. Set to 0 to disable.
#elasticsearch.shardTimeout: 30000

# =================== System: Elasticsearch (Optional) ===================
# These files are used to verify the identity of Kibana to Elasticsearch and are required when
# xpack.security.http.ssl.client_authentication in Elasticsearch is set to required.
#elasticsearch.ssl.certificate: /path/to/your/client.crt
#elasticsearch.ssl.key: /path/to/your/client.key

# Enables you to specify a path to the PEM file for the certificate
# authority for your Elasticsearch instance.
#elasticsearch.ssl.certificateAuthorities: ["/path/to/your/CA.pem"]

# To disregard the validity of SSL certificates, change this setting's value to 'none'.
#elasticsearch.ssl.verificationMode: full

# =================== System: Logging ===================
# Set the value of this setting to off to suppress all logging output, or to debug to log everything. Defaults to 'error'
logging.root.level: debug

# Enables you to specify a file where Kibana stores log output.
# logging.appenders.default:
  # type: file
  # fileName: C:\Elastic\Kibana\kibana.log
  # layout:
    # type: json

# # Logs queries sent to Elasticsearch.
# logging.loggers:
  # - name: elasticsearch.query
    # level: debug

# # Logs http responses.
# logging.loggers:
  # - name: http.server.response
    # level: debug

# # Logs system usage information.
# logging.loggers:
  # - name: metrics.ops
    # level: debug

# =================== System: Other ===================
# The path where Kibana stores persistent data not saved in Elasticsearch. Defaults to data
#path.data: data

# Specifies the path where Kibana creates the process ID file.
#pid.file: /run/kibana/kibana.pid

# Set the interval in milliseconds to sample system and process performance
# metrics. Minimum is 100ms. Defaults to 5000.
#ops.interval: 5000

# Specifies locale to be used for all localizable strings, dates and number formats.
# Supported languages are the following: English - en , by default , Chinese - zh-CN .
#i18n.locale: "en"

# =================== Frequently used (Optional)===================

# =================== Saved Objects: Migrations ===================
# Saved object migrations run at startup. If you run into migration-related issues, you might need to adjust these settings.

# The number of documents migrated at a time.
# If Kibana can't start up or upgrade due to an Elasticsearch `circuit_breaking_exception`,
# use a smaller batchSize value to reduce the memory pressure. Defaults to 1000
# migrations.batchSize: 1000

# The maximum payload size for indexing batches of upgraded saved objects.
# To avoid migrations failing due to a 413 Request Entity Too Large response from Elasticsearch.
# This value should be lower than or equal to your Elasticsearch cluster’s `http.max_content_length`
# configuration option. Default: 100mb
# migrations.maxBatchSizeBytes: 100mb

# The number of times to retry temporary migration failures. Increase the setting
# if migrations fail frequently with a message such as `Unable to complete the [...] step after
# 15 attempts, terminating`. Defaults to 15
# migrations.retryAttempts: 15

# =================== Search Autocomplete ===================
# Time in milliseconds to wait for autocomplete suggestions from Elasticsearch.
# This value must be a whole number greater than zero. Defaults to 1000
# data.autocomplete.valueSuggestions.timeout: 1000

# Maximum number of documents loaded by each shard to generate autocomplete suggestions.
# This value must be a whole number greater than zero. Defaults to 100000
# data.autocomplete.valueSuggestions.terminateAfter: 100000

```

Here the console errors when i start kibana:

```auto
GET /_nodes?filter_path=nodes.*.version%2Cnodes.*.http.publish_address%2Cnodes.*.ip
[2022-02-25T11:23:26.872+01:00][DEBUG][elasticsearch.query.data] 200 - 117.0B
GET /_nodes?filter_path=nodes.*.version%2Cnodes.*.http.publish_address%2Cnodes.*.ip
[2022-02-25T11:23:27.007+01:00][DEBUG][elasticsearch.query.data] [TimeoutError]: Request timed out
[2022-02-25T11:23:27.009+01:00][DEBUG][savedobjects-service] [.kibana_task_manager] CREATE_NEW_TARGET RESPONSE
[2022-02-25T11:23:27.014+01:00][ERROR][savedobjects-service] [.kibana_task_manager] Action failed with 'Request timed out'. Retrying attempt 10 in 64 seconds.
[2022-02-25T11:23:27.022+01:00][INFO][savedobjects-service] [.kibana_task_manager] CREATE_NEW_TARGET -> CREATE_NEW_TARGET. took: 184062ms.
[2022-02-25T11:23:27.032+01:00][DEBUG][savedobjects-service] [.kibana_task_manager] CREATE_NEW_TARGET -> CREATE_NEW_TARGET. took: 184062ms.
[2022-02-25T11:23:27.196+01:00][DEBUG][elasticsearch.query.data] [TimeoutError]: Request timed out
[2022-02-25T11:23:27.196+01:00][DEBUG][savedobjects-service] [.kibana] CREATE_NEW_TARGET RESPONSE
[2022-02-25T11:23:27.199+01:00][ERROR][savedobjects-service] [.kibana] Action failed with 'Request timed out'. Retrying attempt 10 in 64 seconds.
[2022-02-25T11:23:27.206+01:00][INFO][savedobjects-service] [.kibana] CREATE_NEW_TARGET -> CREATE_NEW_TARGET. took: 184085ms.
[2022-02-25T11:23:27.207+01:00][DEBUG][savedobjects-service] [.kibana] CREATE_NEW_TARGET -> CREATE_NEW_TARGET. took: 184085ms.
[2022-02-25T11:23:27.421+01:00][DEBUG][metrics.ops] memory: 341.6MB uptime: 0:24:42 load:
 [0.00,0.00,0.00] mean delay: 15.856 delay histogram: { 50: 15.712; 95: 16.294; 99: 18.711 }

```

if i check shards

```auto
curl -XGET http:/localhost:9200/_cat/shards?v
index shard prirep state docs store ip node
.kibana_8.0.0_001 0 p UNASSIGNED
.kibana_task_manager_8.0.0_001 0 p UNASSIGNED

```

When i try to go the kibana page, i have this message "Kibana server is not ready yet."

Have you got an idea of the problem?

Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 25, 2022, 10:35am UTC](https://discuss.elastic.co/t/error-kibana-8-0-start-windows/298264/2 "2022-03-25T10:35:06Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
