# Error loading Monitor Management

**URL:** <https://discuss.elastic.co/t/error-loading-monitor-management/326104>\
**Category:** Synthetics\
**Tags:** docker\
**Created:** [February 21, 2023, 9:00pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104 "2023-02-21T21:00:02Z")\
**Posts on this page:** 13\
**Page:** 1

<div class="post-metadata">

**Author:** ![Juan\_Pablo\_Carvajal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juan_pablo_carvajal/32/117540_2.png) [@Juan\_Pablo\_Carvajal](https://discuss.elastic.co/u/Juan_Pablo_Carvajal)\
**Post date:** [February 21, 2023, 9:00pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/1 "2023-02-21T21:00:02Z")

</div>

Hello!

I am currently deploying synthetic monitoring for a few applications. But when trying to enable Monitor Management, I get the following message:

Error loading Monitor Management

Monitor Management settings could not be loaded. Please contact Support.

I must clarify, that elastic, kibana, and heartbeat are deployed in docker.  
 ![Screenshot_1](https://us1.discourse-cdn.com/elastic/original/3X/c/2/c28b589cc542bf15991d274358f26fadf4dea6f5.png)

Thank you so much.

---

<div class="post-metadata">

**Author:** ![shahzad31](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shahzad31/32/51637_2.png) [@shahzad31](https://discuss.elastic.co/u/shahzad31)\
**Post date:** [February 22, 2023, 9:59am UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/2 "2023-02-22T09:59:15Z")

</div>

Hello @Juan_Pablo_Carvajal Welcome to the Elastic discuss forum.

Would it be possible to share the network har file when you face the issue?

Regards

---

<div class="post-metadata">

**Author:** ![Juan\_Pablo\_Carvajal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juan_pablo_carvajal/32/117540_2.png) [@Juan\_Pablo\_Carvajal](https://discuss.elastic.co/u/Juan_Pablo_Carvajal)\
**Post date:** [February 24, 2023, 4:08pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/3 "2023-02-24T16:08:48Z")

</div>

Hello @shahzad31 . Thanks for your answer.

I am unable to send the network har file, due to corporate confidentiality.

---

<div class="post-metadata">

**Author:** ![Dominique\_Clarke](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dominique_clarke/32/92223_2.png) [@Dominique\_Clarke](https://discuss.elastic.co/u/Dominique_Clarke)\
**Post date:** [February 24, 2023, 5:03pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/4 "2023-02-24T17:03:51Z")

</div>

@Juan_Pablo_Carvajal Can you confirm the version of the Kibana you are using?

---

<div class="post-metadata">

**Author:** ![Juan\_Pablo\_Carvajal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juan_pablo_carvajal/32/117540_2.png) [@Juan\_Pablo\_Carvajal](https://discuss.elastic.co/u/Juan_Pablo_Carvajal)\
**Post date:** [February 24, 2023, 7:13pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/5 "2023-02-24T19:13:58Z")

</div>

Hello @Dominique_Clarke .

I am using kibana 8.6.0. And containerized heartbeat, also with version 8.6.0.

---

<div class="post-metadata">

**Author:** ![Dominique\_Clarke](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dominique_clarke/32/92223_2.png) [@Dominique\_Clarke](https://discuss.elastic.co/u/Dominique_Clarke)\
**Post date:** [February 24, 2023, 9:59pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/6 "2023-02-24T21:59:16Z")

</div>

@Juan_Pablo_Carvajal Thanks for the information, we're investigating.

In the meantime, could you check your Kibana server logs for any errors? The code path that handles enabling monitor management should report an error in the server if it encounters one.

---

<div class="post-metadata">

**Author:** ![Dominique\_Clarke](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dominique_clarke/32/92223_2.png) [@Dominique\_Clarke](https://discuss.elastic.co/u/Dominique_Clarke)\
**Post date:** [February 24, 2023, 10:29pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/7 "2023-02-24T22:29:30Z")

</div>

@Juan_Pablo_Carvajal do you happen to have API keys or security turned off in your Elasticsearch settings?

Monitor management requires an API key to be created in order for our global-managed testing service to communicate back with your ES cluster. Our global-managed testing service allows you to run your monitors from locations around the world, without having to manage your own infrastructure.

However, global-managed testing locations are only available on Elasticsearch Service cluster. Since you are self-hosting your deployment, you wouldn't be able to utilize our global managed testing service to run your monitors. This makes requiring API keys to be enabled unnecessary.

Instead, you can utilize private locations and use your own managed elastic-agent and Fleet setup to run your monitors.

If it is indeed an issue with API keys being enabled on your cluster, you should find an error in your Kibana logs stating such. It should look something like " Error: Please enable API keys in kibana to use synthetics service."

Let us know if this is your challenge. We'll create a issue to tackle not requiring API keys to be enabled for self-hosted clusters.

---

<div class="post-metadata">

**Author:** ![Gunter\_Van\_Damme](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gunter_van_damme/32/117865_2.png) [@Gunter\_Van\_Damme](https://discuss.elastic.co/u/Gunter_Van_Damme)\
**Post date:** [March 16, 2023, 2:51pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/8 "2023-03-16T14:51:22Z")

</div>

Hi, I got the same error page.

In kibana I see the following stacktrace:

```auto
[2023-03-16T15:40:20.063+01:00][ERROR][http] Error: Unable to encrypt attribute "apiKey"
    at EncryptedSavedObjectsService.attributesToEncryptIterator (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\encrypted_saved_objects\server\crypto\encrypted_saved_objects_service.js:193:17)
    at attributesToEncryptIterator.throw (<anonymous>)
    at EncryptedSavedObjectsService.encryptAttributes (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\encrypted_saved_objects\server\crypto\encrypted_saved_objects_service.js:235:23)
    at EncryptedSavedObjectsClientWrapper.create (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\encrypted_saved_objects\server\saved_objects\encrypted_saved_objects_client_wrapper.js:30:129)
    at SecureSavedObjectsClientWrapper.create (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\security\server\saved_objects\secure_saved_objects_client_wrapper.js:77:47)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at SpacesSavedObjectsClient.create (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\spaces\server\saved_objects\spaces_saved_objects_client.js:63:12)
    at Object.setSyntheticsServiceApiKey [as set] (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\synthetics\server\legacy_uptime\lib\saved_objects\service_api_key.js:71:3)
    at generateAndSaveServiceAPIKey (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\synthetics\server\synthetics_service\get_api_key.js:141:7)
    at handler (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\synthetics\server\routes\synthetics_service\enablement.js:97:7)
    at handler (C:\tools\elastic\kibana-8.6.1\x-pack\plugins\synthetics\server\synthetics_route_wrapper.js:84:19)
    at Router.handle (C:\tools\elastic\kibana-8.6.1\node_modules\@kbn\core-http-router-server-internal\target_node\src\router.js:141:30)
    at handler (C:\tools\elastic\kibana-8.6.1\node_modules\@kbn\core-http-router-server-internal\target_node\src\router.js:107:50)
    at exports.Manager.execute (C:\tools\elastic\kibana-8.6.1\node_modules\@hapi\hapi\lib\toolkit.js:60:28)
    at Object.internals.handler (C:\tools\elastic\kibana-8.6.1\node_modules\@hapi\hapi\lib\handler.js:46:20)
    at exports.execute (C:\tools\elastic\kibana-8.6.1\node_modules\@hapi\hapi\lib\handler.js:31:20)
    at Request._lifecycle (C:\tools\elastic\kibana-8.6.1\node_modules\@hapi\hapi\lib\request.js:371:32)
    at Request._execute (C:\tools\elastic\kibana-8.6.1\node_modules\@hapi\hapi\lib\request.js:281:9)

```

When I look at API management an API key with the name 'synthetics-api-key (required for monitor management)' was created on the Realm 'reserved'.

---

<div class="post-metadata">

**Author:** ![shahzad31](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shahzad31/32/51637_2.png) [@shahzad31](https://discuss.elastic.co/u/shahzad31)\
**Post date:** [March 20, 2023, 2:39pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/9 "2023-03-20T14:39:01Z")

</div>

@Gunter_Van_Damme We will take a look into it. Can you try disabling monitor management and re-enable it to see if it resolves the issue for you.

---

<div class="post-metadata">

**Author:** ![Gunter\_Van\_Damme](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gunter_van_damme/32/117865_2.png) [@Gunter\_Van\_Damme](https://discuss.elastic.co/u/Gunter_Van_Damme)\
**Post date:** [March 20, 2023, 4:29pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/10 "2023-03-20T16:29:08Z")

</div>

Hi,

It is never enabled .  
When I click the button, the error occurs and kibana says that it is disabled (as a result of this error).

---

<div class="post-metadata">

**Author:** ![shahzad31](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shahzad31/32/51637_2.png) [@shahzad31](https://discuss.elastic.co/u/shahzad31)\
**Post date:** [March 21, 2023, 12:57pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/11 "2023-03-21T12:57:46Z")

</div>

@Gunter_Van_Damme do you have Kibana config encryption key set as

```auto
xpack.encryptedSavedObjects:
  encryptionKey: "min-32-byte-long-strong-encryption-key"

```

you can also docker en vars to set it

> **[Secure saved objects | Kibana Guide \[8.6\] | Elastic](https://www.elastic.co/guide/en/kibana/current/xpack-security-secure-saved-objects.html#encryption-key-docker-configuration)**
>
> A list of the supported authentication mechanisms in Kibana.

---

<div class="post-metadata">

**Author:** ![Gunter\_Van\_Damme](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gunter_van_damme/32/117865_2.png) [@Gunter\_Van\_Damme](https://discuss.elastic.co/u/Gunter_Van_Damme)\
**Post date:** [March 22, 2023, 2:02pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/12 "2023-03-22T14:02:32Z")

</div>

Great thx. That worked.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 15, 2023, 2:02pm UTC](https://discuss.elastic.co/t/error-loading-monitor-management/326104/13 "2023-04-15T14:02:59Z")

</div>

This topic was automatically closed 24 days after the last reply. New replies are no longer allowed.
