# Error loading visualizations in kibana timelion

**URL:** https://discuss.elastic.co/t/error-loading-visualizations-in-kibana-timelion/271525
**Category:** Kibana
**Tags:** timelion
**Created:** [April 28, 2021, 2:34pm UTC](https://discuss.elastic.co/t/error-loading-visualizations-in-kibana-timelion/271525 "2021-04-28T14:34:46Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![Juan\_David\_Jaramillo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juan_david_jaramillo/32/76831_2.png) [@Juan\_David\_Jaramillo](https://discuss.elastic.co/u/Juan_David_Jaramillo)
#### Post date: [April 28, 2021, 2:34pm UTC](https://discuss.elastic.co/t/error-loading-visualizations-in-kibana-timelion/271525/1 "2021-04-28T14:34:46Z")

</div>

I have an error that appears when entering a dashboard in kibana, no data in the visualizations, everything comes out blank; these visualizations are of filebeat that the service works correctly, but this error comes out:

```auto
[timelion_vis] > Timelion request error: undefined Error: in cell #1: [illegal_argument_exception] Text fields are not optimised for operations that require per-document field data like aggregations and sorting, so these operations are disabled by default. Please use a keyword field instead. Alternatively, set fielddata=true on [destination.as.organization.name] in order to load field data by uninverting the inverted index. Note that this can use significant memory.

```

 ![MicrosoftTeams-image](https://us1.discourse-cdn.com/elastic/original/3X/7/8/782a52d3ae526c5e14a32348fbea0a17c5ca82bc.png)

 ![MicrosoftTeams-image (1)](https://us1.discourse-cdn.com/elastic/original/3X/9/7/97c7f2e70a39be0a050cae2cc3dd56a0a0124a4a.png)

---

<div class="post-metadata">

### Author: ![dosant](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dosant/32/64489_2.png) [@dosant](https://discuss.elastic.co/u/dosant)
#### Post date: [April 28, 2021, 2:57pm UTC](https://discuss.elastic.co/t/error-loading-visualizations-in-kibana-timelion/271525/2 "2021-04-28T14:57:29Z")

</div>

It looks like the problem is that `destination.as.organization.name` is not available for aggregations.  
The error says, that in the visualizations you should use the field of type keyword [Keyword type family | Elasticsearch Guide [7.12] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/keyword.html) (if you use default mappings then probably already have `destination.as.organization.name.keyword` and you could try to use that one in your viz) or alternatively you could enable field data on your field of type text [Text field type | Elasticsearch Guide [7.12] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/7.12/text.html#fielddata-mapping-param)

I suspect that in your case it would make sense for the organization name to be of a type keyword.

---

<div class="post-metadata">

### Author: ![Juan\_David\_Jaramillo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juan_david_jaramillo/32/76831_2.png) [@Juan\_David\_Jaramillo](https://discuss.elastic.co/u/Juan_David_Jaramillo)
#### Post date: [April 28, 2021, 3:12pm UTC](https://discuss.elastic.co/t/error-loading-visualizations-in-kibana-timelion/271525/3 "2021-04-28T15:12:46Z")

</div>

when changing to keyword the visualization works but the same error is still displayed, look at the index fields and there is already one with the keyword

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/b/c/bcec9900334d5435abded7fabe5bac2b56bdbda6.png)

---

<div class="post-metadata">

### Author: ![Juan\_David\_Jaramillo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juan_david_jaramillo/32/76831_2.png) [@Juan\_David\_Jaramillo](https://discuss.elastic.co/u/Juan_David_Jaramillo)
#### Post date: [April 28, 2021, 3:14pm UTC](https://discuss.elastic.co/t/error-loading-visualizations-in-kibana-timelion/271525/4 "2021-04-28T15:14:43Z")

</div>

![image](https://us1.discourse-cdn.com/elastic/original/3X/4/7/4787df9d059bcb7ea9f32fed78e09b39ef133a51.png)

---

<div class="post-metadata">

### Author: ![dosant](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dosant/32/64489_2.png) [@dosant](https://discuss.elastic.co/u/dosant)
#### Post date: [April 29, 2021, 11:06am UTC](https://discuss.elastic.co/t/error-loading-visualizations-in-kibana-timelion/271525/5 "2021-04-29T11:06:03Z")

</div>

Looks like other visualizations on that dashboard are still using `destination.as.organization.name`, hence there are errors. I'd try to change all visualizations to use a keyword field

---

<div class="post-metadata">

### Author: ![Juan\_David\_Jaramillo](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/juan_david_jaramillo/32/76831_2.png) [@Juan\_David\_Jaramillo](https://discuss.elastic.co/u/Juan_David_Jaramillo)
#### Post date: [April 30, 2021, 12:11am UTC](https://discuss.elastic.co/t/error-loading-visualizations-in-kibana-timelion/271525/6 "2021-04-30T00:11:10Z")

</div>

> [@dosant](#):
>
> destination.as.organization.name

I already did for the Timelion visualizations but for the normal graphs the .keyword is not in destination.as.organization.name so it does not work for me, and that field is not aggregatable, how do I transform it to keyword?

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/c/7/c7ecd73f8a66a17a7cc482b5d36e159fac895949.png)

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 28, 2021, 12:11am UTC](https://discuss.elastic.co/t/error-loading-visualizations-in-kibana-timelion/271525/7 "2021-05-28T00:11:32Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
