# Error log curl: (52) Empty reply from server in v8.11.3

**URL:** https://discuss.elastic.co/t/error-log-curl-52-empty-reply-from-server-in-v8-11-3/350338
**Category:** Elasticsearch
**Tags:** docker
**Created:** [January 3, 2024, 7:12pm UTC](https://discuss.elastic.co/t/error-log-curl-52-empty-reply-from-server-in-v8-11-3/350338 "2024-01-03T19:12:14Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![ACodingfreak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/acodingfreak/32/130511_2.png) [@ACodingfreak](https://discuss.elastic.co/u/ACodingfreak)
#### Post date: [January 3, 2024, 7:12pm UTC](https://discuss.elastic.co/t/error-log-curl-52-empty-reply-from-server-in-v8-11-3/350338/1 "2024-01-03T19:12:14Z")

</div>

Hi All,

I am new to ELK and started using the same via docker compose.  
I have used the standard docker-compose.yaml file which is available in below link.

> <https://github.com/elastic/elasticsearch/blob/8.11/docs/reference/setup/install/docker/docker-compose.yml>

As shown in below logs all containers are up and running

```auto
$ sudo docker container ls 
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
b35f00b59c6f docker.elastic.co/logstash/logstash:8.11.3 "/usr/local/bin/dockâ€¦" 11 minutes ago Up 10 minutes 0.0.0.0:5000->5000/udp, :::5000->5000/udp, 5044/tcp, 0.0.0.0:5000->5000/tcp, 0.0.0.0:5044->5044/udp, :::5000->5000/tcp, :::5044->5044/udp, 9600/tcp elastic-logstash-1
215e5633c5a8 docker.elastic.co/kibana/kibana:8.11.3 "/bin/tini -- /usr/lâ€¦" 11 minutes ago Up 10 minutes (healthy) 0.0.0.0:5601->5601/tcp, :::5601->5601/tcp elastic-kibana-1
a5082ab5b96e docker.elastic.co/elasticsearch/elasticsearch:8.11.3 "/bin/tini -- /usr/lâ€¦" 11 minutes ago Up 11 minutes (healthy) 9200/tcp, 9300/tcp elastic-es03-1
68c089bcce7c docker.elastic.co/elasticsearch/elasticsearch:8.11.3 "/bin/tini -- /usr/lâ€¦" 11 minutes ago Up 11 minutes (healthy) 9200/tcp, 9300/tcp elastic-es02-1
63a2280866b7 docker.elastic.co/elasticsearch/elasticsearch:8.11.3 "/bin/tini -- /usr/lâ€¦" 11 minutes ago Up 11 minutes (healthy) 0.0.0.0:9200->9200/tcp, :::9200->9200/tcp, 9300/tcp elastic-es01-1

```

Now If i try below command to access the elastic server from the same machine I get error saying empty reply

```auto
$ curl -X GET "http://elastic:elasticpass@127.0.0.1:9200"
curl: (52) Empty reply from server

$ curl http://127.0.0.1:9200
curl: (52) Empty reply from server

$ curl http://localhost:9200 -k -u elastic:elasticpass
curl: (52) Empty reply from server

```

Any pointers would be of great help

---

<div class="post-metadata">

### Author: ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)
#### Post date: [January 3, 2024, 7:27pm UTC](https://discuss.elastic.co/t/error-log-curl-52-empty-reply-from-server-in-v8-11-3/350338/2 "2024-01-03T19:27:12Z")

</div>

You need to use `https`, you are using `http`.

---

<div class="post-metadata">

### Author: ![ACodingfreak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/acodingfreak/32/130511_2.png) [@ACodingfreak](https://discuss.elastic.co/u/ACodingfreak)
#### Post date: [January 3, 2024, 8:18pm UTC](https://discuss.elastic.co/t/error-log-curl-52-empty-reply-from-server-in-v8-11-3/350338/3 "2024-01-03T20:18:34Z")

</div>

Thanks that resolved the issue

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 31, 2024, 8:18pm UTC](https://discuss.elastic.co/t/error-log-curl-52-empty-reply-from-server-in-v8-11-3/350338/4 "2024-01-31T20:18:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
