# ERROR logstash.inputs.jdbc

**URL:** <https://discuss.elastic.co/t/error-logstash-inputs-jdbc/292610>\
**Category:** Logstash\
**Created:** [December 21, 2021, 8:01pm UTC](https://discuss.elastic.co/t/error-logstash-inputs-jdbc/292610 "2021-12-21T20:01:04Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Gabriel\_Munoz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gabriel_munoz/32/47141_2.png) [@Gabriel\_Munoz](https://discuss.elastic.co/u/Gabriel_Munoz)\
**Post date:** [December 21, 2021, 8:01pm UTC](https://discuss.elastic.co/t/error-logstash-inputs-jdbc/292610/1 "2021-12-21T20:01:04Z")

</div>

El controlador no pudo establecer una conexión segura con SQL Server con el cifrado de Capa de sockets seguros (SSL). Error: "No appropriate protocol (protocol is disabled or cipher suites are inappropriate)

[2021-12-21T16:37:05,245][ERROR][logstash.inputs.jdbc][main][7fb3867b14204d8f7acbe9f535d702f82ce7a7a9806c1fed29b247109377a5f3] Unable to connect to database. Tried 1 times {:message=\>"Java::ComMicrosoftSqlserverJdbc::SQLServerException: El controlador no pudo establecer una conexión segura con SQL Server con el cifrado de Capa de sockets seguros (SSL). Error: "No appropriate protocol (protocol is disabled or cipher suites are inappropriate)". ClientConnectionId:c0a53a5b-216b-4764-9f32-75b3a89782b9", :exception=\>Sequel::DatabaseConnectionError, :cause=\>com.microsoft.sqlserver.jdbc.SQLServerException: El controlador no pudo establecer una conexión segura con SQL Server con el cifrado de Capa de sockets seguros (SSL). Error: "No appropriate protocol (protocol is disabled or cipher suites are inappropriate)". ClientConnectionId:c0a53a5b-216b-4764-9f32-75b3a89782b9, :backtrace=\>["com.microsoft.sqlserver.jdbc.SQLServerConnection.terminate(com/microsoft/sqlserver/jdbc/SQLServerConnection.java:1746)", "com.microsoft.sqlserver.jdbc.TDSChannel.enableSSL(com/microsoft/sqlserver/jdbc/IOBuffer.java:1704)", "com.microsoft.sqlserver.jdbc.SQLServerConnection.connectHelper(com/microsoft/sqlserver/jdbc/SQLServerConnection.java:1402)", "com.microsoft.sqlserver.jdbc.SQLServerConnection.login(com/microsoft/sqlserver/jdbc/SQLServerConnection.java:1069)", "com.microsoft.sqlserver.jdbc.SQLServerConnection.connectInternal(com/microsoft/sqlserver/jdbc/SQLServerConnection.java:905)", "com.microsoft.sqlserver.jdbc.SQLServerConnection.connect(com/microsoft/sqlserver/jdbc/SQLServerConnection.java:452)", "com.microsoft.sqlserver.jdbc.SQLServerDriver.connect(com/microsoft/sqlserver/jdbc/SQLServerDriver.java:1014)", "java.lang.reflect.Method.invoke(java/lang/reflect/Method.java:498)", "org.jruby.javasupport.JavaMethod.invokeDirectWithExceptionHandling(org/jruby/javasupport/JavaMethod.java:426)", "org.jruby.javasupport.JavaMethod.invokeDirect(org/jruby/javasupport/JavaMethod.java:293)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_51\_dot\_0.lib.sequel.adapters.jdbc.connect(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.51.0/lib/sequel/adapters/jdbc.rb:239)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_51\_dot\_0.lib.sequel.connection\_pool.make\_new(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.51.0/lib/sequel/connection\_pool.rb:122)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_51\_dot\_0.lib.sequel.connection\_pool.threaded.assign\_connection(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.51.0/lib/sequel/connection\_pool/threaded.rb:209)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_51\_dot\_0.lib.sequel.connection\_pool.threaded.acquire(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.51.0/lib/sequel/connection\_pool/threaded.rb:139)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_51\_dot\_0.lib.sequel.connection\_pool.threaded.hold(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.51.0/lib/sequel/connection\_pool/threaded.rb:91)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_51\_dot\_0.lib.sequel.database.connecting.synchronize(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.51.0/lib/sequel/database/connecting.rb:269)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_51\_dot\_0.lib.sequel.database.connecting.test\_connection(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.51.0/lib/sequel/database/connecting.rb:278)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_51\_dot\_0.lib.sequel.database.misc.initialize(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.51.0/lib/sequel/database/misc.rb:175)", "org.jruby.RubyClass.newInstance(org/jruby/RubyClass.java:939)", "org.jruby.RubyClass$INVOKER$i$newInstance.call(org/jruby/RubyClass$INVOKER$i$newInstance.gen)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_51\_dot\_0.lib.sequel.database.connecting.connect(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.51.0/lib/sequel/database/connecting.rb:57)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.sequel\_minus\_5\_dot\_51\_dot\_0.lib.sequel.core.connect(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/sequel-5.51.0/lib/sequel/core.rb:124)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_integration\_minus\_jdbc\_minus\_5\_dot\_1\_dot\_8.lib.logstash.plugin\_mixins.jdbc.jdbc.jdbc\_connect(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.1.8/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:114)", "org.jruby.RubyKernel.loop(org/jruby/RubyKernel.java:1442)", "org.jruby.RubyKernel$INVOKER$s$0$0$loop.call(org/jruby/RubyKernel$INVOKER$s$0$0$loop.gen)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_integration\_minus\_jdbc\_minus\_5\_dot\_1\_dot\_8.lib.logstash.plugin\_mixins.jdbc.jdbc.jdbc\_connect(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.1.8/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:111)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_integration\_minus\_jdbc\_minus\_5\_dot\_1\_dot\_8.lib.logstash.plugin\_mixins.jdbc.jdbc.open\_jdbc\_connection(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.1.8/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:154)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_integration\_minus\_jdbc\_minus\_5\_dot\_1\_dot\_8.lib.logstash.plugin\_mixins.jdbc.jdbc.execute\_statement(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.1.8/lib/logstash/plugin\_mixins/jdbc/jdbc.rb:211)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_integration\_minus\_jdbc\_minus\_5\_dot\_1\_dot\_8.lib.logstash.inputs.jdbc.execute\_query(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.1.8/lib/logstash/inputs/jdbc.rb:335)", "usr.share.logstash.vendor.bundle.jruby.$2\_dot\_5\_dot\_0.gems.logstash\_minus\_integration\_minus\_jdbc\_minus\_5\_dot\_1\_dot\_8.lib.logstash.inputs.jdbc.run(/usr/share/logstash/vendor/bundle/jruby/2.5.0/gems/logstash-integration-jdbc-5.1.8/lib/logstash/inputs/jdbc.rb:303)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.inputworker(/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:409)", "usr.share.logstash.logstash\_minus\_core.lib.logstash.java\_pipeline.start\_input(/usr/share/logstash/logstash-core/lib/logstash/java\_pipeline.rb:400)", "org.jruby.RubyProc.call(org/jruby/RubyProc.java:318)", "java.lang.Thread.run(java/lang/Thread.java:748)"]}  
[2021-12-21T16:37:05,249][WARN][logstash.inputs.jdbc][main][7fb3867b14204d8f7acbe9f535d702f82ce7a7a9806c1fed29b247109377a5f3] Exception when executing JDBC query {:exception=\>"Java::ComMicrosoftSqlserverJdbc::SQLServerException: El controlador no pudo establecer una conexión segura con SQL Server con el cifrado de Capa de sockets seguros (SSL). Error: "No appropriate protocol (protocol is disabled or cipher suites are inappropriate)". ClientConnectionId:c0a53a5b-216b-4764-9f32-75b3a89782b9"}

---

<div class="post-metadata">

**Author:** ![Gabriel\_Munoz](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gabriel_munoz/32/47141_2.png) [@Gabriel\_Munoz](https://discuss.elastic.co/u/Gabriel_Munoz)\
**Post date:** [December 22, 2021, 12:21pm UTC](https://discuss.elastic.co/t/error-logstash-inputs-jdbc/292610/2 "2021-12-22T12:21:58Z")

</div>

add  
-Djdk.tls.client.protocols=TLSv1

in file /etc/logstash/jvm.options also update in file java.security -\>\> jdk.certpath.disabledAlgorithms

#jdk.tls.disabledAlgorithms=SSLv3, TLSv1, TLSv1.1, RC4, DES, MD5withRSA,   
jdk.tls.disabledAlgorithms=SSLv3, RC4, DES, MD5withRSA,   
DH keySize \< 1024, EC keySize \< 224, 3DES\_EDE\_CBC, anon, NULL,   
include jdk.disabled.namedCurves

Ahora funciona sin problemas .....

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 19, 2022, 12:22pm UTC](https://discuss.elastic.co/t/error-logstash-inputs-jdbc/292610/3 "2022-01-19T12:22:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
