# Error logstash "requires the configuration of \`certificate\_authorities "

**URL:** <https://discuss.elastic.co/t/error-logstash-requires-the-configuration-of-certificate-authorities/125218>\
**Category:** Elastic en Español\
**Created:** [March 22, 2018, 3:31pm UTC](https://discuss.elastic.co/t/error-logstash-requires-the-configuration-of-certificate-authorities/125218 "2018-03-22T15:31:30Z")\
**Posts on this page:** 1\
**Showing post:** 9

<div class="post-metadata">

**Author:** ![Ugo\_Sangiorgi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ugo_sangiorgi/32/146361_2.png) [@Ugo\_Sangiorgi](https://discuss.elastic.co/u/Ugo_Sangiorgi)\
**Post date:** [March 22, 2018, 5:54pm UTC](https://discuss.elastic.co/t/error-logstash-requires-the-configuration-of-certificate-authorities/125218/9 "2018-03-22T17:54:47Z")

</div>

El problema puede ser relacionado a la configuracion de logstash con respeto a una libreria que escribe en el directorio /tmp

> [@Problem with cipher in beat input](https://discuss.elastic.co/t/problem-with-cipher-in-beat-input/67841/5):
>
> Had this issue with a system, and found the problem was /tmp was mounted with noexec option. Removing the noexec option and rebooting fixed the issue on my system. It looks like logstash puts a copy of the libnetty-tcnative dynamic library so in /tmp and tries to load it from there which the noexec option blocks. Loading code from /tmp seems like a security risks. EDIT: the code putting the library in TMP is in netty which is used by logstash. EDIT 2: maybe the tmp path can be made more sa…

puedes cambiar en el jvm.options de logstash el parametro `-Dio.netty.native.workdir=/directorio` donde `directorio` debe ser un directorio diferente a tmp

---

_[View the full topic](https://discuss.elastic.co/t/error-logstash-requires-the-configuration-of-certificate-authorities/125218)._
