# Error Logstash: unable to load plugin Postgresql.jar

**URL:** <https://discuss.elastic.co/t/error-logstash-unable-to-load-plugin-postgresql-jar/214562>\
**Category:** Logstash\
**Created:** [January 10, 2020, 8:29am UTC](https://discuss.elastic.co/t/error-logstash-unable-to-load-plugin-postgresql-jar/214562 "2020-01-10T08:29:31Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Kostis95](https://avatars.discourse-cdn.com/v4/letter/k/ccd318/32.png) [@Kostis95](https://discuss.elastic.co/u/Kostis95)\
**Post date:** [January 10, 2020, 8:29am UTC](https://discuss.elastic.co/t/error-logstash-unable-to-load-plugin-postgresql-jar/214562/1 "2020-01-10T08:29:32Z")

</div>

Hi there,

I'm trying to get started with elasticsearch and to use it for our forum data (which is stored in a postgresql database). I read that it would be possible to sync a postgresql database with elastic by using logstash. So in usr/local/etc/logstash I've got all files in place (logstash.yml, p1.conf, pipelines.yml). I've put the postgresql jar on my Desktop and refer to it in the p1.conf file like so:  
jdbc\_driver\_library =\> "Users/{myUserName}/Desktop/postgresql-42.2.9.jar"  
However when running logstash I get a pluginLoadingError that states that there is no such file to load. I can't see what I'm doing wrong here, so any help would be appreciated!

---

<div class="post-metadata">

**Author:** ![Kostis95](https://avatars.discourse-cdn.com/v4/letter/k/ccd318/32.png) [@Kostis95](https://discuss.elastic.co/u/Kostis95)\
**Post date:** [January 10, 2020, 10:01am UTC](https://discuss.elastic.co/t/error-logstash-unable-to-load-plugin-postgresql-jar/214562/2 "2020-01-10T10:01:45Z")

</div>

I found the solution. You need to give all users Read & Write access (I'm using Mac OS). And instead of writing the path to our conf file like: "Users/user/Desktop/postgresql-42.2.9.jar" you write it like "~/Desktop/postgresql-42.2.9.jar".  
After that all seems to be resolved.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 7, 2020, 10:01am UTC](https://discuss.elastic.co/t/error-logstash-unable-to-load-plugin-postgresql-jar/214562/3 "2020-02-07T10:01:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
