# Error mapping logstash

**URL:** https://discuss.elastic.co/t/error-mapping-logstash/59441
**Category:** Elasticsearch
**Created:** [August 31, 2016, 3:57pm UTC](https://discuss.elastic.co/t/error-mapping-logstash/59441 "2016-08-31T15:57:40Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Thomas.Fehringer](https://avatars.discourse-cdn.com/v4/letter/t/d07c76/32.png) [@Thomas.Fehringer](https://discuss.elastic.co/u/Thomas.Fehringer)
#### Post date: [August 31, 2016, 3:57pm UTC](https://discuss.elastic.co/t/error-mapping-logstash/59441/1 "2016-08-31T15:57:40Z")

</div>

Hi, I get the following error when logstash is sending data to ES  
2016-08-31 17:38:53,439][DEBUG][action.admin.indices.create] [dewrmon01] [logstash-2016.08.31] failed to create  
MapperParsingException[Failed to parse mapping [_default_]: Mapping definition for [@fields] has unsupported parameters: [path : full]]; nested: MapperParsingException[Mapping definition for [@fields] has unsupported parameters: [path : full]];  
at org.elasticsearch.index.mapper.MapperService.merge(MapperService.java:280)  
at org.elasticsearch.cluster.metadata.MetaDataCreateIndexService$1.execute(MetaDataCreateIndexService.java:317)  
at org.elasticsearch.cluster.ClusterStateUpdateTask.execute(ClusterStateUpdateTask.java:45)  
at org.elasticsearch.cluster.service.InternalClusterService.runTasksForExecutor(InternalClusterService.java:468)  
at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:772)  
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.runAndClean(PrioritizedEsThreadPoolExecutor.java:231)  
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:194)  
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)  
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)  
at java.lang.Thread.run(Thread.java:745)  
Caused by: MapperParsingException[Mapping definition for [@fields] has unsupported parameters: [path : full]]  
at org.elasticsearch.index.mapper.DocumentMapperParser.checkNoRemainingFields(DocumentMapperParser.java:171)  
at org.elasticsearch.index.mapper.DocumentMapperParser.checkNoRemainingFields(DocumentMapperParser.java:165)  
at org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:311)  
at org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseObjectOrDocumentTypeProperties(ObjectMapper.java:222)  
at org.elasticsearch.index.mapper.object.RootObjectMapper$TypeParser.parse(RootObjectMapper.java:139)  
at org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:118)  
at org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:99)  
at org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:85)  
at org.elasticsearch.index.mapper.MapperService.merge(MapperService.java:300)  
at org.elasticsearch.index.mapper.MapperService.merge(MapperService.java:278)  
Do you have an idea - I'm a beginner

---

<div class="post-metadata">

### Author: ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)
#### Post date: [September 1, 2016, 11:43pm UTC](https://discuss.elastic.co/t/error-mapping-logstash/59441/2 "2016-09-01T23:43:21Z")

</div>

What does the mapping for the index look like?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 5, 2017, 10:23pm UTC](https://discuss.elastic.co/t/error-mapping-logstash/59441/3 "2017-07-05T22:23:05Z")

</div>


