# Error: master not discovered exception setting up cluster

**URL:** <https://discuss.elastic.co/t/error-master-not-discovered-exception-setting-up-cluster/232238>\
**Category:** Elasticsearch\
**Created:** [May 12, 2020, 1:48pm UTC](https://discuss.elastic.co/t/error-master-not-discovered-exception-setting-up-cluster/232238 "2020-05-12T13:48:23Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![kawalec](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kawalec/32/46404_2.png) [@kawalec](https://discuss.elastic.co/u/kawalec)\
**Post date:** [May 12, 2020, 1:48pm UTC](https://discuss.elastic.co/t/error-master-not-discovered-exception-setting-up-cluster/232238/1 "2020-05-12T13:48:24Z")

</div>

Having all sorts of issues getting my cluster to work properly. using 7.6.1

On node1 I'm able to set my passwords on my machine without error. On node 2 and 3 I get

./elasticsearch-setup-passwords interactive

Failed to determine the health of the cluster running at [http://10.10.10.28:9200](http://10.10.10.28:9200)  
Unexpected response code [503] from calling GET [http://10.10.10.B:9200/\_cluster/health?pretty](http://10.10.10.B:9200/_cluster/health?pretty)  
Cause: master\_not\_discovered\_exception

It is recommended that you resolve the issues with your cluster before running elasticsearch-setup-passwords.

Node set up. this is set up on all machines. from everything I read this is correct way to set up.

------------------------------------ Node -----------------------------------

# 

# Use a descriptive name for the node:

# 

node.name: logs1

# 

# Add custom attributes to the node:

node.master: true  
node.data: true

# --------------------------------- Discovery ---------------------------------

# 

# Pass an initial list of hosts to perform discovery when this node is started:

# The default list of hosts is ["127.0.0.1", "[::1]"]

# 

#discovery.seed\_hosts: ["host1", "host2"]  
discovery.seed\_hosts: ["10.10.10.A", "10.10.10.B", "10.10.10.C"]

# 

# Bootstrap the cluster using an initial set of master-eligible nodes:

# 

cluster.initial\_master\_nodes: ["10.10.10.A", "10.10.10.B", "10.10.10.C"]

# 

#to avoid split brain ([Master Eligible Node) / 2 + 1])  
discovery.zen.minimum\_master\_nodes: 2

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 9, 2020, 1:48pm UTC](https://discuss.elastic.co/t/error-master-not-discovered-exception-setting-up-cluster/232238/2 "2020-06-09T13:48:25Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
