# Error message using logstash(Response code: 429, 500)

**URL:** <https://discuss.elastic.co/t/error-message-using-logstash-response-code-429-500/75264>\
**Category:** Logstash\
**Created:** [February 16, 2017, 2:49am UTC](https://discuss.elastic.co/t/error-message-using-logstash-response-code-429-500/75264 "2017-02-16T02:49:00Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Suin\_You](https://avatars.discourse-cdn.com/v4/letter/s/71c47a/32.png) [@Suin\_You](https://discuss.elastic.co/u/Suin_You)\
**Post date:** [February 16, 2017, 2:49am UTC](https://discuss.elastic.co/t/error-message-using-logstash-response-code-429-500/75264/1 "2017-02-16T02:49:00Z")

</div>

I got the two error messages and how could I do?

The first problem is

[2017-02-16T11:42:17,332][ERROR][logstash.outputs.elasticsearch] Got a bad response code from server, but this code is not considered retryable. Request will be dropped {:code=\>500, :response\_body=\>"{"took":8,"errors":true,"error":{"type":"export\_exception","reason":"failed to flush export bulks","caused\_by":{"type":"export\_exception","reason":"failed to flush export bulk [default\_local]","caused\_by":{"type":"es\_rejected\_execution\_exception","reason":"rejected execution of org.elasticsearch.ingest.PipelineExecutionService$2@4793a95f on EsThreadPoolExecutor[bulk, queue capacity = 50, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@157c3366[Running, pool size = 4, active threads = 4, queued tasks = 56, completed tasks = 627145]]"}},"exceptions":[{"type":"export\_exception","reason":"failed to flush export bulk [default\_local]","caused\_by":{"type":"es\_rejected\_execution\_exception","reason":"rejected execution of org.elasticsearch.ingest.PipelineExecutionService$2@4793a95f on EsThreadPoolExecutor[bulk, queue capacity = 50, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@157c3366[Running, pool size = 4, active threads = 4, queued tasks = 56, completed tasks = 627145]]"}}]}}"}

and second is ...

[2017-02-16T11:42:17,332][ERROR][logstash.outputs.elasticsearch] Got a bad response code from server, but this code is not considered retryable. Request will be dropped {:code=\>500, :response\_body=\>"{"took":8,"errors":true,"error":{"type":"export\_exception","reason":"failed to flush export bulks","caused\_by":{"type":"export\_exception","reason":"failed to flush export bulk [default\_local]","caused\_by":{"type":"es\_rejected\_execution\_exception","reason":"rejected execution of org.elasticsearch.ingest.PipelineExecutionService$2@4793a95f on EsThreadPoolExecutor[bulk, queue capacity = 50, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@157c3366[Running, pool size = 4, active threads = 4, queued tasks = 56, completed tasks = 627145]]"}},"exceptions":[{"type":"export\_exception","reason":"failed to flush export bulk [default\_local]","caused\_by":{"type":"es\_rejected\_execution\_exception","reason":"rejected execution of org.elasticsearch.ingest.PipelineExecutionService$2@4793a95f on EsThreadPoolExecutor[bulk, queue capacity = 50, org.elasticsearch.common.util.concurrent.EsThreadPoolExecutor@157c3366[Running, pool size = 4, active threads = 4, queued tasks = 56, completed tasks = 627145]]"}}]}}"}

It looks like bulk too many datas.. and how could I solve this problems?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 16, 2017, 2:49am UTC](https://discuss.elastic.co/t/error-message-using-logstash-response-code-429-500/75264/2 "2017-03-16T02:49:07Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
