# Error no living connections

**URL:** https://discuss.elastic.co/t/error-no-living-connections/183750
**Category:** Kibana
**Created:** [May 31, 2019, 2:53pm UTC](https://discuss.elastic.co/t/error-no-living-connections/183750 "2019-05-31T14:53:20Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![leobaiano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leobaiano/32/43704_2.png) [@leobaiano](https://discuss.elastic.co/u/leobaiano)
#### Post date: [May 31, 2019, 2:53pm UTC](https://discuss.elastic.co/t/error-no-living-connections/183750/1 "2019-05-31T14:53:20Z")

</div>

I have an elasticsearch running in the elastic cloud and I would like to run the kibana in another place because there they do not allow to customize the look of kibana, but when I try to run kibana locally, for example, I get the message:

```
kibana | {"type":"log","@timestamp":"2019-05-31T14:48:58Z","tags":["warning","task_manager"],"pid":1,"message":"PollError No Living connections"}
kibana | {"type":"log","@timestamp":"2019-05-31T14:49:00Z","tags":["warning","elasticsearch","admin"],"pid":1,"message":"Unable to revive connection: https://22afcafe58ee4c818b66829c7488b23b.us-east-1.aws.found.io:9243/"}

```

My elasticsearch.yml  
xpack:  
security:  
authc:  
realms:  
cloud-saml:  
type: saml  
order: 2  
attributes.principal: "nameid"  
attributes.groups: "[http://schemas.microsoft.com/ws/2008/06/identity/claims/groups](http://schemas.microsoft.com/ws/2008/06/identity/claims/groups)"  
idp.metadata.path: "[https://login.microsoftonline.com/4a39dff3-ff09-440b-b47b-8c603416bfce/federationmetadata/2007-06/federationmetadata.xml?appid=bdf10ffb-849e-4fd4-8038-335ed137c0aa](https://login.microsoftonline.com/4a39dff3-ff09-440b-b47b-8c603416bfce/federationmetadata/2007-06/federationmetadata.xml?appid=bdf10ffb-849e-4fd4-8038-335ed137c0aa)"  
idp.entity\_id: "[https://sts.windows.net/4a39dff3-ff09-440b-b47b-8c603416bfce/](https://sts.windows.net/4a39dff3-ff09-440b-b47b-8c603416bfce/)"  
sp.entity\_id: "[https://8b64c0c41ede48bc9e907a5279089109.us-east-1.aws.found.io:9243](https://8b64c0c41ede48bc9e907a5279089109.us-east-1.aws.found.io:9243)"  
sp.acs: "[https://8b64c0c41ede48bc9e907a5279089109.us-east-1.aws.found.io:9243/api/security/v1/saml](https://8b64c0c41ede48bc9e907a5279089109.us-east-1.aws.found.io:9243/api/security/v1/saml)"  
sp.logout: "[https://8b64c0c41ede48bc9e907a5279089109.us-east-1.aws.found.io:9243/logout](https://8b64c0c41ede48bc9e907a5279089109.us-east-1.aws.found.io:9243/logout)"

My kibana.yml  
elasticsearch.hosts: ["[https://22afcafe58ee4c818b66829c7488b23b.us-east-1.aws.found.io:9243](https://22afcafe58ee4c818b66829c7488b23b.us-east-1.aws.found.io:9243)" ]  
elasticsearch.username: "elastic"  
elasticsearch.password: "XXXXXX"  
elasticsearch.ssl.verificationMode: "certificate"  
xpack.monitoring.enabled: true  
xpack.security.enabled: true  
server.ssl.enabled: true  
elasticsearch.ssl.certificateAuthorities: "/usr/share/elasticsearch/config/certificates/ca/ca.crt"  
server.ssl.key: "/usr/share/elasticsearch/config/certificates/kibana/kibana.key"  
server.ssl.certificate: "/usr/share/elasticsearch/config/certificates/kibana/kibana.crt"

---

<div class="post-metadata">

### Author: ![leobaiano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leobaiano/32/43704_2.png) [@leobaiano](https://discuss.elastic.co/u/leobaiano)
#### Post date: [May 31, 2019, 4:02pm UTC](https://discuss.elastic.co/t/error-no-living-connections/183750/2 "2019-05-31T16:02:37Z")

</div>

Looking more closely at the kibana log I found the error below:

`["error", "elasticsearch", "admin"], "pid": 1, "message": "Request error, retrying \ nHEAD https://591cbb5e654cf58eff21acce4a572c80.us-east-1.aws.found.io:9243 / => unable to get local issuer certificate "}`

---

<div class="post-metadata">

### Author: ![leobaiano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leobaiano/32/43704_2.png) [@leobaiano](https://discuss.elastic.co/u/leobaiano)
#### Post date: [May 31, 2019, 4:16pm UTC](https://discuss.elastic.co/t/error-no-living-connections/183750/3 "2019-05-31T16:16:02Z")

</div>

If I remove the block below I stop receiving the errors:

```
# xpack.monitoring.ui.container.elasticsearch.enabled: true
# elasticsearch.ssl.verificationMode: "certificate"
# xpack.monitoring.enabled: true
# xpack.security.enabled: true
# server.ssl.enabled: true
# elasticsearch.ssl.certificateAuthorities: "/usr/share/elasticsearch/config/certificates/ca/ca.crt"
# server.ssl.key: "/usr/share/elasticsearch/config/certificates/kibana/kibana.key"
# server.ssl.certificate: "/usr/share/elasticsearch/config/certificates/kibana/kibana.crt"

```

The last line of the log is:

`kibana | { "Type": "log", "@ timestamp", "2019-05-31T16: 06: 05Z", "tags": ["listening", "info"] "PID" 1, "message": "Server running at http: // kibana: 5601"} kibana | { "Type": "log", "@ timestamp": "2019-05-31T16: 06: 05Z", "tags": ["status", "plugin: spaces@6.8.0", "info"] "pid": 1, "state", "green", "message": "Status changed from yellow to green - Ready", "prevState", "yellow", "prevMsg": "Waiting for ElasticSearch"}`

However when accessing [http://kibana:5601](http://kibana:5601) does not load kibana, I get the error: `ERR_CONNECTION_TIMED_OUT`

If I enter the machine with `docker exec -it kibana /bin/bash` and slash:`curl -i https://elastic: GJcpADMsV7YDtuXhbq90qHfl@22afcafe58ee4c818b66829c7488b23b.us-east-1.aws.found.io: 9243` I get the elasticsearch return

```
HTTP / 1.1 200 OK
Content-Type: application / json; charset = UTF-8
Date: Fri, 31 May 2019 16:10:49 GMT
X-Cloud-Request-Id: IioEHy_lRhyDcJDZ9JjZ_g
X-Found-Handling-Cluster: 22afcafe58ee4c818b66829c7488b23b
X-Found-Handling-Instance: instance-0000000014
X-Found-Handling-Server: 172.25.130.251
Content-Length: 524
Connection: keep-alive

{
  "name": "instance-0000000014",
  "cluster_name": "22afcafe58ee4c818b66829c7488b23b",
  "cluster_uuid": "Bb1tpdbpTRGNPP6V4RfetQ",
  "version": {
    "number": "6.8.0",
    "build_flavor": "default",
    "build_type": "tar",
    "build_hash": "65b6179",
    "build_date": "2019-05-15T20: 06: 13.172855Z",
    "build_snapshot": false,
    "lucene_version": "7.7.0",
    "minimum_wire_compatibility_version": "5.6.0",
    "minimum_index_compatibility_version": "5.0.0"
  },
  "tagline": "You Know, for Search"
}
```

---

<div class="post-metadata">

### Author: ![leobaiano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leobaiano/32/43704_2.png) [@leobaiano](https://discuss.elastic.co/u/leobaiano)
#### Post date: [June 3, 2019, 5:18pm UTC](https://discuss.elastic.co/t/error-no-living-connections/183750/4 "2019-06-03T17:18:27Z")

</div>

I made a change in my kibana.yml and now as final log message I get:

```auto
kibana | {"type": "log", "@ timestamp": "2019-06-03T17: 11: 59Z", "tags": "pid": 1, "message": "Imported license information from Elasticsearch for the [monitoring] cluster: mode: platinum | status: active | expiry date: 2020-04-30T23: 59: 59 + 00: 00"}
kibana | {"type": "log", "@ timestamp": "2019-06-03T17: 11: 59Z", "tags": ["listening", "info"], "pid": 1, "message": "Server running at http: // kibana: 5601"}
kibana | {"type": "log", "@ timestamp": "2019-06-03T17: 12: 00Z", "tags": "status", "plugin: spaces@6.8.0", "info" "status": "green", "message": "Status changed from yellow to green - Ready", "prevState": "yellow", "prevMsg": "Waiting for Elasticsearch"}

```

But when I try to access kibana in the browser I get the error `DNS_PROBE_FINISHED_NXDOMAIN`

kibana.yml

```auto
server.name: kibana
server.host: "kibana"
elasticsearch.hosts: ["https://22afcafe58ee4c818b66829c7488b23b.us-east-1.aws.found.io:9243"]
elasticsearch.username: "elastic"
elasticsearch.password: "XXXXXXXX"
xpack.monitoring.ui.container.elasticsearch.enabled: true
xpack.security.authProviders:
  saml
  basic
server.xsrf.whitelist:
  - /api/security/v1/saml

```

---

<div class="post-metadata">

### Author: ![leobaiano](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leobaiano/32/43704_2.png) [@leobaiano](https://discuss.elastic.co/u/leobaiano)
#### Post date: [June 3, 2019, 5:57pm UTC](https://discuss.elastic.co/t/error-no-living-connections/183750/5 "2019-06-03T17:57:39Z")

</div>

If localhost access the error changes to `ERR_CONNECTION_REFUSED` then something tells me that kibana is not actually running. Any idea?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [July 1, 2019, 5:57pm UTC](https://discuss.elastic.co/t/error-no-living-connections/183750/6 "2019-07-01T17:57:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
