# \[ERROR\]\[o.e.x.m.e.l.LocalExporter\] \[my-cluster\] failed to delete indices org.elasticsearch.index.IndexNotFoundException: no such index \[.monitoring-kibana-7-YYYY.MM.DD\]

**URL:** <https://discuss.elastic.co/t/error-o-e-x-m-e-l-localexporter-my-cluster-failed-to-delete-indices-org-elasticsearch-index-indexnotfoundexception-no-such-index-monitoring-kibana-7-yyyy-mm-dd/367239>\
**Category:** Kibana\
**Created:** [September 27, 2024, 10:58am UTC](https://discuss.elastic.co/t/error-o-e-x-m-e-l-localexporter-my-cluster-failed-to-delete-indices-org-elasticsearch-index-indexnotfoundexception-no-such-index-monitoring-kibana-7-yyyy-mm-dd/367239 "2024-09-27T10:58:29Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![mwitsas](https://avatars.discourse-cdn.com/v4/letter/m/e47774/32.png) [@mwitsas](https://discuss.elastic.co/u/mwitsas)\
**Post date:** [September 27, 2024, 10:58am UTC](https://discuss.elastic.co/t/error-o-e-x-m-e-l-localexporter-my-cluster-failed-to-delete-indices-org-elasticsearch-index-indexnotfoundexception-no-such-index-monitoring-kibana-7-yyyy-mm-dd/367239/1 "2024-09-27T10:58:29Z")

</div>

My cluster is raising the following error every day - this is a single node cluster using all default settings. I have enabled stack monitoring in Kibana.

Looking to understand the cause an stop this error from being raised.

```auto
[2024-09-27T02:00:00,113][ERROR][o.e.x.m.e.l.LocalExporter] [my-cluster] failed to delete indices
org.elasticsearch.index.IndexNotFoundException: no such index [.monitoring-kibana-7-2024.09.20]
     at org.elasticsearch.cluster.metadata.Metadata.getIndexSafe(Metadata.java:1248) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.cluster.metadata.MetadataDeleteIndexService.deleteIndices(MetadataDeleteIndexService.java:98) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.cluster.metadata.MetadataDeleteIndexService$1.executeTask(MetadataDeleteIndexService.java:65) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.cluster.metadata.MetadataDeleteIndexService$1.executeTask(MetadataDeleteIndexService.java:59) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.cluster.SimpleBatchedAckListenerTaskExecutor.execute(SimpleBatchedAckListenerTaskExecutor.java:63) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.cluster.service.MasterService.innerExecuteTasks(MasterService.java:1039) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.cluster.service.MasterService.executeTasks(MasterService.java:1004) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.cluster.service.MasterService.executeAndPublishBatch(MasterService.java:232) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.cluster.service.MasterService$BatchingTaskQueue$Processor.lambda$run$2(MasterService.java:1645) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.action.ActionListener.run(ActionListener.java:356) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.cluster.service.MasterService$BatchingTaskQueue$Processor.run(MasterService.java:1642) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.cluster.service.MasterService$5.lambda$doRun$0(MasterService.java:1237) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.action.ActionListener.run(ActionListener.java:356) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.cluster.service.MasterService$5.doRun(MasterService.java:1216) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:984) ~[elasticsearch-8.14.2.jar:?]
     at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:26) ~[elasticsearch-8.14.2.jar:?]
     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1144) ~[?:?]
     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:642) ~[?:?]
     at java.lang.Thread.run(Thread.java:1570) ~[?:?]

```

Here's the result of GET \_cat/indices/.monitoring-kibana\*:

```auto
green open .monitoring-kibana-7-2024.09.27 Wj4A_HjdTLi1NUsseB0a_Q 1 0 7936 0 3.1mb 3.1mb 3.1mb
green open .monitoring-kibana-7-2024.09.26 whAsQFPUTQWM721SOHyOcg 1 0 17280 0 7.3mb 7.3mb 7.3mb
green open .monitoring-kibana-7-2024.09.25 eDBvrFZyQ6aHtNMYEeiQIg 1 0 17278 0 7.1mb 7.1mb 7.1mb
green open .monitoring-kibana-7-2024.09.24 TtKMuN89Toyx0j6GKDpgrw 1 0 17280 0 7.2mb 7.2mb 7.2mb
green open .monitoring-kibana-7-2024.09.23 etxAm29KS4mLaPhRqIYnxQ 1 0 17280 0 7.1mb 7.1mb 7.1mb
green open .monitoring-kibana-7-2024.09.22 s0ALRy9qTCOPK0B2Dc6Twg 1 0 17280 0 7mb 7mb 7mb
green open .monitoring-kibana-7-2024.09.21 Wfgkzep4SMGZh3SiGwPoXA 1 0 17280 0 7.1mb 7.1mb 7.1mb

```

Many thanks
