# Error of ELK stack memory overflow on Windows Server 2012

**URL:** <https://discuss.elastic.co/t/error-of-elk-stack-memory-overflow-on-windows-server-2012/330518>\
**Category:** Elasticsearch\
**Tags:** docker\
**Created:** [April 21, 2023, 11:46am UTC](https://discuss.elastic.co/t/error-of-elk-stack-memory-overflow-on-windows-server-2012/330518 "2023-04-21T11:46:19Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![DuanTran](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/duantran/32/120074_2.png) [@DuanTran](https://discuss.elastic.co/u/DuanTran)\
**Post date:** [April 21, 2023, 11:46am UTC](https://discuss.elastic.co/t/error-of-elk-stack-memory-overflow-on-windows-server-2012/330518/1 "2023-04-21T11:46:19Z")

</div>

I am happy to meet everyone. I am currently in great need of help from Elastic experts. When using ELK on Windows Server 2012, the OpenJVM processes of Elasticsearch and Logstash occupy up to 80% of the system. I have been trying to find the cause for a week, even though I have configured the heapsize in the Elasticsearch config. I am wondering if it is because ELK running on Windows for a long time causes this issue.  
I apologize for not being able to show more due to our security policy. You can make your own assumptions. Thank you for your contribution and have a good day.

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/0/d/0d81eb81e5d4402b6b9c6f16fecd905e7b9207c0.jpeg)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [April 23, 2023, 10:38pm UTC](https://discuss.elastic.co/t/error-of-elk-stack-memory-overflow-on-windows-server-2012/330518/2 "2023-04-23T22:38:11Z")

</div>

Welcome to our community! 😃

Is this causing issues?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 21, 2023, 10:38pm UTC](https://discuss.elastic.co/t/error-of-elk-stack-memory-overflow-on-windows-server-2012/330518/3 "2023-05-21T22:38:14Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
