# Error on fleet-server install

**URL:** https://discuss.elastic.co/t/error-on-fleet-server-install/344346
**Category:** Elasticsearch
**Tags:** fleet
**Created:** [October 3, 2023, 8:25pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346 "2023-10-03T20:25:37Z")
**Posts on this page:** 15
**Page:** 1

<div class="post-metadata">

### Author: ![gustavoluza](https://avatars.discourse-cdn.com/v4/letter/g/d2c977/32.png) [@gustavoluza](https://discuss.elastic.co/u/gustavoluza)
#### Post date: [October 3, 2023, 8:25pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/1 "2023-10-03T20:25:37Z")

</div>

hi there,  
I'm trying to install fleet-server on a VM with CentOS 7.  
In this same VM I already have elasticsearch (8.9.0), logstash and kibana (version 8.6.1) installed.

To install I am using the commands below (advanced mode)

```auto
curl -L -O https://artifacts.elastic.co/downloads/beats/elastic-agent/elastic-agent-8.9.0-linux-x86_64.tar.gz
tar xzvf elastic-agent-8.9.0-linux-x86_64.tar.gz
cd elastic-agent-8.9.0-linux-x86_64
sudo ./elastic-agent install --url=https://my_url.com:8220 \
  --fleet-server-es=https://my_url.com:9200 \
  --fleet-server-service-token=XXXXXXXXXXXXXXXXXXXXXXXXXXXXX \
  --fleet-server-policy=2c3db780-5244-11ee-b17f-317560648b1c \
  --certificate-authorities=/etc/certs/ca.crt \
  --fleet-server-es-ca=/etc/certs/ca.crt \
  --fleet-server-cert=/etc/certs/fleet.crt \
  --fleet-server-cert-key=/etc/certs/fleet.key 

```

also tried with --fleet-server-es-insecure flag

also tried with the command bellow

```auto
curl -L -O https://artifacts.elastic.co/downloads/beats/elastic-agent/elastic-agent-8.9.0-x86_64.rpm
sudo rpm -vi elastic-agent-8.9.0-x86_64.rpm
sudo elastic-agent enroll --url=https://apm.webmaissistemas.com.br:8220 \
  --fleet-server-es=https://my_urlr:9200 \
  --fleet-server-service-token=XXXXXXXXXXXXXXXXXXXXXXXXXX \
  --fleet-server-policy=2c3db780-5244-11ee-b17f-317560648b1c \
  --certificate-authorities=/etc/certs/ca.crt \
  --fleet-server-es-ca=/etc/certs/ca.crt \
  --fleet-server-cert=/etc/certs/fleet.crt \
  --fleet-server-cert-key=/etc/certs/fleet.key \
  --fleet-server-port=8220
sudo systemctl enable elastic-agent
sudo systemctl start elastic-agent

```

also tried with --fleet-server-es-insecure flag

in the Kibana interface I configured the fleet output and fleet server hosts like the image below

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/b/3/b3cee78176dcaccfef786bbcdc6b26136d3e3f7c.png)  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/4/b/4b5e67e83a6ccb5b0db50bdb05abae3edf59fa66.png)

on both installations I get errors

```auto
Error: enroll command failed with exit code: 1
Error: fleet-server failed: context canceled

```

if need full log, how to enable it?

thanks

---

<div class="post-metadata">

### Author: ![Julia\_Bardi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julia_bardi/32/79463_2.png) [@Julia\_Bardi](https://discuss.elastic.co/u/Julia_Bardi)
#### Post date: [October 9, 2023, 1:55pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/2 "2023-10-09T13:55:15Z")

</div>

Hello!

> elasticsearch (8.9.0), logstash and kibana (version 8.6.1)

This doesn't sound right, elasticsearch and kibana has to be on the same minor version, I think.

Is there any more output of the enroll command?

---

<div class="post-metadata">

### Author: ![gustavoluza](https://avatars.discourse-cdn.com/v4/letter/g/d2c977/32.png) [@gustavoluza](https://discuss.elastic.co/u/gustavoluza)
#### Post date: [October 9, 2023, 2:29pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/3 "2023-10-09T14:29:25Z")

</div>

Hello,

I will try to update kibana version, but, you think that it’s the problem? Kibana working fine… the problem is that I can’t install fleet.  
About the log error, that’s all that I have

Atenciosamente,

Gustavo Luza

---

<div class="post-metadata">

### Author: ![Julia\_Bardi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julia_bardi/32/79463_2.png) [@Julia\_Bardi](https://discuss.elastic.co/u/Julia_Bardi)
#### Post date: [October 9, 2023, 2:52pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/4 "2023-10-09T14:52:56Z")

</div>

You should be able to set the logging level in the `elastic-agent.yml` file:

`agent.logging.level: debug`

---

<div class="post-metadata">

### Author: ![gustavoluza](https://avatars.discourse-cdn.com/v4/letter/g/d2c977/32.png) [@gustavoluza](https://discuss.elastic.co/u/gustavoluza)
#### Post date: [October 9, 2023, 3:08pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/5 "2023-10-09T15:08:45Z")

</div>

I will try to enable it and after back with the results

Atenciosamente,

Gustavo Luza

---

<div class="post-metadata">

### Author: ![gustavoluza](https://avatars.discourse-cdn.com/v4/letter/g/d2c977/32.png) [@gustavoluza](https://discuss.elastic.co/u/gustavoluza)
#### Post date: [October 9, 2023, 6:49pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/6 "2023-10-09T18:49:25Z")

</div>

@Julia_Bardi

I updated the versions of Kibana, Elasticsearch and logstash, they are all running with the same version

![image](https://us1.discourse-cdn.com/elastic/original/3X/8/4/84548e983c249580cedddc6ed6cddf4900685153.png)

i tried to install fleet after the update, but still getting error,

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/c/1/c19f366cbd06a6ed520d5993b838b6eb6bc15613.png)

this is my elastic-agent.yml used on the installation folder, i need to change something here?

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/f/2/f23f21667348ebea1934c0c29a3663e56717cb48.png)

my log folder are empty

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/2/c/2c93a779918823845d1ea08bbcdbe9a2f04ff0f0.png)  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/5/a/5ac1e3994a39fdda8ceb23a66d4851dd2d02aca9.png)

in each new installation attempt I am ensuring that the token generated by the kibana interface is correct in the code I am using to attempt the installation

i hope that this information can help you

---

<div class="post-metadata">

### Author: ![Julia\_Bardi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julia_bardi/32/79463_2.png) [@Julia\_Bardi](https://discuss.elastic.co/u/Julia_Bardi)
#### Post date: [October 10, 2023, 7:49am UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/7 "2023-10-10T07:49:22Z")

</div>

Can you try to set the logging level to debug in `elastic-agent.yml` by inserting this line and check if there are more logs on install?  
`agent.logging.level: debug`

---

<div class="post-metadata">

### Author: ![gustavoluza](https://avatars.discourse-cdn.com/v4/letter/g/d2c977/32.png) [@gustavoluza](https://discuss.elastic.co/u/gustavoluza)
#### Post date: [October 10, 2023, 12:58pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/8 "2023-10-10T12:58:18Z")

</div>

I tried several ways to install, I set the logs to `agent.logging.level: debug`  
but it didn't generate any logs, do you know the reason for this behavior?

the only log that i see is this one, that are showed to me in terminal

```auto
{"log.level":"debug","@timestamp":"2023-10-10T09:59:50.895-0300","log.origin":{"file.name":"cmd/enroll_cmd.go","file.line":307},"message":"verifying communication with running Elastic Agent daemon","ecs.version":"1.6.0"}
{"log.level":"debug","@timestamp":"2023-10-10T09:59:55.541-0300","log.origin":{"file.name":"cmd/enroll_cmd.go","file.line":783},"message":"Waiting for Elastic Agent to start Fleet Server: STARTING - Starting","ecs.version":"1.6.0"}
{"log.level":"info","@timestamp":"2023-10-10T09:59:55.541-0300","log.origin":{"file.name":"cmd/enroll_cmd.go","file.line":806},"message":"Fleet Server - Starting","ecs.version":"1.6.0"}
{"log.level":"debug","@timestamp":"2023-10-10T09:59:59.542-0300","log.origin":{"file.name":"cmd/enroll_cmd.go","file.line":783},"message":"Waiting for Elastic Agent to start Fleet Server: STARTING - Starting","ecs.version":"1.6.0"}
{"log.level":"debug","@timestamp":"2023-10-10T10:00:07.545-0300","log.origin":{"file.name":"cmd/enroll_cmd.go","file.line":783},"message":"Waiting for Elastic Agent to start Fleet Server: STARTING - Starting","ecs.version":"1.6.0"}
{"log.level":"debug","@timestamp":"2023-10-10T10:00:23.546-0300","log.origin":{"file.name":"cmd/enroll_cmd.go","file.line":783},"message":"Waiting for Elastic Agent to start Fleet Server: STARTING - Starting","ecs.version":"1.6.0"}
{"log.level":"debug","@timestamp":"2023-10-10T10:00:55.552-0300","log.origin":{"file.name":"cmd/enroll_cmd.go","file.line":783},"message":"Waiting for Elastic Agent to start Fleet Server: STARTING - Starting","ecs.version":"1.6.0"}
Error: fleet-server failed: context canceled
For help, please see our troubleshooting guide at https://www.elastic.co/guide/en/fleet/8.9/fleet-troubleshooting.html
Error: enroll command failed with exit code: 1
For help, please see our troubleshooting guide at https://www.elastic.co/guide/en/fleet/8.9/fleet-troubleshooting.html

```

in my log folder i just have older logs

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/8/4/8431b551e0cdd0e112dee83a24e84061c2e71bf0.png)

---

<div class="post-metadata">

### Author: ![Julia\_Bardi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julia_bardi/32/79463_2.png) [@Julia\_Bardi](https://discuss.elastic.co/u/Julia_Bardi)
#### Post date: [October 10, 2023, 1:21pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/9 "2023-10-10T13:21:07Z")

</div>

I'm not sure about where agent logs should be, other than the stdout, asked the Agent team.

Could you check that the agent policy that you are using has a fleet\_server integration?  
It can be checked in kibana console with this ES query, the expected doc should have the inputs array populated.

```auto
GET .fleet-policies/_search?q=policy_id:2c3db780-5244-11ee-b17f-317560648b1c
{
  "size": 1, 
  "sort": [
    {
      "revision_idx": {
        "order": "desc"
      }
    }
  ]
}

```

---

<div class="post-metadata">

### Author: ![gustavoluza](https://avatars.discourse-cdn.com/v4/letter/g/d2c977/32.png) [@gustavoluza](https://discuss.elastic.co/u/gustavoluza)
#### Post date: [October 10, 2023, 1:44pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/10 "2023-10-10T13:44:01Z")

</div>

about the location of the logs, they are defined in this path `path: /var/log/elastic-agent` as default in my file `elastic-agent.yml` within the installation folder `/root/elastic-agent-8.10.3-linux-x86_64`

about fleet server integration, below are some screenshots of my configuration

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/2/4/24de0008e4d52b75df0a55641a24db87a537750d.png)  
 ![image](https://us1.discourse-cdn.com/elastic/original/3X/5/2/52963c2fc653af482c151b31fd92b627454be2c6.png)

````auto
id: 2c3db780-5244-11ee-b17f-317560648b1c
revision: 3
outputs:
  default:
    type: elasticsearch
    '0': s
    '1': s
    '2': l
    '3': .
    '4': c
    '5': e
    '6': r
    '7': t
    '8': i
    '9': f
    '10': i
    '11': c
    '12': a
    '13': t
    '14': e
    '15': _
    '16': a
    '17': u
    '18': t
    '19': h
    '20': o
    '21': r
    '22': i
    '23': t
    '24': i
    '25': e
    '26': s
    '27': ':'
    '28': '['
    '29': '"'
    '30': /
    '31': e
    '32': t
    '33': c
    '34': /
    '35': c
    '36': e
    '37': r
    '38': t
    '39': s
    '40': /
    '41': a
    '42': p
    '43': m
    '44': .
    '45': w
    '46': e
    '47': b
    '48': m
    '49': a
    '50': i
    '51': s
    '52': s
    '53': i
    '54': s
    '55': t
    '56': e
    '57': m
    '58': a
    '59': s
    '60': .
    '61': c
    '62': o
    '63': m
    '64': .
    '65': b
    '66': r
    '67': /
    '68': c
    '69': a
    '70': .
    '71': c
    '72': r
    '73': t
    '74': '"'
    '75': ']'
    hosts:
      - 'https://my_url.com.br:9200'
fleet:
  hosts:
    - 'https://my_url.com.br:8220'
output_permissions:
  default:
    _elastic_agent_monitoring:
      indices:
        - names:
            - logs-elastic_agent-default
            - logs-elastic_agent.elastic_agent-default
            - logs-elastic_agent.apm_server-default
            - logs-elastic_agent.filebeat-default
            - logs-elastic_agent.filebeat_input-default
            - logs-elastic_agent.fleet_server-default
            - logs-elastic_agent.metricbeat-default
            - logs-elastic_agent.osquerybeat-default
            - logs-elastic_agent.packetbeat-default
            - logs-elastic_agent.endpoint_security-default
            - logs-elastic_agent.auditbeat-default
            - logs-elastic_agent.heartbeat-default
            - logs-elastic_agent.cloudbeat-default
            - logs-elastic_agent.cloud_defend-default
            - metrics-elastic_agent-default
            - metrics-elastic_agent.elastic_agent-default
            - metrics-elastic_agent.apm_server-default
            - metrics-elastic_agent.filebeat-default
            - metrics-elastic_agent.filebeat_input-default
            - metrics-elastic_agent.fleet_server-default
            - metrics-elastic_agent.metricbeat-default
            - metrics-elastic_agent.osquerybeat-default
            - metrics-elastic_agent.packetbeat-default
            - metrics-elastic_agent.endpoint_security-default
            - metrics-elastic_agent.auditbeat-default
            - metrics-elastic_agent.heartbeat-default
            - metrics-elastic_agent.cloudbeat-default
            - metrics-elastic_agent.cloud_defend-default
          privileges:
            - auto_configure
            - create_doc
    _elastic_agent_checks:
      cluster:
        - monitor
    5b2b0dd8-2315-4edf-8bfc-1586dac01eb1:
      indices:
        - names:
            - logs-system.auth-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - logs-system.syslog-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - logs-system.application-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - logs-system.security-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - logs-system.system-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - metrics-system.cpu-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - metrics-system.diskio-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - metrics-system.filesystem-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - metrics-system.fsstat-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - metrics-system.load-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - metrics-system.memory-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - metrics-system.network-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - metrics-system.process-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - metrics-system.process.summary-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - metrics-system.socket_summary-default
          privileges:
            - auto_configure
            - create_doc
        - names:
            - metrics-system.uptime-default
          privileges:
            - auto_configure
            - create_doc
agent:
  download:
    sourceURI: 'https://artifacts.elastic.co/downloads/'
  monitoring:
    enabled: true
    use_output: default
    namespace: default
    logs: true
    metrics: true
  features: {}
  protection:
    enabled: false
    uninstall_token_hash: ''
    signing_key: >-
      MFkwEwYHKoZIzj0CAQYIKoZIzj0DAQcDQgAEAq6hlblwOAWsel2o5dt2iXn33s4+UX7SR2Q1iqvqbWimjMTl8KAamC8HiHyBCAqQb1Jt3NuMo38g4C7SODcLVg==
inputs:
  - id: fleet-server-fleet_server-a4448ce7-df1d-45e4-b047-99ee4b33384f
    name: fleet_server-2
    revision: 1
    type: fleet-server
    use_output: default
    meta:
      package:
        name: fleet_server
        version: 1.3.1
    data_stream:
      namespace: default
    package_policy_id: a4448ce7-df1d-45e4-b047-99ee4b33384f
    unused_key: not_used
  - id: logfile-system-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
    name: system-2
    revision: 1
    type: logfile
    use_output: default
    meta:
      package:
        name: system
        version: 1.19.5
    data_stream:
      namespace: default
    package_policy_id: 5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
    streams:
      - id: logfile-system.auth-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.auth
          type: logs
        ignore_older: 72h
        paths:
          - /var/log/auth.log*
          - /var/log/secure*
        exclude_files:
          - .gz$
        multiline:
          pattern: ^\s
          match: after
        tags:
          - hashicorp-vault-log
        processors:
          - add_locale: null
      - id: logfile-system.syslog-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.syslog
          type: logs
        paths:
          - /var/log/messages*
          - /var/log/syslog*
        exclude_files:
          - .gz$
        multiline:
          pattern: ^\s
          match: after
        processors:
          - add_locale: null
        ignore_older: 72h
  - id: winlog-system-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
    name: system-2
    revision: 1
    type: winlog
    use_output: default
    meta:
      package:
        name: system
        version: 1.19.5
    data_stream:
      namespace: default
    package_policy_id: 5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
    streams:
      - id: winlog-system.application-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        name: Application
        data_stream:
          dataset: system.application
          type: logs
        condition: '${host.platform} == ''windows'''
        ignore_older: 72h
      - id: winlog-system.security-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        name: Security
        data_stream:
          dataset: system.security
          type: logs
        condition: '${host.platform} == ''windows'''
        ignore_older: 72h
      - id: winlog-system.system-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        name: System
        data_stream:
          dataset: system.system
          type: logs
        condition: '${host.platform} == ''windows'''
        ignore_older: 72h
  - id: system/metrics-system-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
    name: system-2
    revision: 1
    type: system/metrics
    use_output: default
    meta:
      package:
        name: system
        version: 1.19.5
    data_stream:
      namespace: default
    package_policy_id: 5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
    streams:
      - id: system/metrics-system.cpu-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.cpu
          type: metrics
        metricsets:
          - cpu
        cpu.metrics:
          - percentages
          - normalized_percentages
        period: 10s
      - id: system/metrics-system.diskio-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.diskio
          type: metrics
        metricsets:
          - diskio
        diskio.include_devices: null
        period: 10s
      - id: system/metrics-system.filesystem-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.filesystem
          type: metrics
        metricsets:
          - filesystem
        period: 1m
        processors:
          - drop_event.when.regexp:
              system.filesystem.mount_point: ^/(sys|cgroup|proc|dev|etc|host|lib|snap)($|/)
      - id: system/metrics-system.fsstat-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.fsstat
          type: metrics
        metricsets:
          - fsstat
        period: 1m
        processors:
          - drop_event.when.regexp:
              system.fsstat.mount_point: ^/(sys|cgroup|proc|dev|etc|host|lib|snap)($|/)
      - id: system/metrics-system.load-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.load
          type: metrics
        metricsets:
          - load
        condition: '${host.platform} != ''windows'''
        period: 10s
      - id: system/metrics-system.memory-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.memory
          type: metrics
        metricsets:
          - memory
        period: 10s
      - id: system/metrics-system.network-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.network
          type: metrics
        metricsets:
          - network
        period: 10s
        network.interfaces: null
      - id: system/metrics-system.process-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.process
          type: metrics
        metricsets:
          - process
        period: 10s
        process.include_top_n.by_cpu: 5
        process.include_top_n.by_memory: 5
        process.cmdline.cache.enabled: true
        process.cgroups.enabled: false
        process.include_cpu_ticks: false
        processes:
          - .*
      - id: >-
          system/metrics-system.process.summary-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.process.summary
          type: metrics
        metricsets:
          - process_summary
        period: 10s
      - id: >-
          system/metrics-system.socket_summary-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.socket_summary
          type: metrics
        metricsets:
          - socket_summary
        period: 10s
      - id: system/metrics-system.uptime-5b2b0dd8-2315-4edf-8bfc-1586dac01eb1
        data_stream:
          dataset: system.uptime
          type: metrics
        metricsets:
          - uptime
        period: 10s
signed:
  data: >-
    eyJpZCI6IjJjM2RiNzgwLTUyNDQtMTFlZS1iMTdmLTMxNzU2MDY0OGIxYyIsImFnZW50Ijp7ImZlYXR1cmVzIjp7fSwicHJvdGVjdGlvbiI6eyJlbmFibGVkIjpmYWxzZSwidW5pbnN0YWxsX3Rva2VuX2hhc2giOiIiLCJzaWduaW5nX2tleSI6Ik1Ga3dFd1lIS29aSXpqMENBUVlJS29aSXpqMERBUWNEUWdBRUFxNmhsYmx3T0FXc2VsMm81ZHQyaVhuMzNzNCtVWDdTUjJRMWlxdnFiV2ltak1UbDhLQWFtQzhIaUh5QkNBcVFiMUp0M051TW8zOGc0QzdTT0RjTFZnPT0ifX0sImlucHV0cyI6W3siaWQiOiJmbGVldC1zZXJ2ZXItZmxlZXRfc2VydmVyLWE0NDQ4Y2U3LWRmMWQtNDVlNC1iMDQ3LTk5ZWU0YjMzMzg0ZiIsIm5hbWUiOiJmbGVldF9zZXJ2ZXItMiIsInJldmlzaW9uIjoxLCJ0eXBlIjoiZmxlZXQtc2VydmVyIn0seyJpZCI6ImxvZ2ZpbGUtc3lzdGVtLTViMmIwZGQ4LTIzMTUtNGVkZi04YmZjLTE1ODZkYWMwMWViMSIsIm5hbWUiOiJzeXN0ZW0tMiIsInJldmlzaW9uIjoxLCJ0eXBlIjoibG9nZmlsZSJ9LHsiaWQiOiJ3aW5sb2ctc3lzdGVtLTViMmIwZGQ4LTIzMTUtNGVkZi04YmZjLTE1ODZkYWMwMWViMSIsIm5hbWUiOiJzeXN0ZW0tMiIsInJldmlzaW9uIjoxLCJ0eXBlIjoid2lubG9nIn0seyJpZCI6InN5c3RlbS9tZXRyaWNzLXN5c3RlbS01YjJiMGRkOC0yMzE1LTRlZGYtOGJmYy0xNTg2ZGFjMDFlYjEiLCJuYW1lIjoic3lzdGVtLTIiLCJyZXZpc2lvbiI6MSwidHlwZSI6InN5c3RlbS9tZXRyaWNzIn1dfQ==
  signature: >-
    MEYCIQD4OFhX4H7d54NRDBNrbvbnOJzikLMnGY/RON8T3Ke1owIhAPHyIhikNBbnj3oqQOEBlJ900IOGdyfTLmex3AcFJ1Rt
secret_references: []```
````

---

<div class="post-metadata">

### Author: ![Julia\_Bardi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julia_bardi/32/79463_2.png) [@Julia\_Bardi](https://discuss.elastic.co/u/Julia_Bardi)
#### Post date: [October 10, 2023, 2:52pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/11 "2023-10-10T14:52:31Z")

</div>

The agent policy looks good, so I'm out of ideas why the enrollment doesn't succeed.

---

<div class="post-metadata">

### Author: ![gustavoluza](https://avatars.discourse-cdn.com/v4/letter/g/d2c977/32.png) [@gustavoluza](https://discuss.elastic.co/u/gustavoluza)
#### Post date: [October 10, 2023, 5:21pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/12 "2023-10-10T17:21:29Z")

</div>

sure... thats bad news...

---

<div class="post-metadata">

### Author: ![Julia\_Bardi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/julia_bardi/32/79463_2.png) [@Julia\_Bardi](https://discuss.elastic.co/u/Julia_Bardi)
#### Post date: [October 11, 2023, 1:24pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/13 "2023-10-11T13:24:43Z")

</div>

I found a similar discuss thread where they have used the linux tar gz to install fleet-server: [Elastic agent fails to install on Centos 7 - #2 by stephenb](https://discuss.elastic.co/t/elastic-agent-fails-to-install-on-centos-7/329260/2)  
Could you try again with that and see if there are any more logs in stdout or in `/opt/Elastic/Agent/ `?

---

<div class="post-metadata">

### Author: ![gustavoluza](https://avatars.discourse-cdn.com/v4/letter/g/d2c977/32.png) [@gustavoluza](https://discuss.elastic.co/u/gustavoluza)
#### Post date: [October 11, 2023, 5:54pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/14 "2023-10-11T17:54:34Z")

</div>

i tried again to install, but still getting the same error.  
when i check `journalctl -u elastic-agent` i can see this "log"

```auto
Oct 11 14:42:03 elk systemd[1]: Started Elastic Agent is a unified agent to observe, monitor and protect your system..
Oct 11 14:42:03 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:03.568-0300","log.origin":{"file.name":"cmd/run.go","file.line":154},"message":"Elastic Agent started","log":{"source":"elastic-agent"},"process.pid"
Oct 11 14:42:03 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:03.568-0300","log.origin":{"file.name":"migration/migrate_config.go","file.line":35},"message":"checking stat of enc config \"/opt/Elastic/Agent/fle
Oct 11 14:42:03 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:03.568-0300","log.origin":{"file.name":"migration/migrate_config.go","file.line":36},"message":"checking stat of unenc config \"/opt/Elastic/Agent/f
Oct 11 14:42:03 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:03.568-0300","log.origin":{"file.name":"migration/migrate_config.go","file.line":35},"message":"checking stat of enc config \"/opt/Elastic/Agent/dat
Oct 11 14:42:03 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:03.568-0300","log.origin":{"file.name":"migration/migrate_config.go","file.line":36},"message":"checking stat of unenc config \"/opt/Elastic/Agent/d
Oct 11 14:42:03 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:03.788-0300","log.origin":{"file.name":"upgrade/rollback.go","file.line":113},"message":"agent is not upgradable, not starting watcher","log":{"sourc
Oct 11 14:42:03 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:03.788-0300","log.origin":{"file.name":"cmd/run.go","file.line":241},"message":"APM instrumentation disabled","log":{"source":"elastic-agent"},"ecs.v
Oct 11 14:42:03 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:03.789-0300","log.origin":{"file.name":"application/application.go","file.line":61},"message":"Gathered system information","log":{"source":"elastic-
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.077-0300","log.origin":{"file.name":"application/application.go","file.line":67},"message":"Detected available inputs and outputs","log":{"source"
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.077-0300","log.origin":{"file.name":"capabilities/capabilities.go","file.line":48},"message":"Capabilities file not found in /opt/Elastic/Agent/ca
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.077-0300","log.origin":{"file.name":"application/application.go","file.line":73},"message":"Determined allowed capabilities","log":{"source":"elas
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.275-0300","log.origin":{"file.name":"application/application.go","file.line":130},"message":"Parsed configuration and determined agent is managed 
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.275-0300","log.origin":{"file.name":"application/application.go","file.line":138},"message":"Reloading of configuration is on, frequency is set t
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.278-0300","log.logger":"api","log.origin":{"file.name":"api/server.go","file.line":74},"message":"Starting stats endpoint","log":{"source":"elasti
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.279-0300","log.logger":"api","log.origin":{"file.name":"api/server.go","file.line":76},"message":"Metrics endpoint listening on: 127.0.0.1:6791 (c
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.279-0300","log.logger":"composable","log.origin":{"file.name":"composable/controller.go","file.line":112},"message":"Starting controller for comp
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.279-0300","log.logger":"composable","log.origin":{"file.name":"composable/controller.go","file.line":155},"message":"Started controller for compo
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.279-0300","log.logger":"composable","log.origin":{"file.name":"composable/controller.go","file.line":191},"message":"Variable state changed for c
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.279-0300","log.logger":"docker","log.origin":{"file.name":"docker/client.go","file.line":49},"message":"Docker client will negotiate the API vers
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.279-0300","log.logger":"composable","log.origin":{"file.name":"kubernetessecrets/kubernetes_secrets.go","file.line":97},"message":"Kubernetes_sec
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.280-0300","log.origin":{"file.name":"application/periodic.go","file.line":77},"message":"Adding 1 file to watch","log":{"source":"elastic-agent"}
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.280-0300","log.origin":{"file.name":"application/periodic.go","file.line":93},"message":"Configuration changes detected","log":{"source":"elastic-
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.280-0300","log.origin":{"file.name":"application/periodic.go","file.line":99},"message":"Updated 1 files: /opt/Elastic/Agent/elastic-agent.yml","
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.280-0300","log.logger":"composable.providers.docker","log.origin":{"file.name":"docker/docker.go","file.line":44},"message":"Docker provider skipp
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.281-0300","log.logger":"composable","log.origin":{"file.name":"kubernetesleaderelection/kubernetes_leaderelection.go","file.line":53},"message":"
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.281-0300","log.origin":{"file.name":"config/loader.go","file.line":45},"message":"Loaded configuration from /opt/Elastic/Agent/elastic-agent.yml"
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.281-0300","log.origin":{"file.name":"config/loader.go","file.line":57},"message":"Merged configuration from /opt/Elastic/Agent/elastic-agent.yml 
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.281-0300","log.origin":{"file.name":"config/loader.go","file.line":64},"message":"Merged all configuration files from [/opt/Elastic/Agent/elastic
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.281-0300","log.logger":"composable.providers.kubernetes","log.origin":{"file.name":"kubernetes/kubernetes.go","file.line":106},"message":"Kuberne
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.281-0300","log.logger":"composable.providers.kubernetes","log.origin":{"file.name":"kubernetes/kubernetes.go","file.line":106},"message":"Kuberne
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.282-0300","log.origin":{"file.name":"upgrade/upgrade.go","file.line":99},"message":"Source URI reset from \"https://artifacts.elastic.co/downloads
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.380-0300","log.logger":"composable","log.origin":{"file.name":"composable/controller.go","file.line":207},"message":"Computing new variable state
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.382-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1063},"message":"Continue with missing \"signed\" properties: policy
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.382-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1071},"message":"Updating running component model","log":{"source":"e
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.383-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1072},"message":"Updating running component model","log":{"source":"
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.503-0300","log.logger":"composable","log.origin":{"file.name":"composable/controller.go","file.line":191},"message":"Variable state changed for c
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.603-0300","log.logger":"composable","log.origin":{"file.name":"composable/controller.go","file.line":207},"message":"Computing new variable state
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.662-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1247},"message":"Spawned new component system/metrics-default: Starti
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.662-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1247},"message":"Spawned new unit system/metrics-default-unique-syste
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.662-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1247},"message":"Spawned new unit system/metrics-default: Starting: s
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.967-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1247},"message":"Spawned new component http/metrics-monitoring: Start
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.968-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1247},"message":"Spawned new unit http/metrics-monitoring-metrics-mon
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.968-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1247},"message":"Spawned new unit http/metrics-monitoring: Starting: 
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.974-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1063},"message":"Continue with missing \"signed\" properties: policy
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.974-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1071},"message":"Updating running component model","log":{"source":"e
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:04.976-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1072},"message":"Updating running component model","log":{"source":"
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.976-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1247},"message":"Spawned new component filestream-monitoring: Startin
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.976-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1247},"message":"Spawned new unit filestream-monitoring-filestream-mo
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.976-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1247},"message":"Spawned new unit filestream-monitoring: Starting: sp
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.976-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1247},"message":"Spawned new component beat/metrics-monitoring: Start
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.976-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1247},"message":"Spawned new unit beat/metrics-monitoring: Starting: 
Oct 11 14:42:04 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:04.976-0300","log.origin":{"file.name":"coordinator/coordinator.go","file.line":1247},"message":"Spawned new unit beat/metrics-monitoring-metrics-mon
Oct 11 14:42:06 elk elastic-agent[1800]: {"log.level":"info","@timestamp":"2023-10-11T14:42:06.166-0300","log.origin":{"file.name":"cmd/run.go","file.line":301},"message":"reexec shutdown channel triggered","log":{"source":"elastic-agent"},"
Oct 11 14:42:06 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:06.166-0300","log.logger":"composable","log.origin":{"file.name":"composable/controller.go","file.line":159},"message":"Stopping controller for comp
Oct 11 14:42:06 elk elastic-agent[1800]: {"log.level":"debug","@timestamp":"2023-10-11T14:42:06.166-0300","log.logger":"composable","log.origin":{"file.name":"composable/controller.go","file.line":188},"message":"Stopped controller for compo
Oct 11 14:44:06 elk systemd[1]: Stopping Elastic Agent is a unified agent to observe, monitor and protect your system....
Oct 11 14:44:06 elk systemd[1]: Stopped Elastic Agent is a unified agent to observe, monitor and protect your system..

```

the /opt/Elastic/Agent/ directory does not exist, I tried to create it manually and after running the installation it was removed

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [November 8, 2023, 5:54pm UTC](https://discuss.elastic.co/t/error-on-fleet-server-install/344346/15 "2023-11-08T17:54:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
