# Error on pipeline configuration with Java plugin

**URL:** <https://discuss.elastic.co/t/error-on-pipeline-configuration-with-java-plugin/196484>\
**Category:** Logstash\
**Created:** [August 23, 2019, 9:52am UTC](https://discuss.elastic.co/t/error-on-pipeline-configuration-with-java-plugin/196484 "2019-08-23T09:52:56Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![DottorP](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dottorp/32/52891_2.png) [@DottorP](https://discuss.elastic.co/u/DottorP)\
**Post date:** [August 23, 2019, 9:52am UTC](https://discuss.elastic.co/t/error-on-pipeline-configuration-with-java-plugin/196484/1 "2019-08-23T09:52:56Z")

</div>

Hi. I wrote a filter plugin in Java named _blob\_to\_clob\_filter_. When using it in a pipeline I get the following error:  
[2019-08-23T11:20:38,254][DEBUG][logstash.plugins.registry] On demand adding plugin to the registry {:name=\>"blob\_to\_clob\_filter", :type=\>"filter", :class=\>LogStash::Filters::BlobToClobFilter}  
[2019-08-23T11:20:38,285][FATAL][logstash.runner] The given configuration is invalid. Reason: java.lang.reflect.InvocationTargetException  
[2019-08-23T11:20:38,300][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit  
The main class implements co.elastic.logstash.api.Filter  
When running it in another machine i get  
[2019-08-23T11:47:14,859][FATAL][logstash.runner] The given configuration is invalid. Reason: Cannot start the Java plugin 'blob\_to\_clob\_filter' in the Ruby execution engine. The Java execution engine is required to run Java plugins.  
[2019-08-23T11:47:14,884][ERROR][org.logstash.Logstash] java.lang.IllegalStateException: Logstash stopped processing because of an error: (SystemExit) exit  
So maybe I have the same issue on the two machines.  
How can I install the execution engine? One of the two machines has no internet access.

EDIT: it was a bug on the "Test and exit" mode, according to this topic on GitHub:

> <https://github.com/logstash-plugins/logstash-filter-java_filter_example/issues/11>

---

<div class="post-metadata">

**Author:** ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)\
**Post date:** [August 23, 2019, 1:58pm UTC](https://discuss.elastic.co/t/error-on-pipeline-configuration-with-java-plugin/196484/2 "2019-08-23T13:58:56Z")

</div>

> [@DottorP](#):
>
> The Java execution engine is required to run Java plugins.

The java execution engine is enable by 'pipeline.java\_execution: true' in logstash.yml (assuming you have a logstash version new enough to support it). It is on by default in v7.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 20, 2019, 1:59pm UTC](https://discuss.elastic.co/t/error-on-pipeline-configuration-with-java-plugin/196484/3 "2019-09-20T13:59:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
